Вход | Регистрация

1С:Предприятие ::

Метки:Встроенный язык

Как сделать, чтобы 1С-ка проверяла Если Контрагент.Код = dbf.TEL.Значение

Я
   cat
 
16.08.04 - 14:50
Есть dbf.файл = у него поле "TEL" и поле "PT"
есть в 1С-е справочник Контрагентов у него поле "Код"
Как сделать, чтобы 1c проверяла Если Контрагент.Код = dbf.TEL.Значение
Тогда Создать запись в dbf.PT в виде *
 
 
   427
 
1 - 16.08.04 - 14:52
Так и делай. Правильно пишешь....
   Guk
 
2 - 16.08.04 - 14:52
dbf.TEL.Значение
???
   Волшебник
 
3 - 16.08.04 - 14:54
для числового кода:
Если Число(Контрагент.Код) = Число(dbf.TEL) Тогда

или для текстового кода:

Если СокрЛП(Контрагент.Код) = СокрЛП(dbf.TEL) Тогда

Про работу с DBF написано здесь:
http://www.mista.ru/tutor_1c/dbf.htm
   cat
 
4 - 16.08.04 - 15:14
а как создать эту запись? в виде *
   Волшебник
 
5 - 16.08.04 - 15:14
Что такое "в виде *" ?
   cat
 
6 - 16.08.04 - 15:21
ну запись в dbf  = в поле TEL = "*"
   cat
 
7 - 16.08.04 - 15:44
что не так понаделал?
Процедура ПроверкаФайла() 
СПР = СоздатьОбъект("Справочник.АбонентскиеТочки"); 
Контрагент = СоздатьОбъект("Справочник.Контрагенты");
Файл = СоздатьОбъект("XBase");
Файл.ОткрытьФайл("E:\Documents\МЕЖГОРОД\2004 год\Июнь 2004\Erl_04.dbf"); 

Если Файл.Открыта()=0 Тогда 
Сообщить("Не удалось открыть файл!");
КонецЕсли; 

Файл.Первая(); 
Пока Файл.ВКонце()=0 Цикл
НомерЗаписи = Файл.НомерЗаписи();
КодАбонента = Файл.TEL_A;
ПолеМетки = Файл.RT;      
Если СокрЛП(Контрагент.Код) = Число(Файл.TEL_A) Тогда 
    Иначе Продолжить;
Файл.Добавить();
Файл.RT = "*";
Файл.Записать(); 
    КонецЕсли;
Файл.Следующая(); 
КонецЦикла; 
Файл.ЗакрытьФайл();
КонецПроцедуры
   cat
 
8 - 16.08.04 - 15:45
только не ругайтесь сильно...
прошу просто указать на ошибки :0)
   barada
9 - 16.08.04 - 16:59
Если СокрЛП(Контрагент.Код) = Число(Файл.TEL_A) Тогда
   barada
10 - 16.08.04 - 17:05
и "продолжить" перед добавлением стоит то же не гут
 
 
   barada
11 - 16.08.04 - 17:09
// так попробуй

Если СокрЛП(Контрагент.Код) = СокрЛП(Файл.TEL_A) Тогда 
   Файл.Добавить(); 
   Файл.RT = "*"; 
   Файл.Записать(); 
Иначе
   Продолжить; 
КонецЕсли;


Список тем форума
Рекламное место пустует  
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует