Вход | Регистрация

1С:Предприятие ::

Метки:

Эл почта

Я
   vitaly
 
15.08.04 - 20:48
Пытаюсь отправить письмо из 1С при помощи v7plus/
Длаю вроде все правильно, но сервер почтовый выдает ошибку, что мол слишком длинный адрес. Если после этого посмотреть письмо в аутглюк експресс то адрес действительно очень длинный.
Проверил: в модуле адрес добавляеться нормальный.
 
  Рекламное место пустует
   Волшебник
 
1 - 15.08.04 - 20:54
Может быть СокрЛП тебе поможет?
   vitaly
 
2 - 15.08.04 - 21:33
Не помогает
я даже строго адре в модуле забивал.
иду отладчиком все намано (нормальный адрес)
а в письме длинный
   427
 
3 - 16.08.04 - 07:00
А чего он там добавляет? Полностью напиши...

P.S. чего то там такое было.....
   vitaly
 
4 - 16.08.04 - 09:48
После адреса пробелы стоят
   427
 
5 - 16.08.04 - 10:18
не нашел своей обработки, но вот работающая с АутГлюком процедура из учебно-методической конфы с ИТС

Процедура ПослатьПисьмо(Адрес, Заголовок="", Текст="", Файл="")
    Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "v7plus.dll") <> 1 Тогда
        Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "v7plus.dll") <> 1 Тогда
            Предупреждение("Ошибка загрузки компоненты v7plus.dll!");
            Возврат;
        КонецЕсли;        
    КонецЕсли;
    
    Попытка
        Почта = СоздатьОбъект("AddIn.V7Mail");
    Исключение 
        Предупреждение("Не удалось создать объект Addin.V7Mail!");
        Возврат;
    КонецПопытки;
    
    Попытка        
        Почта.Подключиться();
        Почта.НовоеСообщение();
                
        Если ПустоеЗначение(Адрес) = 1 Тогда
            Предупреждение("Не задан адрес получателя!");
            Возврат;
        Иначе
            СтрАдрес = ?(Лев(Адрес, 5)="SMTP:", Адрес, "SMTP:" + Адрес);
            Почта.ДобавитьАдрес(Адрес);            
        КонецЕсли;
        
        Если ПустаяСтрока(Файл) = 0 Тогда Почта.ДобавитьФайл(Файл) КонецЕсли;
        Почта.Заголовок        = Заголовок;
        Почта.Текст            = Текст;
        Почта.Послать();
        Почта.Отключиться();
        Предупреждение("Документ успешно отправлен!");
    Исключение
        Предупреждение("Неудачная попытка! Отправка документа по почте не произведена!");
    КонецПопытки;
КонецПроцедуры
   vitaly
 
6 - 16.08.04 - 10:42
На ИТС посмотреть я не догадался.
Но тем не менее процедура точно такая же, слово в слово.
Она находиться в конфе писанной не мной, я с ней тока разбираюсь.
Проблема видимо гдето не в модуле.
Теперь я это тоже понял, после мороки вчера ночью.
Буду говорить с админом, может от что то подскажет.
Спасибо за отзывы!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует