Вход | Регистрация

1С:Предприятие ::

Метки:регистры

Регистры

Я
   Alexxx
 
13.08.04 - 22:00
Чем можно заменить следующий код? (Выводит количество реализованного товара.)
    Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл  
        Если Склад1.Выбран()=1 Тогда 
            Рег.УстановитьФильтр(Товар,Склад1);
        Иначе    
            Рег.УстановитьФильтр(Товар);
        КонецЕсли;  
        Пока Рег.ПолучитьДвижение()=1 Цикл 
            Если (Рег.Расход=1) и (Рег.ТекущийДокумент().Вид()="РасходнаяНакладная") Тогда 
                КолРасхода=КолРасхода+Рег.ОстатокТовара;
            КонецЕсли; 
        КонецЦикла; 
    КонецЦикла;
 
 
   Матрейя
 
1 - 13.08.04 - 22:31
Это не код. Лучше поясни задачу.
   Alexxx
 
2 - 14.08.04 - 20:07
Для каждого товара, уже забитого в документе нужно найти количество его расхода за к.-л. период.
   ОбезьянаСГранатой
3 - 14.08.04 - 20:55
и чо?
   Матрейя
 
4 - 14.08.04 - 21:23
Перем Тз;

Функция РасходПоНоменклатуре(ЭлНом)
    ТекСтр="";
    Если Тз.НайтиЗначение(ЭлНом,ТекСтр,1)=1 Тогда
        Возврат (Тз.ПолучитьЗначение(ТекСтр,2);
    КонецЕсли;
    Возврат(0);    
КонецФункции    

Процедура ПосчитатьРасход()
    Спис=СоздатьОбъект("СписокЗначений");
    Тз=СоздатьОбъект("ТаблицаЗначений"); 
    ВыгрузитьТабличнуюЧасть(Спис,"Номенклатура");   
    НачПериода=НачМесяца(ДатаДок);
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с НачПериода по ДатаДок;
    |Без итогов;
    |_Склад = Регистр.ОстаткиТМЦ.Склад;
    |_Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
    |_Количество = Регистр.ОстаткиТМЦ.Количество;
    |_ТекущийДокумент = Регистр.ОстаткиТМЦ.ТекущийДокумент;
    |Функция Расход = Расход(_Количество) когда (_ТекущийДокумент.Вид()=""Реализация"");
    |Группировка _Номенклатура без групп;
    |Условие(_Склад в Склад);
    |Условие(_Номенклатура в Спис);
    |";  
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    Запрос.Выгрузить(Тз,"_Номенклатура(1),Расход");
КонецПроцедуры
   NS
 
5 - 14.08.04 - 21:55
(4) А не лучше ли брать продажи из оборотного регистра продажи?
   Матрейя
 
6 - 14.08.04 - 21:58
5.Откуда я знаю, что у него за конфигурация? И есть ли там оборотный регистр.


Список тем форума
  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует