Вход | Регистрация


1С:Предприятие ::

Метки:УПП

Не могу провести документ в УПП - "Запись не верна!: (1)

Я
   fixin
 
17.02.05 - 11:18
Провожу документ "Прием к учету объекта строительства". Выдается такая ошибка.
Я думаю, что дело в том, что запись регистра не верна. Как понять, это первая запись или что?
 
  Рекламное место пустует
   fixin
 
1 - 17.02.05 - 11:31
Блин, это недоделанное УПП не проставляет Регистратор по ГрафикуАмортизации. Как они тестируют свои программы в 1С?
Я хочу вставить в конец модуля заплатку, которая будет проставлять регистратор у тех регистров, которым нужен регистратор (если регистратор не проставлен).
Сделаю это универсальной функцией.
   Ядрена Матрена
2 - 17.02.05 - 11:32
Генитально!!!
зы. Мне нравится образ Вашего мышления...
   fixin
 
3 - 17.02.05 - 11:48
(2) Это ерония?
   француз
 
4 - 17.02.05 - 11:53
(3) скорее, ирония
   Ядрена Матрена
5 - 17.02.05 - 11:56
Вы оба не правы. Это эрония.
   fixin
 
6 - 17.02.05 - 12:01
Блин, хотел бросить код, но сработал антимат

Функция ДвиженияДокументаПроставитьРегистратор(Ссылка, Движения, Записать=истина) Экспорт
   fixin
 
7 - 17.02.05 - 12:02
Перем Движение, НЗ, НуженРегистратор;
   fixin
 
8 - 17.02.05 - 12:02
Для Каждого НЗ из Движения Цикл
   fixin
 
9 - 17.02.05 - 12:03
Модифицированность=ложь;
        МД=НЗ.Метаданные();
       Если МД.РежимЗаписиРегистра=Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору Тогда
           Для Каждого Движение Из Движение Цикл                Если Движение.Регистратор=Неопределено Тогда
                    Движение.Регистратор=ССылка;
                    Модифицированность=Истина;
                КонецЕсли;
            КонецЦикла
        КонецЕсли
    КонецЦикла;
    Если Модифицированность И Записать Тогда
        Движения.Записать();
    КонецЕсли;
    Возврат Модифицированность;
КонецФункции
   fixin
 
10 - 17.02.05 - 12:03
Гыгыгы, а вот антимат был на:
 
  Рекламное место пустует
   fixin
 
11 - 17.02.05 - 12:04
//
   fixin
 
12 - 17.02.05 - 12:04
П-е$-р-е$б$и$р$а$е$м
Волшебник, я вас умоляю, он ругнулся на слог Е Б $
Но это же не правильно!
   fixin
 
13 - 17.02.05 - 12:05
Короче функция такая:


Функция ДвиженияДокументаПроставитьРегистратор(Ссылка, Движения, Записать=истина) Экспорт
    Перем Движение, НЗ, НуженРегистратор;
    Для Каждого НЗ из Движения Цикл 
        Модифицированность=ложь;
        МД=НЗ.Метаданные();
        Если МД.РежимЗаписиРегистра=Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору Тогда
            Для Каждого Движение Из Движение Цикл 
                Если Движение.Регистратор=Неопределено Тогда
                    Движение.Регистратор=ССылка;
                    Модифицированность=Истина;
                КонецЕсли;
            КонецЦикла
        КонецЕсли
    КонецЦикла;
    Если Модифицированность И Записать Тогда
        Движения.Записать();
    КонецЕсли;
    Возврат Модифицированность;
КонецФункции
   SKrin
 
14 - 17.02.05 - 12:10
было такое, если происходит запись движение в регистры, а какой-то реквизит или измерение (которое указано в регистрах для обязательного заполнения) не заполнено в документе
   fixin
 
15 - 17.02.05 - 12:10
Пардон, условие должно быть таким:
Если  МД.РежимЗаписи=Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору Тогда
   Пролд
 
16 - 17.02.05 - 12:11
перебираем
   Пролд
 
17 - 17.02.05 - 12:12
(12) У тебя руки кривые.
Еще раз: Переёбираем
   fixin
 
18 - 17.02.05 - 14:28
(16) английским балуетесь?
Я ошибся, регистратор указывать не обязательно.
Просто платформа глюкнула - именно этот документ не хотел проводиться, я его скопировал - все провелося
   Кабан мимо пробеган
 
19 - 17.02.05 - 18:44
А что нам скажет Волшебник? Неужели он ни разу не сталкивался с такой проблемой?
   fixin
 
20 - 17.02.05 - 19:17
реально проблема в том, что в балансовой проводке не был указан счет дебета...
(читай ветку про диагностику), уродские сообщения об ошибках у платформы 8.0
   SnarkHunter
 
21 - 17.02.05 - 20:49
Дело было не в бобине...
   француз
 
22 - 18.02.05 - 00:07
(20) 1с - "Традиционно виноваты - без аргументации" (с)...



Список тем форума
  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует