Вход | Регистрация

1С:Предприятие ::

Метки:

Как программно узнать, кто работает с конфигурацией?

Я
   Saper
 
06.01.04 - 11:32
Читал, что есть некий файл, в который 1С пишет кто вошел в конфигурацию, и кто вышел. Что это за файл и можно ли из наго вытащить информацию о текущих (или аварийно вышедших) пользователях?
 
 
   Saper
 
2 - 06.01.04 - 12:10
Я хочу автоматом отправлять сообщения всем, кто пользует нужную мне конфигурацию
   Львенок
 
3 - 06.01.04 - 12:20
(2) Я обычно делаю это через терминалы. tsadmin.exe запускаешь, выделяешь всех, кто на сервере и кидаешь им что-то вроде - "всех кто в такой-то базе прошу выйти на десять минут". Кстати удобно сделать константы ВыкинутьПользователей и КогоВыкинуть, и повесить в ОбработкуОжидания что-то вроде:

Процедура ВыкинутьПользователя()
    Если Константа.ВыкинутьПользователей<1 Тогда
        Возврат;
    КонецЕсли;
    КогоВыкинуть=Нрег(СокрЛП(Константа.КогоВыкинуть));
    Если (Нрег(ИмяПользователя())=КогоВыкинуть) Или (КогоВыкинуть="всех") Тогда
        Если Константа.ВыкинутьПользователей=1 Тогда
            ЗавершитьРаботуСистемы(1);
        КонецЕсли;
        Если Константа.ВыкинутьПользователей=2 Тогда
            ЗавершитьРаботуСистемы(0);
        КонецЕсли;                    
    КонецЕсли;
КонецПроцедуры
___
Искренне Ваш, Львенок.
   Saper
 
4 - 09.01.04 - 12:12
Я нашел этот файл - SYSLOG\links.tmp - здесь все входившие в конфу в текущем сеансе, а вышедших можно узнать из 1cv7.mlg
   345
5 - 09.01.04 - 17:13
Обломайся ...
при вылете юзеров - нет записи в млг... и лишние блокировки в links////


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует