Вход | Регистрация

1С:Предприятие ::

Метки:отчеты, Запросы и построители

Отчет бухг Запросом в разрезе итогов по периодам

Я
   Arelendil
 
12.08.04 - 13:15
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "70",,, 1,"месяц", "С");

По строкам вывожу субконто, по столбцам периоды (месяц).
Проблема в том, что не у каждого субконто есть результаты за конкретный период.
Получается например, у одного субконто есть сумма за все 12 месяцев, у другого только за 6.
И отчет выводится неровно. Таким зигзагом.
Как сделать так, чтобы при выборке периодов выбирались все по максимуму (или учитывались нулевые суммы).

К примеру в обычном запросе эта проблема решается так:
|Группировка Период все ВошедшиеВЗапрос;
 
  Рекламное место пустует
   laeg
 
1 - 12.08.04 - 13:33
А что если сначала в ТЗ вывести ?
   Старина Z
 
2 - 12.08.04 - 13:41
(0) ВыбратьПериоды(1) не спасет отца русской демократии?
   Press
 
3 - 12.08.04 - 13:43
Попробую угадать:
//*******************************************

//{{БУХГАЛТЕРСКИЙ ЗАПРОС(Сформировать)

//Данный фрагмент построен конструктором.

//При повторном использовании конструктора, внесенные вручную изменения будут потеряны!!!

//{{ Схема номер 6

//{{ ДтКт 1111110

Процедура Сформировать_Колонки(Ит, Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Ит.ВыбратьПериоды(1);
    Пока Ит.ПолучитьПериод() = 1 Цикл
        Таб.ПрисоединитьСекцию(Стр+"|Период");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Итог");
КонецПроцедуры

Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники,, 1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,"70",,, 1, "Месяц", "С");
    Таб.ВывестиСекцию("Заголовок");
    Сформировать_Колонки(Ит, Таб, "Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСубконто(ВидыСубконто.Сотрудники);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Сотрудники) = 1 Цикл
        Сформировать_Колонки(Ит, Таб, "Субконто1");
    КонецЦикла;
    Сформировать_Колонки(Ит, Таб, "Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
КонецПроцедуры
//}}БУХГАЛТЕРСКИЙ ЗАПРОС
   Arelendil
 
4 - 12.08.04 - 22:13
Мде... ума не хватило синтаксис-помошник посмотреть...
Спасибо
   Arelendil
 
5 - 12.08.04 - 22:44
Ещё вопрос:
как можно итоги бухгалтерского запроса выргужать в ТЗ.
Так просто: Ит.Выгрузить(ТЗ);??
   child
 
6 - 12.08.04 - 23:02
Не, так просто не получиться, нужно сначала описать структуру ТЗ, а потом выбрать итоги по запросу и построчно заносить их в ТЗ.
ЗЫ: Скока с бухией сталкивался, никогда ТЗ не пользовался.... Хотя мож у мя задачи другие были....


Список тем форума
 
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует