Вход | Регистрация

1С:Предприятие ::

Метки:

Вопрос по "ПринадлежитГруппе()"

Я
   Денис
12.08.04 - 08:38
наши=0;
всего=0;
ЭлементыГруппы=СоздатьОбъект("Справочник.Номенклатура");
ЭлементыГруппы.ВыбратьЭлементы();
   ЭлементыГруппы.НайтиПоНаименованию(Проект1.ТекущийЭлемент(),0);
   Группа=СокрП(Проект1.ТекущийЭлемент());
Док = СоздатьОбъект("Документ.Счет");
Док.ВыбратьДокументы(Дата1, Дата2);
Пока Док.ПолучитьДокумент() = 1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку() = 1 Цикл
        Если Док.Товар.ПринадлежитГруппе(ЭлементыГруппы.ТекущийЭлемент()) = 1 Тогда наши=наши+1 иначе всего=всего+1;
        КонецЕсли;
    КонецЦикла;     
КонецЦикла;    

Выдает наши=0, хотя есть удовлетворяющие условию. Где я не прав?

PS наши - удовлетворяющие условию, всего - всего строк обработано, Проект1 - группа в номенклатуре, выбирается в диалоге.
 
 
   shura
 
1 - 12.08.04 - 08:48
наши=0; 
всего=0; 
//ЭлементыГруппы=СоздатьОбъект("Справочник.Номенклатура"); 

//ЭлементыГруппы.ВыбратьЭлементы(); 
//  ЭлементыГруппы.НайтиПоНаименованию(Проект1.ТекущийЭлемент(),0); 

//  Группа=СокрП(Проект1.ТекущийЭлемент()); 
Док = СоздатьОбъект("Документ.Счет"); 
Док.ВыбратьДокументы(Дата1, Дата2); 
Пока Док.ПолучитьДокумент() = 1 Цикл 
   Док.ВыбратьСтроки(); 
   Пока Док.ПолучитьСтроку() = 1 Цикл 
       Если Док.Товар.ПринадлежитГруппе(Проект1) = 1 Тогда наши=наши+1 иначе всего=всего+1; 
       КонецЕсли; 
   КонецЦикла;     
КонецЦикла;
   427
 
2 - 12.08.04 - 08:50
==================================
Пока уходит почта...
==================================


Это что за .....я?

Группа=СокрП(Проект1.ТекущийЭлемент());

Как можно сократить ссылку? Если Проект1 - выбранная в диалоге группа - так и делай

перед циклом проверки

если Проект1.выбран()<> 1 тогда
    Идти искать крылья для бурундука

если Проект1.ЭтоГруппа()<> 1 тогда
    Идти искать крылья для бурундука


Если Док.Товар.ПринадлежитГруппе(Проект1) .... и далее
   maloy
 
3 - 12.08.04 - 08:50
Типа, надо бы проверять
ЭлементыГруппы.НайтиПоНаименованию(Проект1.ТекущийЭлемент(),0);
ентот метод возвращает чего-нибудь?
Проект1- элемент справочника "проекты"?
   maloy
 
4 - 12.08.04 - 08:52
Типа, надо бы проверять
ЭлементыГруппы.НайтиПоНаименованию(Проект1.ТекущийЭлемент(),0);
ентот метод возвращает чего-нибудь?
Проект1- элемент справочника "проекты"?
   maloy
 
5 - 12.08.04 - 08:53
блин, два раза ушло
   Денис
6 - 12.08.04 - 08:57
Проект1 - элемент "Справочник.Номенклатура"
Группа=СокрП(Проект1.ТекущийЭлемент()); - это для вывода на экран(пока правлю)
   Денис
7 - 12.08.04 - 09:15
Всем спасибо, код shura работает.
   maloy
 
8 - 12.08.04 - 09:20
Кранты. Если он элемент справочника "Номенклатура" то нафига ты его получаешь через наименование?
   tsd
 
9 - 12.08.04 - 09:57
(7) да не спасибо нужно говорить, а хотя бы пару раз открыть книгу и прочитать ее
   SnarkHunter
 
10 - 12.08.04 - 09:59
А зачем? Всегда можно задать здесь подобный вопрос и на протяжении пяти-восьми десятков постов пытаться упорно понять о чем идет речь...
 
  Рекламное место пустует
   Guk
 
11 - 12.08.04 - 10:08
(10) А что? Это же намного интереснее, чем думать...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует