Вход | Регистрация

1С:Предприятие ::

Метки:

УТ 11.1 Про ККМ и чеки и отчеты по ним..

Я
   Yuri Ro
 
12.01.18 - 22:22
Доброго времени суток, может сталкивался с таким, расскажите пожалуйста
Подключаю рабочее место кассира и фискальный регистратор без подключения  оборудования, далее...
В Розничные продажи-Чеки ККМ вижу то что продано, но в кассе есть возможность ОТЛОЖИТЬ или ПОСТАВИТЬ В РЕЗЕРВ, когда продавец это делает в Чеки ККМ или "отчет о розничных продажах" я вижу продажи, отложить и поставить в резерв, но как смена закрывается видны только продажи.
Как сделать так чтоб в Чеки ККМ и отчете о розничных продажах видеть и отложенные и поставленные в резерв и помеченные на удаление
 
 
   Yuri Ro
 
1 - 12.01.18 - 23:00
В документе ЧекиККМ нашел такой код
НаСервере
Функция ОтложитьНаСервере()
    
    ОтложитьВыполнено = Истина;
    
    СтарыйСтатус = Объект.Статус;
    Объект.Статус = Перечисления.СтатусыЧековККМ.Отложен;
    Объект.Дата = ТекущаяДата();
    
    Если ИспользоватьАвтоматическиеСкидкиВПродажах 
        И ПараметрыПримененияСкидок.НазначеныСкидки Тогда
        
        ОтменитьСкидкиНаценкиНаСервере();
        
    КонецЕсли;
    
    Попытка
        
        ОтложитьВыполнено = Записать(Новый Структура("РежимЗаписи, РежимПроведения", РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Оперативный));
        
        Если Не ОтложитьВыполнено Тогда
            Объект.Статус = СтарыйСтатус;
        КонецЕсли;
        
    Исключение
        
        Объект.Статус = СтарыйСтатус;
        ОтложитьВыполнено = Ложь;
        
    КонецПопытки;
    
    Возврат ОтложитьВыполнено;
    
КонецФункции

&НаКлиенте
Функция ОтменитьОплату()
    
    ОплатаОтменена = Ложь;
    
    Если ВнесенаОплата() Тогда
        
        РезультатВопроса = Вопрос(НСтр("ru = 'Перед выполнением операции оплата должна быть отменена. Продолжить?'"), РежимДиалогаВопрос.ДаНет);
        
        Если РезультатВопроса = КодВозвратаДиалога.Нет Тогда
            Возврат ОплатаОтменена;
        КонецЕсли;
        
    КонецЕсли;
    
    Для каждого СтрокаОплаты Из Объект.ОплатаПлатежнымиКартами Цикл
        УдалитьОплатуКартой(СтрокаОплаты);
    КонецЦикла;
    
    // Если отмена оплаты не удалась - вернутся.

    Если Объект.ОплатаПлатежнымиКартами.Количество() > 0 Тогда
        
        ПересчитатьДокументНаКлиенте();
        Возврат ОплатаОтменена;
        
    КонецЕсли;
    
    Объект.ПодарочныеСертификаты.Очистить();
    
    Объект.ФормаОплаты       = Неопределено;
    Объект.ПолученоНаличными = 0;
    
    ОплатаОтменена = Истина;
    
    Возврат ОплатаОтменена;
    
КонецФункции

&НаКлиенте
Функция ОтложитьИОтменитьОплатуНаКлиенте()
    
    Результат = ОтменитьОплату();
    
    Если Результат Тогда
        
        Объект.ОтложенДо = Дата(1,1,1);
        
        Результат = ОтложитьНаСервере();
        
        Если Результат Тогда
            Оповестить("Запись_ЧекККМ", Новый Структура, Объект.Ссылка);
        КонецЕсли;
        
        ПересчитатьДокументНаКлиенте();
        Элементы.Страницы.ТекущаяСтраница = Элементы.СтраницаТовары;
        
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции

Может тут кроется секрет?
   МимохожийОднако
 
2 - 12.01.18 - 23:03
Отключи удаление чеков при закрытии смены.
   Yuri Ro
 
3 - 14.01.18 - 19:05
Спасибо, нашел  в CRM и продажи - Розничные продажи - При закрытии смены архивировать чеки. Теперь видно отложенные и поставленные в резерв.
А как можно сделать чтоб администратор видел удаленные за день, и отмененные строки?


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует