Вход | Регистрация

1С:Предприятие ::

Метки:

Вывод горизонтального разделителя в табличном документе

Я
   furen23
 
12.01.18 - 12:53
Есть форма справочника, на форме расположен табличный документ.Нужно при установке курсора на определённую ячейку и при нажатии на кнопку на форме выводить после ячейки горизонтальный разделитель.

&НаКлиенте
Процедура ВставитьГоризонтальныйРазделитель(Команда)
    ВставитьГоризонтальныйРазделительНаСервере(ТабДокПроектДокумента,ТабДокПроектДокумента.ТекущаяОбласть.Имя);
КонецПроцедуры

&НаСервере
Процедура ВставитьГоризонтальныйРазделительНаСервере(ТабДок,Ячейка)
ТабДок.ТекущаяОбласть = ТабДок.Область(Ячейка);
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();    
КонецПроцедуры

вот что есть на данный момент,но не отрабатывает,видимо чего-то не хватает
 
  Рекламное место пустует
   Lexey_
 
1 - 12.01.18 - 13:03
(0) тебе поможет:

ОбластьЯчеекТабличногоДокумента (SpreadsheetDocumentRange)
КонецСтраницы (PageBottom)


Использование:
Чтение и запись.

Описание:
Тип: Булево.
Признак того, что данная область находится последней на странице.
Истина - область является последней.


Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

Примечание:
Применимо только для областей строк/колонок.
   furen23
 
2 - 12.01.18 - 13:25
(1) Поле объекта недоступно для записи
Область = ТабДок.ПолучитьОбласть(Ячейка);
Область.ТекущаяОбласть.КонецСтраницы = Истина;
   Радим1987
 
3 - 12.01.18 - 13:32
Область.Область(Ячейка).КонецСтраницы = Истина;
   Радим1987
 
4 - 12.01.18 - 13:32
ТабДок.Область(Ячейка).КонецСтраницы = Истина;
   furen23
 
5 - 12.01.18 - 13:40
(3) (4) ситуация та же
   Радим1987
 
6 - 12.01.18 - 13:44
Странно у меня все норм работает
   Радим1987
 
7 - 12.01.18 - 13:49
Попробуй вот так для примера ТабДок.Область(1,,4).КонецСтраницы = Истина;
   furen23
 
8 - 12.01.18 - 13:51
(7) Тоже недоступно, и почему то поле Значение недоступно для Чтения
   Радим1987
 
9 - 12.01.18 - 13:52
    ТабличныйДокумент = Новый ТабличныйДокумент;
    
    Данные = ПолучитьИзВременногоХранилища(АдресХранилища);
    
    ИмяФайлаВременное = ПолучитьИмяВременногоФайла("mxl");
    
    Данные.Записать(ИмяФайлаВременное);
    ТабличныйДокумент.Прочитать(ИмяФайлаВременное);   

    
    
    Формулы.Очистить();
    Для Итератор = 1 По Число(ТабличныйДокумент.Область(1,1,1,1).Текст) Цикл
        
        
        ТекЛист = "Лист"+Итератор;          
        
        НовыйЛист = ЭтаФорма[ТекЛист];
        
        НовыйЛист.Очистить();            
        
        //На случай если есть группировки в сохраненном табличном документе сначала выводим все а потом удаляем ненужные (По другому ни как)        

        НовыйЛист.Вывести(ТабличныйДокумент);
        Если НовыйЛист.Область(ТекЛист).Верх > 1 Тогда
            НовыйЛист.УдалитьОбласть(НовыйЛист.Область(1,,НовыйЛист.Область(ТекЛист).Верх-1),ТипСмещенияТабличногоДокумента.ПоВертикали);
        КонецЕсли;  
        
        Если НовыйЛист.Область(ТекЛист).Низ <> НовыйЛист.ВысотаТаблицы Тогда
            НовыйЛист.УдалитьОбласть(НовыйЛист.Область(НовыйЛист.Область(ТекЛист).Низ+1,,НовыйЛист.ВысотаТаблицы),ТипСмещенияТабличногоДокумента.ПоВертикали);
        КонецЕсли;         
                
        НовыйЛист.Область(ТекЛист).КонецСтраницы = Ложь; 
        НовыйЛист.Область(ТекЛист).Имя = "";



Вот этот код работает у меня


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует