Вход | Регистрация

1С:Предприятие ::

Метки:коллекции значений

Учебник по 1С

Я
   Basily
 
11.08.04 - 16:08
Удаление строк и колонок из таблицы значений.
Следующий приём мне больше нравится:
    j = 0;
    Для i = 1 По Табл.КоличествоСтрок() Цикл
        Если <УСЛОВИЕ> Тогда
            Табл.УдалитьСтроку(i - j);
            j = j + 1;
        КонецЕсли;
    КонецЦикла;
 
 
   Эмблема форума
 
1 - 11.08.04 - 16:11
Это очень медленный приём ...
   Gavrila
 
2 - 11.08.04 - 16:14
(1) А как быстрее?
   Эмблема форума
 
3 - 11.08.04 - 16:18
Почти любой "приём" без УдалитьСтроку() будет быстрее ...
   Basily
 
4 - 11.08.04 - 16:22
Примеры в учебнике - метки, цикл в цикле, это както не очень...
   Basily
 
5 - 11.08.04 - 16:24
(3) Ты в "учебнике" смотрел ?
   barada
6 - 11.08.04 - 16:28
(3) А "почти" исключает метод "выгрузить"?
   Basily
 
7 - 11.08.04 - 16:31
(6) Метод "Выгрузить" очищает таблицу-приёмник перед загрузкой.
   barada
8 - 11.08.04 - 16:36
угу прогнал :) ...
   Эмблема форума
 
9 - 11.08.04 - 16:36
(5) Некоторые писатели учебников мало читали учебников, поэтому некоторые учебники - плохие учебники ...
(6) Я Вас не понял ...
Постарайтесь выразить Вашу умную мысль другими словами ...
   barada
10 - 11.08.04 - 16:43
(9) Это не умная мысль, а проста вапрос

и ваабще я где то здесь видел копирование тз с помощью "заполнить" тока щас найти не смог ...
 
 
   Bekas
 
11 - 11.08.04 - 16:47
Если ТЗД.КоличествоСтрок() <> 0 Тогда
        ТЗД.ВыбратьСтроки();
        ТЗД.ПолучитьСтроку();
        Пока 1=1 Цикл
            Если ТЗД.НомерСтроки = 0 Тогда
                Прервать;
            КонецЕсли;
            Если <УСЛОВИЕ> Тогда
                ТЗД.УдалитьСтроку();
            Иначе
                Если ТЗД.ПолучитьСтроку()=0 Тогда
                    Прервать;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
   Эмблема форума
 
12 - 11.08.04 - 16:57
   barada
13 - 11.08.04 - 17:04
Кто все таки зашел по ссылке, скиньте мне на мыло плиз
   Эмблема форума
 
14 - 11.08.04 - 17:08


Список тем форума
Рекламное место пустует  
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует