Вход | Регистрация

1С:Предприятие ::

Метки:

БП 3.0 Нумерация счетов фактур с БЕЗ префиксов в книге продаж

Я
   bvb
 
14.11.17 - 18:55
Нужно что бы нумерация счетов фактур в книге продаж шла аналогично печатной форме (без префикса организации и нулей после него).
НВ000002419  --> 2419
Я понимаю тема не нова...
Погуглил, но как понял настройками БП 3.0 это не отыграть.
Если я не прав поправьте меня.

ИМХО нужно допиливать напильником функцию УчетНДС.ОпределитьДатуИНомерСФ

Подскажите как правильнее по феншую
 
 
   Ц_У
 
1 - 14.11.17 - 19:09
в типовых есть

// Получает номер документа для вывода на печать; из номера удаляются префиксы и лидирующие нули.
// Функция:

// отбрасывает префикс организации,
// отбрасывает префикс информационной базы (опционально),

// отбрасывает пользовательские префиксы (опционально),
// удаляет лидирующие нули в номере объекта.

//
// Параметры:

//    НомерОбъекта - Строка - номер или код объекта, который преобразуется для вывода на печать.
//    УдалитьПрефиксИнформационнойБазы - Булево - признак удаления префикса информационной базы.

//    УдалитьПользовательскийПрефикс - Булево - признак удаления пользовательского префикса.
//

// Возвращаемое значение:
//     Строка - Номер на печать.

//
Функция НомерНаПечать(Знач НомерОбъекта, УдалитьПрефиксИнформационнойБазы = Ложь, УдалитьПользовательскийПрефикс = Ложь) Экспорт
    
    // {Обработчик: ПриПолученииНомераНаПечать} Начало

    СтандартнаяОбработка = Истина;
    
    ПрефиксацияОбъектовКлиентСерверПереопределяемый.ПриПолученииНомераНаПечать(НомерОбъекта, СтандартнаяОбработка,
        УдалитьПрефиксИнформационнойБазы, УдалитьПользовательскийПрефикс);
    
    Если СтандартнаяОбработка = Ложь Тогда
        Возврат НомерОбъекта;
    КонецЕсли;
    // {Обработчик: ПриПолученииНомераНаПечать} Окончание

    
    // Удаляем пользовательские префиксы из номера объекта.

    Если УдалитьПользовательскийПрефикс Тогда
        
        НомерОбъекта = УдалитьПользовательскиеПрефиксыИзНомераОбъекта(НомерОбъекта);
        
    КонецЕсли;
    
    // Удаляем лидирующие нули из номера объекта.

    НомерОбъекта = УдалитьЛидирующиеНулиИзНомераОбъекта(НомерОбъекта);
    
    // Удаляем префикс организации и префикс информационной базы из номера объекта.

    НомерОбъекта = УдалитьПрефиксыИзНомераОбъекта(НомерОбъекта, Истина, УдалитьПрефиксИнформационнойБазы);
    
    Возврат НомерОбъекта;
КонецФункции
   Cyberhawk
 
2 - 14.11.17 - 19:35
А сколько платят за решение вопроса?
   bvb
 
3 - 14.11.17 - 19:49
(2) Знаешь метод решить проблем не корежа конфу ?
А то с допиливанием я решил.
   Злопчинский
 
4 - 14.11.17 - 19:50
Штатно БП3 - так и делает.
Ищите почему накосяпорили...
   Злопчинский
 
5 - 14.11.17 - 19:51
я б для начал посмотрел на нумерацию.
чисто поиздеваться - а куда вы дели типовую хрень нумерации по шаблону

0000-000000
   Cyberhawk
 
6 - 14.11.17 - 19:58
(3) У меня в типовой без префикса и лидирующих нулей выводится, так что с большой вероятностью это лечится на уровне данных ИБ, а не путем расширения или изменения конфигурации
   Cyberhawk
 
7 - 14.11.17 - 20:00
Кури РС "Журнал учета СФ"
   Cyberhawk
 
8 - 14.11.17 - 20:02
(оттуда скорее всего берется)
   bvb
 
9 - 14.11.17 - 20:16
(5) Я посмотрел. Типовя нумерация а также номер на печать базируется на том что есть разделитель "-"
Но у меня не типовая номер Реализации и СФ грузятся из самописной конфы где свои законы нумерации
Поэтому типовые функции не работают

(7) Правильное. Берется оттуда. Я вот только думаю допилить конфу или сделать регламентный обработчик регистра.
   Cyberhawk
 
10 - 14.11.17 - 20:41
(9) Ну так туда в поле "Номер СФ" номер пишется без префиксов всяких, по крайней мере в 3.0.42+
 
  Рекламное место пустует
   Cyberhawk
 
11 - 14.11.17 - 20:42
А, не почитал начало (9)
   Cyberhawk
 
12 - 14.11.17 - 20:42
Изменение кода конфигурации БП - это мина замедленного действия. Потом у тебя что-нибудь изменится в приходящих из обмена внешних номерах и будет алес.
   bvb
 
13 - 15.11.17 - 15:31
Пришлось код менять. Регистр подчинен регистратору .
В модуле СчетФактураВыданный дописал

НаборДвижений   = Движения.ЖурналУчетаСчетовФактур;
Для Каждого Движение ИЗ НаборДвижений Цикл
    Движение.НомерСчетаФактуры = ПроизвольныйАлгоритмЗаменыНомера(Движение.НомерСчетаФактуры);
КонецЦикла;    
НаборДвижений.Записывать = ИСТИНА;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует