Вход | Регистрация

1С:Предприятие ::

Метки:

Не могу вставить графу в журнал

Я
   Николай
 
11.08.04 - 10:36
Есть приходная накладная. В таб части есть колонка Товар типа
Справочник.Товары. В журнале Приходных накладных не могу добавить
эту графу.
 
  Рекламное место пустует
   ИВМ35
 
1 - 11.08.04 - 10:40
ИМХО.. было бы чудо, если в колонке журнала увидеть всю табличную часть дока..
   AlexP
2 - 11.08.04 - 11:12
(0) Добавляешь в журнале в форме списка текстовую колонку на нее вешаешь функцию и в модуле пишешь функцию типа такой:
Функция Подробнее()
    Если ТекущийДокумент.Вид()="Пересортица" Тогда
        Спис=СоздатьОбъект("СписокЗначений");
        ТекущийДокумент.ВыбратьСтроки();
        Пока ТекущийДокумент.ПолучитьСтроку()=1 Цикл
            Тов=ТекущийДокумент.Товар;
            Спис.ДобавитьЗначение(Тов);
        КонецЦикла;
        Опись=Спис.ВСтрокуСРазделителями();
    Иначе
        Опись=" - ";
    КонецЕсли;
    Возврат Опись;
КонецФункции
Учитывай, что чем больше товаров в табличной части документа, тем больше тормоза при открытии журнала.


Список тем форума
  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует