Вход | Регистрация

1С:Предприятие ::

Метки:

Подчиненные справочники

Я
   Саша
11.08.04 - 07:55
Создаю подчиненный справочник справочнику"Контрагенты"
Создаю реквизит в справочнике "контрагенты", и присваиваю ему тип этого справочника. Почему при выборе этого реквизита открывается справочник "Контрагенты" для выбора контрагента , и только затем выбор из моего подчиненного справочника? Зарание спасибо всем!
 
 
   VladZagorsky
1 - 11.08.04 - 08:04
Э...  Что-то я не понял... Ты создаешь подчиненный, а потом еще в справочнике делаешь с реквизитом подчиненного?....  Ого...  Ты и себя запутал и программу...
   alkl
2 - 11.08.04 - 08:16
Ну вообще то в типовой договора (основнойц договор у контрагенты) так работают, может ты просто забыл записать контрагента передвыбором подчиненного элемента....
   Кот с улицы Лизюкова
 
3 - 11.08.04 - 09:35
Обрати внимание как сделан выбор договора в этом справочнике.
Согласно (2) это выглядит так (из формы элемента)
Процедура ПриНачалеВыбораЗначения(ИдентЭлементаДиалога, ФлагСтандартнойОбработки)// Предопределенная процедура

    Если ИдентЭлементаДиалога = "ОсновнойДоговор" Тогда
        ФлагСтандартнойОбработки = 0;
        Если Выбран() = 0 Тогда
           Если Вопрос("Список договоров можно открыть
                        |только после записи контрагента.
                        |Записать контрагента?", "Да+Нет") = "Да" Тогда
                Записать();
            КонецЕсли;
        КонецЕсли;
        Если Выбран() = 0 Тогда
            Возврат;
        КонецЕсли;

        ОткрытьФорму("Справочник.Договоры", ТекущийЭлемент());
    КонецЕсли;
КонецПроцедуры// ПриНачалеВыбораЗначения
   VaS
 
4 - 11.08.04 - 09:43
alkl прав. Для выбора из подчинённого спр. ты сначала должен определить владельца. Если сделаешь это сам в модуле методом ИспользоватьВладельца() то выбор контрагента не будет вылазить.


Список тем форума
  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует