Вход | Регистрация


1С:Предприятие ::

Метки:

Ошибка в обмене с бухгалтерией

Я
   refit
 
12.09.17 - 15:34
После обновление конфигурации Далион перестала делаться обмен с бухгалтерией загрузка идет а выгрузка нет Релиз БП последняя пишет ошибку
{Справочник.Номенклатура.МодульОбъекта(185,11)}: Процедура или функция с указанным именем не определена (ПроверитьПравоПользователяНаРедактированиеНоменкл атуры)
Если НЕ <<?>>ПроверитьПравоПользователяНаРедактированиеНом енклатуры( ТекстСообщения ) Тогда
{Справочник.Номенклатура.МодульОбъекта(186,4)}: Процедура или функция с указанным именем не определена (Предупреждение)
<<?>>Предупреждение( ТекстСообщения );
Помогите пожалуйста 
Заранее спасибо
 
  Рекламное место пустует
   DrShad
 
1 - 12.09.17 - 15:39
а чем тут можно помочь? ну нет такой процедуры или функции
   ajax_new
 
2 - 12.09.17 - 15:41
Мне кажется или действительно лишний пробел в названии ??
ПроверитьПравоПользователяНаРедактированиеНоменкл атуры
   refit
 
3 - 12.09.17 - 15:46
тут проблема такая что не идет обмен загрузка идет а выгрузка нет
   Wirtuozzz
 
4 - 12.09.17 - 15:47
(3) отладчика нет на рабочей базе?
   piter3
 
5 - 12.09.17 - 15:50
как может идти загрузка если нет выгрузки?
   DrShad
 
6 - 12.09.17 - 15:51
(5) элементарно
   Wirtuozzz
 
7 - 12.09.17 - 15:52
(5) Запросто, файла 2. Файл на загрузку, файл на выгрузку. главное что бы у них номера отправленных сообщений были впорядке.
   refit
 
8 - 12.09.17 - 15:55
Дата успешной загрузки 12,09,2017
Дата успешной выгрузки 07,09,2017
В день обновления он выгрузку сделал и все
   refit
 
9 - 12.09.17 - 15:55
Перем СтатусПроверкиДиапазона Экспорт;      // Структура для проверки кода в диапазоне кодов


///////////////////////////////////////////////////////////////////////////////

// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ

// Получает таблицу категорий цен

Функция ПолучитьТаблицуКатегорийЦен(ПолучитьЗакупочнуюЦену,ВыводитьГлавные = Истина, ВыводитьПодчиненные = Истина) Экспорт
    
    Перем СписокТО;
    
    ЕстьОграничениеДоступа = ОграничениеДоступа.ЕстьОграничениеДоступаКТОНаПросмотр(СписокТО);
    
    Запрос = Новый Запрос;
    
    Запрос.УстановитьПараметр("ЕстьОграничениеДоступа", ЕстьОграничениеДоступа);
    Запрос.УстановитьПараметр("СписокТО"          , СписокТО);
    
    Запрос.Текст =
    "ВЫБРАТЬ РАЗЛИЧНЫЕ 
    |    ТорговыеОбъекты.Ссылка КАК КатегорияЦен,
    |    ТорговыеОбъекты.Ссылка.Наименование КАК Наименование
    |ИЗ
    |    Справочник.КатегорииЦен.ТорговыеОбъекты КАК ТорговыеОбъекты
    |ГДЕ
    |    (Не &ЕстьОграничениеДоступа ИЛИ ТорговыеОбъекты.ТорговыйОбъект В (&СписокТО))
    |    И ТорговыеОбъекты.Просмотр = ИСТИНА"
    +?(НЕ ВыводитьПодчиненные И НЕ(ВыводитьГлавные И ВыводитьПодчиненные) ,"
    |      И ( ТорговыеОбъекты.Ссылка.Родитель = ЗНАЧЕНИЕ(Справочник.КатегорииЦен.ПустаяСсылка)
    |        ИЛИ ТорговыеОбъекты.Ссылка.ПереоценкаПоГруппе = ИСТИНА 
    |        ИЛИ ТорговыеОбъекты.Ссылка.Родитель.ПереоценкаПоГруппе = ЛОЖЬ )","")
    +?(НЕ ВыводитьГлавные И НЕ(ВыводитьГлавные И ВыводитьПодчиненные),"
    |      И ТорговыеОбъекты.Ссылка.Родитель.ПереоценкаПоГруппе = ИСТИНА","")
    +?(ПолучитьЗакупочнуюЦену, "", "
    |    И ТорговыеОбъекты.Ссылка <> ЗНАЧЕНИЕ(Справочник.КатегорииЦен.Закупочная)") + ?(ПолучитьЗакупочнуюЦену, "
    |ОБЪЕДИНИТЬ
    |ВЫБРАТЬ
    |    ЗНАЧЕНИЕ(Справочник.КатегорииЦен.Закупочная),
    |    (ЗНАЧЕНИЕ(Справочник.КатегорииЦен.Закупочная)).Наименование", "")+"
    |УПОРЯДОЧИТЬ ПО
    |    Наименование";
                                                         
    Таблица = Запрос.Выполнить().Выгрузить();
    Таблица.Колонки.Добавить("НаценкаПоУмолчанию", Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(6, 2, ДопустимыйЗнак.Неотрицательный)));
    Таблица.Колонки.Добавить("ПравилоОкругления",  Новый ОписаниеТипов("СправочникСсылка.ПравилаОкругления"));
    Таблица.Колонки.Добавить("КоридорЦен",         Новый ОписаниеТипов("СправочникСсылка.КоридорыЦен"));
    Таблица.Колонки.Добавить("ИзГруппы",           Новый ОписаниеТипов("Булево"));
    
    Возврат Таблица;

КонецФункции

// Обновляет таблицу значений ТаблицаКатегорийЦен по категориям цен заданным в таблице значений ТабКатегорийЦен

// В таблице ТабКатегорийЦен обязательна колонка КатегорияЦен
Процедура ОбновитьТаблицуКатегорийЦен(ИсходнаяТаблица, ТабКатегорийЦен) Экспорт
                    
    НоваяТаблица = ПолучитьТаблицуПравилЦенообразования(ТабКатегорийЦен,Родитель,);
            
    Для Каждого СтрокаТЧ Из ИсходнаяТаблица Цикл
        СтрокаНовТаб = НоваяТаблица.Найти(СтрокаТЧ.КатегорияЦен, "КатегорияЦен");
        Если СтрокаНовТаб <> Неопределено Тогда
            ЗаполнитьЗначенияСвойств(СтрокаТЧ, СтрокаНовТаб);
            СтрокаТЧ.ИзГруппы = Истина;
        КонецЕсли;
    КонецЦикла;        
    
КонецПроцедуры

// Функция проверяет, существуют ли ссылки на номенклатуру в регистрах.

//
// Параметры:

//  СуществуютСсылки - старое значение параметра, для единичного запуска функции.
//

// Возвращаемое значение:
//  Истина - если есть движения, Ложь - если нет.

//
Функция СуществуютСсылки(СуществуютСсылки) Экспорт
    
    Если СуществуютСсылки <> Неопределено Тогда
        Возврат СуществуютСсылки;
    КонецЕсли;
    
    Если ЭтоНовый() Тогда
        Возврат Ложь;
    КонецЕсли;
            
    Запрос = Новый Запрос();

    Запрос.УстановитьПараметр("ТекущийВладелец", Ссылка);

    Запрос.Текст =
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |    ОстаткиНоменклатуры.Номенклатура
    |ИЗ
    |    РегистрНакопления.ОстаткиНоменклатуры КАК ОстаткиНоменклатуры
    |ГДЕ
    |    ОстаткиНоменклатуры.Номенклатура = &Номенклатура
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ ПЕРВЫЕ 1
    |    ПартииНоменклатуры.Номенклатура
    |ИЗ
    |    РегистрНакопления.ПартииНоменклатуры КАК ПартииНоменклатуры
    |ГДЕ
    |    ПартииНоменклатуры.Номенклатура = &Номенклатура
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ ПЕРВЫЕ 1
    |    ОстаткиНоменклатурыВРознице.Номенклатура
    |ИЗ
    |    РегистрНакопления.ОстаткиНоменклатурыВРознице КАК ОстаткиНоменклатурыВРознице
    |ГДЕ
    |    ОстаткиНоменклатурыВРознице.Номенклатура = &Номенклатура
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ ПЕРВЫЕ 1
    |    ТоварыНаРеализации.Номенклатура
    |ИЗ
    |    РегистрНакопления.ТоварыНаРеализации КАК ТоварыНаРеализации
    |ГДЕ
    |    ТоварыНаРеализации.Номенклатура = &Номенклатура";
    
    Запрос.УстановитьПараметр("Номенклатура", Ссылка);
    
    СуществуютСсылки =  НЕ Запрос.Выполнить().Пустой();
    
    Возврат СуществуютСсылки;
    
КонецФункции

// Процедура получает код из диапозона кодов.

//
// Отказ - код выдать не удалось,

// УстанавливатьКод - устанавливать код, или проверить на возможность его выдачи,
// ТихийРежим - тихий режим работы.

//
Процедура ПолучитьКодИзДиапазона(Отказ, УстанавливатьКод = Истина, ТихийРежим = Ложь) Экспорт
        
    Если СтатусПроверкиДиапазона.ПоискКодаВДиапозоне Тогда
                
        ДиапазонНачало = ПолучитьПараметрИБ(ПараметрыСеанса.ТекущаяИБ, "ДиапазонНачало");
        ДиапазонКонец  = ПолучитьПараметрИБ(ПараметрыСеанса.ТекущаяИБ, "ДиапазонКонец");
            
        Результат = ПолучитьКодИзДиапазонаТаблицы("Справочник.Номенклатура", "Код", ДиапазонНачало, ДиапазонКонец);
        
        Если Результат.Ошибка Тогда
            Если УстанавливатьКод Тогда
                Окончание = ", элемент не записан!";
            Иначе
                Окончание = ", нельзя завести элемент!";
            КонецЕсли;
            СтрокаСообщение = "Нет свободных кодов в выбранном диапазоне" + Окончание;
            Если ТихийРежим Тогда
                Сообщить(СтрокаСообщение);
            Иначе
                #Если ТолстыйКлиентОбычноеПриложение Тогда
                    Предупреждение(СтрокаСообщение);
                #КонецЕсли

            КонецЕсли;
            
            Отказ = Истина;
            Возврат;
            
        ИначеЕсли УстанавливатьКод Тогда
            Код = Результат.Код;
        КонецЕсли;           
            
    КонецЕсли;
    
КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////

// ОБРАБОТЧИКИ СОБЫТИЙ

// Обработчик события "ПередЗаписью" элемента справочника.

//
Процедура ПередЗаписью(Отказ)

    Если НЕ ОбменДанными.Загрузка Тогда        
        
        // дополнительное право на редактирование Номенклатуры 

        ТекстСообщения = "";
        Если НЕ ПроверитьПравоПользователяНаРедактированиеНоменклатуры( ТекстСообщения ) Тогда                
            Предупреждение( ТекстСообщения );
            Отказ = Истина;
            Возврат;                      
        КонецЕсли;                  
                
        // При попытке перемещения группы

        Если НЕ ЭтоНовый() И ЭтоГруппа И ПланыОбмена.ГлавныйУзел() <> Неопределено Тогда
            Если Ссылка.Родитель <> ЭтотОбъект.Родитель Тогда
                Сообщить("Перемещение групп товаров доступно только в главном узле.", СтатусСообщения.Внимание);
                Отказ = Истина;
            КонецЕсли;
        КонецЕсли;
        
        НеобходимостьПроверкиДиапазона(ЭтотОбъект, ЭтотОбъект.СтатусПроверкиДиапазона);
        
        Если ЭтотОбъект.ЭтоНовый() Тогда
            Если Не ЭтотОбъект.СтатусПроверкиДиапазона.Новый Тогда
                Если ЭтотОбъект.СтатусПроверкиДиапазона.Константа Тогда
                    Сообщить("Элемент можно завести только в узле с заданным диапазоном кодов.", СтатусСообщения.Важное);
                    Отказ = Истина;
                Иначе
                    Сообщить("Элемент можно завести только в узле с признаком ведения справочников.", СтатусСообщения.Важное);
                    Отказ = Истина;
                КонецЕсли;
            Иначе
                
                ПредвАртикул = Формат(Код, "ЧГ=0");// для случая когда артикул сформировался по некорректно полученному коду

                
                Если ДополнительныеСвойства.Свойство("ЗаписьИзФормы") Или Код = 0 Тогда
                    УстановитьНовыйКод();
                КонецЕсли;
                
                Если Код = 0 Тогда
                    Отказ = Истина;
                Иначе
                    Если НЕ ЭтоГруппа И (ПустаяСтрока(Артикул) ИЛИ Артикул = ПредвАртикул) Тогда
                        Артикул = Формат(Код, "ЧГ=0");
                    КонецЕсли;
                 КонецЕсли;
                
            КонецЕсли;
        ИначеЕсли Не ЭтотОбъект.СтатусПроверкиДиапазона.Редактирование Тогда
            Если ЭтотОбъект.СтатусПроверкиДиапазона.Константа Тогда
                Сообщить("Элемент редактируется в узле с признаком ведения справочников либо в узле где был создан.", СтатусСообщения.Важное);
                Отказ = Истина;
            Иначе
                Сообщить("Элемент редактируется только в узле с признаком ведения справочников.", СтатусСообщения.Важное);
                Отказ = Истина;
            КонецЕсли;
        КонецЕсли;
            
        Если НЕ ЭтоГруппа Тогда
            
            Если ТабачныеИзделия Тогда
                Если НЕ ЗначениеЗаполнено(КатегорияТовара)
                    Или КатегорияТовара = Справочники.КатегорииТоваров.УчетПоХарактеристикамНеВедется
                    Или Не ПроверитьКорректностьКатегорииТовараДляТабака() Тогда
                    Сообщить("Для номенклатуры с видом ""Табак"" необходимо указать категорию товара с включенным обязательным свойством ""МРЦ""!");
                    Отказ = Истина;
                Иначе
                    ИспользоватьХарактеристикиНоменклатуры                = Истина;
                    ОбязательноеЗаполнениеХарактеристикиНоменклатуры    = Истина;
                КонецЕсли;
            Иначе
                Если НЕ ЗначениеЗаполнено(КатегорияТовара) Тогда
                    Если ИспользоватьХарактеристикиНоменклатуры Тогда                
                        Сообщить("Не указана категория товара!", СтатусСообщения.Важное);
                        Отказ = Истина;
                    Иначе
                        КатегорияТовара = Справочники.КатегорииТоваров.УчетПоХарактеристикамНеВедется;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
            
            Если Не ЭтоНовый() Тогда
                
                Если Не Услуга И НЕ ЗначениеЗаполнено(БазоваяЕдиницаИзмерения) Тогда
                    Сообщить("Не указана базовая единица измерения.", СтатусСообщения.Важное);
                    Отказ = Истина;
                Иначе
                    
                    // Надо проверить владельца единицы хранения остатков

                    Если БазоваяЕдиницаИзмерения.Владелец <> Ссылка Тогда
                        Сообщить("У базовой единицы номенклатуры """ + СокрЛП(Ссылка) + """ неверно указан владелец!", СтатусСообщения.Важное);
                        Отказ = Истина;
                    КонецЕсли;
                    
                КонецЕсли;

                Если (НЕ Услуга) И (НЕ ЗначениеЗаполнено(ЕдиницаИзмеренияЗаказов)) Тогда
                    ЕдиницаИзмеренияЗаказов = БазоваяЕдиницаИзмерения;
                КонецЕсли;
                
                Если НЕ ЗначениеЗаполнено(ЕдиницаИзмеренияОтчетов) Тогда
                    ЕдиницаИзмеренияОтчетов = БазоваяЕдиницаИзмерения;
                КонецЕсли;
            КонецЕсли;

            Если Тара И СтавкаНДС <> Перечисления.СтавкиНДС.БезНДС Тогда
                СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
            ИначеЕсли Не ЗначениеЗаполнено(СтавкаНДС) Тогда
                Сообщить("Не указана ставка НДС.", СтатусСообщения.Важное);
                Отказ = Истина;
            КонецЕсли;                   

            СуществуютСсылки = Неопределено;
            Если НЕ Услуга
               И Ссылка.БазоваяЕдиницаИзмерения <> БазоваяЕдиницаИзмерения 
               И СуществуютСсылки(СуществуютСсылки) Тогда
                Сообщить("Единица """ + СокрЛП(Ссылка.БазоваяЕдиницаИзмерения) + """ является базовой единицей для """ + Наименование + """
                |и уже участвует в товародвижении. 
                |Изменить эту единицу уже нельзя!", СтатусСообщения.Важное);
            КонецЕсли;

            Если Услуга <> Ссылка.Услуга 
               И СуществуютСсылки(СуществуютСсылки)Тогда
                ТекстСообщения = "Номенклатура """ + СокрЛП(Ссылка) + """ участвует в товародвижении.
                |Признак услуги не может быть изменен!";
                СообщитьОбОшибкеДАЛИОН(ТекстСообщения, Отказ);
            КонецЕсли;
            
            Если Тара <> Ссылка.Тара 
               И СуществуютСсылки(СуществуютСсылки)Тогда
                ТекстСообщения = "Номенклатура """ + СокрЛП(Ссылка) + """ участвует в товародвижении.
                |Признак тары не может быть изменен!";
                СообщитьОбОшибкеДАЛИОН(ТекстСообщения, Отказ);
            КонецЕсли;
            
            Если ФиксированныйПоставщик И НЕ ЗначениеЗаполнено(ОсновнойПоставщик) Тогда
                Сообщить("Не выбран основной поставщик.", СтатусСообщения.Важное);
                Отказ = Истина;
            КонецЕсли;
            
            Если Алкоголь Тогда
                
                Если НЕ ЗначениеЗаполнено(ОбъемАлкоголь) Тогда
                    Сообщить("Не заполнен объем алкоголя.", СтатусСообщения.Важное);
                    Отказ = Истина;
                КонецЕсли;
                
                Если ПивнаяКега Тогда
                    Если ЗначениеЗаполнено(НоменклатураРазливноеПиво) Тогда
                        Если НоменклатураРазливноеПиво = Ссылка Тогда
                            Сообщить("Нельзя указывать в качестве номенклатуры ""Разливное пиво"" саму себя!");
                            Отказ = Истина;
                        ИначеЕсли НЕ НоменклатураРазливноеПиво.Алкоголь Тогда
                            Сообщить("Нельзя указывать в качестве номенклатуры ""Разливное пиво"" неалкогольную продукцию!");
                            Отказ = Истина;
                        КонецЕсли;
                    КонецЕсли;
                Иначе
                    НоменклатураРазливноеПиво = Справочники.Номенклатура.ПустаяСсылка();        
                КонецЕсли;
            Иначе
                //Очистка алкогольных реквизитов

                ВидАлкогольнойПродукции     = Справочники.ВидыАлкогольнойПродукции.ПустаяСсылка();
                ПроизводительАлкоголя        = Справочники.ПроизводителиАлкоголя.ПустаяСсылка();
                ОбъемАлкоголь                = 0;
                ЕмкостьПотребительскойТары     = 0;
                НаименованиеДляДекларации   = "";
                СодержаниеСпирта            = 0;
                ПивнаяКега                    = Ложь;
                РазливноеПиво                = Ложь;
                НоменклатураРазливноеПиво    = Справочники.Номенклатура.ПустаяСсылка();
            КонецЕсли;
                                    
        КонецЕсли;
                  
    КонецЕсли;
        
КонецПроцедуры// ПередЗаписью()


// Обработчик события "ПриЗаписи" элемента справочника.

//
Процедура ПриЗаписи(Отказ)
    
    Если НЕ ЭтоГруппа И НЕ ОбменДанными.Загрузка Тогда
                 
        Если ШтрихКодВключаетКоличество И (Не ИспользоватьХарактеристикиНоменклатуры ИЛИ Не ОбязательноеЗаполнениеХарактеристикиНоменклатуры) И ЗначениеЗаполнено(БазоваяЕдиницаИзмерения) Тогда 
            НайтиВнутреннийКодТовара(Ссылка, Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка(), БазоваяЕдиницаИзмерения, Истина);
        ИначеЕсли ВыгружатьВВесы И (Не ИспользоватьХарактеристикиНоменклатуры ИЛИ Не ОбязательноеЗаполнениеХарактеристикиНоменклатуры) И ЗначениеЗаполнено(БазоваяЕдиницаИзмерения) Тогда
            НайтиВнутреннийКодТовара(Ссылка, Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка(), БазоваяЕдиницаИзмерения, Истина);
        КонецЕсли;
            
        Если ЭтоНовый() Тогда
            
            МенеджерЗаписи = РегистрыСведений.ПараметрыНоменклатуры.СоздатьМенеджерЗаписи();
            МенеджерЗаписи.Период                       = Дата(1980, 1, 1);
            МенеджерЗаписи.Номенклатура                 = Ссылка;    
            МенеджерЗаписи.ЦенаЗадаетсяНаХарактеристику = Ложь;
            МенеджерЗаписи.Записать();
            
        Иначе
            
            Отбор = Новый Структура("Номенклатура", Ссылка);
            
            ТаблицаЗаписей = РегистрыСведений.ПараметрыНоменклатуры.СрезПоследних(ТекущаяДата(), Отбор);
            
            Если ТаблицаЗаписей.Количество() = 0 Тогда
                
                МенеджерЗаписи = РегистрыСведений.ПараметрыНоменклатуры.СоздатьМенеджерЗаписи();
                МенеджерЗаписи.Период                       = Дата(1980, 1, 1);
                МенеджерЗаписи.Номенклатура                 = Ссылка;    
                МенеджерЗаписи.ЦенаЗадаетсяНаХарактеристику = Ложь;
                МенеджерЗаписи.Записать();
                
            КонецЕсли;
            
        КонецЕсли;
                
    ИначеЕсли ЭтоГруппа И НЕ ОбменДанными.Загрузка Тогда    
        
        МаксУровень    = ГлубинаСправочникаНоменклатура();
        ТекущийУровень = Ссылка.Уровень();
        
        Если ТекущийУровень >= МаксУровень Тогда
            
            СтруктураСохранения = Новый Структура;
            СтруктураСохранения.Вставить("МаксУровень",    ТекущийУровень + 1);
            СтруктураСохранения.Вставить("ДатаСохранения", НачалоДня(ТекущаяДата()));
            
            СохранитьЗначениеКонф("ГлубинаСправочникаНоменклатура", СтруктураСохранения, Истина);
            
        КонецЕсли;
        
    КонецЕсли;
    
КонецПроцедуры

// Обработчик события ПриУстановкеНовогоКода объекта.

//
Процедура ПриУстановкеНовогоКода(СтандартнаяОбработка, Префикс)
    
    НеобходимостьПроверкиДиапазона(ЭтотОбъект, СтатусПроверкиДиапазона);
    Если СтатусПроверкиДиапазона.ПоискКодаВДиапозоне Тогда
        
        ПолучитьКодИзДиапазона(Ложь, Истина, Истина);
        СтандартнаяОбработка = Ложь;
        
    КонецЕсли;
                
КонецПроцедуры

Функция ПроверитьКорректностьКатегорииТовараДляТабака()
    
    Запрос = Новый Запрос;
    Запрос.Текст =  "ВЫБРАТЬ
                    |    НазначенияСвойствОбъектов.Свойство
                    |ИЗ
                    |    РегистрСведений.НазначенияСвойствОбъектов КАК НазначенияСвойствОбъектов
                    |ГДЕ
                    |    НазначенияСвойствОбъектов.Объект = &КатегорияТовара
                    |    И НазначенияСвойствОбъектов.ОбязательноеЗаполнение
                    |    И НазначенияСвойствОбъектов.Свойство = ЗНАЧЕНИЕ(ПланВидовХарактеристик.СвойстваОбъектов.МРЦ)";
    Запрос.УстановитьПараметр("КатегорияТовара", КатегорияТовара);
    Результат = Запрос.Выполнить();
    Если Результат.Пустой() Тогда
        Возврат Ложь;
    Иначе
        Возврат Истина;
    КонецЕсли;
    
КонецФункции
   refit
 
10 - 12.09.17 - 15:56
он жалуется походу на это правило потому-что выдал ошибку и нажал там конфигуратор открылась это
 
  Рекламное место пустует
   DrShad
 
11 - 12.09.17 - 16:00
правильно открылось и функции на которую ругается действительно нет
   refit
 
12 - 12.09.17 - 16:02
а что делать ? я вообще не разбираюсь в этом
   Wirtuozzz
 
13 - 12.09.17 - 16:05
(12) А как вам поручили задачу, если вы не понимаете что там?
   refit
 
14 - 12.09.17 - 16:08
я первый раз встречаюсь с такой проблемой я в это организации Егаисом и автоматизации в 1с разбираюсь вот только эти правила не когда не смотрел и вот так получилось
   rudnitskij
 
15 - 12.09.17 - 16:10
Мне одному кажется, что тут ключевые слова в самом начале вопроса - "После обновления..."?
   refit
 
16 - 12.09.17 - 16:11
да после обновления ночь обновили утром мне позванили
   DrShad
 
17 - 12.09.17 - 16:11
(15) ключевые слова тут между строк идут - ТС занялся обновлениями и обменами, при этом вообще 1С видит впервые
   rudnitskij
 
18 - 12.09.17 - 16:13
(16) думаю, что в старой версии, до обновления, эта процедура была. Берите резервную копию и доставайте нужную процедурку из нее.
ЗЫ. По контексту понимаю, что слово ХРАНИЛИЩЕ никому на фирме вашей не знакомо
   rudnitskij
 
19 - 12.09.17 - 16:14
(17) ...но подсознательно тянется ко всему новому - и потому рефлекторно обновляет всё, до чего достанут руки)
   refit
 
20 - 12.09.17 - 16:31
резервная копия есть на 7 мое число как можно из нее вытащить эту процедуру установить ее взять нужное правило обмена и вернуть обратно сегоднещнее
   DrShad
 
21 - 12.09.17 - 16:34
(20) нужно начинать со школы
   refit
 
22 - 12.09.17 - 16:42
а если точнее?
   DrShad
 
23 - 12.09.17 - 16:45
(22) с подготовительной группы
   refit
 
24 - 12.09.17 - 17:08
а где можно скачать свежее правило для конфигурации БП
   DrShad
 
25 - 12.09.17 - 17:09
(24) а оно тебе ничего не даст
   Numerus Mikhail
 
26 - 12.09.17 - 17:10
(24) свежее правило - перед обновлением делать бэкап
   refit
 
27 - 12.09.17 - 17:11
а что делать тогда уже 5 дне обмен не идет мозги делают .
Бекап сделали есть
   refit
 
28 - 12.09.17 - 17:15
Бэкап сделан в день когда оно работала а вот что сним делать ?
   DrShad
 
29 - 12.09.17 - 17:17
(28) разворачивать параллельно и оттуда смотреть конфу
   refit
 
30 - 12.09.17 - 17:19
ок спасибо большое
   refit
 
31 - 12.09.17 - 17:24
попробую сегодня
   refit
 
32 - 13.09.17 - 09:10
(18) нет почему знакомо
   refit
 
33 - 13.09.17 - 10:19
Ребят скажите пожалуйста что сделать уже я всю ночь не спал копался правила из конвертаций выгрузил сверил они одинаковые, но все равно этот обмен не идет уже башка трещит
 
  Рекламное место пустует
   catena
 
34 - 13.09.17 - 10:24
(33)А из каких соображений вы проверяете именно правила, если ошибка идет из модуля номенклатуры?
   DrShad
 
35 - 13.09.17 - 10:25
(34) ну ему так больше нравится )))
   refit
 
36 - 13.09.17 - 10:33
(34) из модуля наменклатуры?
   refit
 
37 - 13.09.17 - 10:34
(35) я всю ночь там копалься
   refit
 
38 - 13.09.17 - 10:36
(34) а что с модулем та его изменить надо ?
   refit
 
39 - 13.09.17 - 10:37
(34) и что надо сделать не подскажите ?)
   DrShad
 
40 - 13.09.17 - 10:55
нужно найти функцию, на отсутствие которой ругается
несколько раз ее прочитать, понять и осмыслить
   refit
 
41 - 13.09.17 - 10:59
(40) значить искать начат надо с конфигуратора
   rudnitskij
 
42 - 13.09.17 - 11:01
(41) я правильно понял, вам пишет ошибку "Нет функции" - а вы что-то смотрели всю ночь, и это был не конфигуратор?
   refit
 
43 - 13.09.17 - 11:05
(42) да вы все правильно понял я ночью заходил в сам далион и КД 2,0 и смотрел правила а проблема нет функции . не могу понять эти числа 185,11 и 186,4
   catena
 
44 - 13.09.17 - 11:06
(43)Это номера строк в модуле. Может не стоит вам этим заниматься?
   refit
 
45 - 13.09.17 - 11:07
(44) учиться же надо
   refit
 
46 - 13.09.17 - 11:08
а за сколько сделают ?
   rudnitskij
 
47 - 13.09.17 - 11:09
(45) если вы совсем не знаете 1С - начинайте учебу с чего-то полегче, а не с правил обмена
   DrShad
 
48 - 13.09.17 - 11:13
185,11 и 186,4

тут 185 и 186 это номера строк
а 11 и 4 это номер позиции в строке
   refit
 
49 - 13.09.17 - 11:13
в 1с разбираюсь вот нашел те строки
 
  Рекламное место пустует
   DrShad
 
50 - 13.09.17 - 11:15
(49) пытаться разобраться и разбираться разные вещи
   refit
 
51 - 13.09.17 - 11:18
(50) все нашел там строки отличается друг от друга
   refit
 
52 - 13.09.17 - 11:18
Процедура ПередЗаписью(Отказ)

    Если НЕ ОбменДанными.Загрузка Тогда
                
        // При попытке перемещения группы

        Если НЕ ЭтоНовый() И ЭтоГруппа И ПланыОбмена.ГлавныйУзел() <> Неопределено Тогда
            Если Ссылка.Родитель <> ЭтотОбъект.Родитель Тогда
                Сообщить("Перемещение групп товаров доступно только в главном узле.", СтатусСообщения.Внимание);
                Отказ = Истина;
            КонецЕсли;
        КонецЕсли;
        
        НеобходимостьПроверкиДиапазона(ЭтотОбъект, ЭтотОбъект.СтатусПроверкиДиапазона);
   refit
 
53 - 13.09.17 - 11:19
Если НЕ ОбменДанными.Загрузка Тогда        
        
        // дополнительное право на редактирование Номенклатуры 

        ТекстСообщения = "";
        Если НЕ ПроверитьПравоПользователяНаРедактированиеНоменклатуры( ТекстСообщения ) Тогда                
            Предупреждение( ТекстСообщения );
            Отказ = Истина;
            Возврат;                      
        КонецЕсли;                  
                
        // При попытке перемещения группы
   ildary
 
54 - 13.09.17 - 11:19
(0) Потрясти техподдержку Далион-а на предмет ошибки в конфигурации - пробовали?
   refit
 
55 - 13.09.17 - 11:20
1 это взял из бэкапа а второе после обновление
   DrShad
 
56 - 13.09.17 - 11:21
(55) ну в таком случае вы некорректно выполнили обновление
   catena
 
57 - 13.09.17 - 11:21
(55)Взять за длинное ухо того, кто делал обновление и потыкать носом в "Предупреждение" в модуле не представляется возможным?
   refit
 
58 - 13.09.17 - 11:22
2рое которое я отправил оно лишнее
   refit
 
59 - 13.09.17 - 12:36
Последний вопрос что если взять старую из старой эти строки и идентично сделать на новой поможет?
   DrShad
 
60 - 13.09.17 - 12:39
(59) может все таки корректно сделать обновление?
   refit
 
61 - 13.09.17 - 16:18
Спасибо огромное всем за помощь пришлось помучатся но получилось благодарю всех
   DrShad
 
62 - 13.09.17 - 16:20
(61) вот бы еще знать что сделано для этого



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует