Вход | Регистрация


1С:Предприятие ::

Метки:

v7: Блин напомните про открытие только созданного документа

Я
   Chameleon1980
 
12.08.17 - 16:33
Приветствую всех.
НовыйПКО=СоздатьОбъект("Документ.ПКО");
            
НовыйПКО.Новый();

НовыйПКО.ДокОснование=ДокументОснование;

НовыйПКО.Касса = глЗначениеПоУмолчанию("ОсновнаяКасса");

глЗаполнитьШапкуНаОсн(НовыйПКО, ДокументОснование);

НовыйПКО.Основание = глПредставлениеДокумента(ДокументОснование);

НовыйПКО.Сумма=Сумма;

НовыйПКО.СуммаВзаиморасчетов=Сумма;

как форму его открыть не записывая?

капец 7.7 отходит на задний план.
 
  Рекламное место пустует
   Guk
 
1 - 12.08.17 - 16:34
формекс подключить...
   Chameleon1980
 
2 - 12.08.17 - 16:35
кажись без формекса

Через открытьФорму

туда контекст передается

а тут контекст заполняем не?
   Chameleon1980
 
3 - 12.08.17 - 16:36
(1) а про формекс подскажи где оно?
   Chameleon1980
 
4 - 12.08.17 - 16:36
метод
   mikecool
 
5 - 12.08.17 - 16:38
НовыйПКО.ПолучитьФорму().Открыть() не?
   Chameleon1980
 
6 - 12.08.17 - 16:39
(5) клюшки жеж. Тут вроде нет такого метода у дока.
   Chameleon1980
 
7 - 12.08.17 - 16:40
во пля:

Конт="";
ОткрытьФорму("Документ.ПКО", Конт);

Конт.Сумма=Сумма;
Конт.СуммаВзаиморасчетов=Сумма;
   Chameleon1980
 
8 - 12.08.17 - 16:41
спасибо всем. походу можно закрывать.

Единственный момент. Все-же интересно каким способом/методом формекс бы помог?
   mikecool
 
9 - 12.08.17 - 16:41
(7) в 7.7 в конфигах была функция ПолучитьКонтекст
   Chameleon1980
 
10 - 12.08.17 - 16:46
такое помню
глВзятьКонтекст(Контекст)
не?

это ты про вместо Конт="" ?
 
 
   Chameleon1980
 
11 - 12.08.17 - 16:47
в общем работает так нормально вместо (0)

Конт="";

ОткрытьФорму("Документ.ПКО", Конт);

Конт.ДокОснование=ДокументОснование;

Конт.Касса = глЗначениеПоУмолчанию("ОсновнаяКасса");

глЗаполнитьШапкуНаОсн(Конт, ДокументОснование);

Конт.Основание = глПредставлениеДокумента(ДокументОснование);

Конт.Сумма=Сумма;

Конт.СуммаВзаиморасчетов=Сумма;
   Злопчинский
 
Ведущий
12 - 12.08.17 - 18:23
(7) третьим параметром в открытьформу  передать документоснование
И будет то что в (0) написано
   Chameleon1980
 
13 - 12.08.17 - 19:20
(12) мне сумму там другую нужно

хотя. форма жеж открытьФорму просто

можно и так попробовать
   Chameleon1980
 
14 - 12.08.17 - 19:21
короче вопрос другой возник

в обработке есть

ОткрытьФормуМодально("Элемент.Автомобили", Конт,,,Контрагент.ТекущийЭлемент());

это создание нового элемента справочника "Автомобили",
подчиненного контрагенту.

как мне после этой строки получить созданный документ?
   Chameleon1980
 
15 - 12.08.17 - 19:24
ой
*созданный документ = созданный элемент
   HawkEye
 
16 - 12.08.17 - 19:26
(15) в созданном элементе сделай, что-то типа:

Записать();
Форма.Параметр = ТекущийЭлемент(); 

здесь будет в конт-е
   Chameleon1980
 
17 - 12.08.17 - 19:28
:) ага вот уже и пробую

//*****************************************************************************

Процедура ПриЗаписи()
    
    Если ПустоеЗначение(Марка)=1 Тогда
        Предупреждение("Не указана марка автомобиля !");
        СтатусВозврата(0);
        Возврат;
    КонецЕсли;
                       
    Наименование=СокрЛП(Марка.Наименование)+" "+СокрП(Номер)+" "+СокрЛП(Год)+" "+СокрЛП(VIN);
    
    Форма.Параметр=ТекущийЭлемент();
    
КонецПроцедуры// ПриЗаписи

//*****************************************************************************
   Chameleon1980
 
18 - 12.08.17 - 19:31
наверное при закрытии
если выбран тогда
форма.Параметр=ТЕкущийЭлемент()

т.к. вернулся справочник, но пустой
   Chameleon1980
 
19 - 12.08.17 - 19:34
так и есть
в при закрытии если выбран
в параметр отдаем текущего созданного

в при записи его еще не до конца сделали :)

прости меня семерочка, что забывается :)

Спасибо всем за помощь.
   HawkEye
 
20 - 12.08.17 - 19:47
(18) в призаписи - эл-т еще не записан, надо сначала Записать()
   Chameleon1980
 
21 - 12.08.17 - 20:02
(20) ага я понял :)

в при закрытии проверил родился элемент или нет
и дал в параметр его
   ADirks
 
22 - 14.08.17 - 06:27
(8) FormEx бы помог, если бы надо было строки добавлять.
Просто так Кон.НоваяСтрока() в семёрке не работает. А с FormEx'ом работает.
   vadim777
 
23 - 14.08.17 - 07:03
(22) Из глобального модуля "Бухия для украины":
Процедура глЗаполнитьТабличнуюЧастьНаОсновании(Конт, ДокументОснование) Экспорт
............    
    ДокументОснование.ВыбратьСтроки();
    Пока ДокументОснование.ПолучитьСтроку() = 1 Цикл
        Конт.НоваяСтрока();

Без формекса.
   Sserj
 
24 - 14.08.17 - 07:18
Ну вообще можно просто передать список параметров при открытии формы нового документа. Типа такого:

спсПараметры = СоздатьОбъект("СписокЗначений");
спсПараметры.Установить("Действие", "ЗаполненениеНового");
спсПараметры.Установить("ДокОснование", ДокументОснование);
спсПараметры.Установить("Касса", глЗначениеПоУмолчанию("ОсновнаяКасса"));
....

ОткрытьФорму("Документ.ПКО", спсПараметры);

В ПКО:
Процедура ПриОткрытии()

Если ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений" Тогда
  Если Форма.Параметр.Получить("Действие") = "ЗаполненениеНового" Тогда
    ДокОснование = Форма.Параметр.Получить("ДокОснование");
    Касса = Форма.Параметр.Получить("Касса");
    ....
  КонецЕсли;
КонецЕсли

КонецПроцедуры
   1dvd
 
25 - 14.08.17 - 07:28
всё так



Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует