Вход | Регистрация

1С:Предприятие ::

Метки:Запросы и построители

Формирование строки условий для запроса из списка с пометками

Я
   ken_gd
10.08.04 - 12:22
Раньше я формировала выбор конкретного продкта при помощи поля ввода ВыбТовар:
"    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    //{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
//    |ОбрабатыватьДокументы все;

    |Обрабатывать НеПомеченныеНаУдаление;
    |Без итогов;        
    |ВидОтгрузки = Документ.РасходнаяНакладная.ВидОтгрузки;
    |РасхНакл = Документ.РасходнаяНакладная.ТекущийДокумент; 
     |Покупатель = Документ.РасходнаяНакладная.Контрагент;
    |Грузополучатель = Документ.РасходнаяНакладная.Грузополучатель;    
    |Товар = Документ.РасходнаяНакладная.Товар;
        |Договор = Документ.РасходнаяНакладная.Договор;
                       ...
    |Функция НДССумма = Сумма(НДС);
    |Функция ВсегоСумма = Сумма(Всего);
    |Функция СуммаСумма = Сумма(Сумма);
    |Функция КоличествоСумма = Сумма(Количество);
     |Группировка Товар без групп;
    |Группировка Покупатель без групп;
                       ...
    |Условие(ВидОтгрузки = 6);    
    |//}}ЗАПРОС

;    
     Если ВыбТовар.Выбран() = 1 Тогда
         ТекстЗапроса = ТекстЗапроса + " Условие(Товар в ВыбТовар);";
    КонецЕсли;

Теперь пользователи просят, чтобы можно было сформировать список товаров в виде списка с пометками и формировать запрос согласно продуктам занесенным в список. Сам список я создала и сделала обработки по его заполнению. Не подскажите, как в запросе сформировать условие по списку с пометками? Буду очень признательна.
 
 
   Guk
 
1 - 10.08.04 - 12:23
(0) Сформировать вспомогательный список, где будут только товары у которых стоит пометка в исходном списке...
   GrayT
 
2 - 10.08.04 - 12:23
Перепиши в другой СЗ только те у которых пометки
   Старина Z
 
3 - 10.08.04 - 12:27
спПомеченных = СоздатьОбъект("СписокЗначений");
Для Сч=1 По спТоваров.РазмерСписка() Цикл
    Если спТоваров.Пометка(Сч)=1 Тогда
        спПомеченных.ДобавитьЗначение(спТоваров.ПолучитьЗначение(сч));
    КонецЕсли;
КонецЦикла;
Условие(Товар в спПомеченных); 
//спТоваров - список на форме
   ken_gd
4 - 10.08.04 - 15:54
Спасибо, получилось!


Список тем форума
  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует