Вход | Регистрация

1С:Предприятие ::

Метки:

Работа с запросами

Я
   L
 
10.08.04 - 11:38
Почему то пишет "поле агрегатного обьекта не обнаружено (ПРОЧИЕ):2"
Процедура Сформировать() 
   Перем Запрос, ТекстЗапроса, Таб; 


   Запрос = СоздатьОбъект("Запрос"); 
   ТекстЗапроса = 
   "//{{ЗАПРОС(Сформировать) 

     | Период с ВыбНачПериода по ВыбКонПериода; 
     | Докум = Документ.ПКО.ТекущийДокумент,
     | Документ.РКО.ТекущийДокумент,
     | Документ.СтрокаВыпискиПриход.ТекущийДокумент,
     | Документ.СтрокаВыпискиРасход.ТекущийДокумент;
     | КодОперации = Документ.ПКО.КодОперации, 
     |               Документ.РКО.КодОперации, 
     |               Документ.СтрокаВыпискиПриход.КодОперации, 
     |               Документ.СтрокаВыпискиРасход.КодОперации; 
     | Группировка Докум; 
     | Условие(КодОперации = Перечисление.КодыОпераций.Прочие); 
    //|Без Итогов;

     |//}}ЗАПРОС 

     ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда 
       Возврат; 
   КонецЕсли; 

   Таб = СоздатьОбъект("Таблица"); 
   Таб.ИсходнаяТаблица("Сформировать"); 
   Таб.ВывестиСекцию("Заголовок"); 
   Пока Запрос.Группировка("Докум") = 1 Цикл 
       Док = Запрос.Докум;
  Таб.ВывестиСекцию("Строка");
КонецЦикла;
//Состояние("Заполнение выходной таблицы...");

   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0); 
   Таб.ТолькоПросмотр(1); 
   Таб.Показать("Сформировать", ""); 
КонецПроцедуры 

В таблице в СТРОКЕ выражение ДОК стоит
 
  Рекламное место пустует
   Волшебник
 
1 - 10.08.04 - 11:42
Не нужно создавать две одинаковые темы. Тщательнее формулируй заголовок. Желательно начинать его со слова "Как".
   Shadal
 
2 - 10.08.04 - 11:48
Посмотри в конфигураторе в перечислениях в кодахОпераций точно ли название "Прочие", может это синоним?
   GrayT
 
3 - 10.08.04 - 11:51
Это Торговля? "ПРочее"
   L
 
4 - 10.08.04 - 11:52
Делаю в комплексной
   L
 
5 - 10.08.04 - 11:54
Там ПРОЧЕЕ
   Shadal
 
6 - 10.08.04 - 12:14
Ну а ты пишешь прочие вместо прочее
   Shadal
 
7 - 10.08.04 - 12:42
ну так что вопрос решён?


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует