Вход | Регистрация


1С:Предприятие ::

Метки:

Для чего пишут условия, которые никогда не сработают? Если Ложь Тогда КонецЕсли

Я
   Shur1cIT
 
17.05.17 - 12:01
Нашел такой кусок, тут какой то сакральный смысл заложен или рудимент остался?
Организация = Выборка.Организация;
        Если Ложь Тогда Организация = Справочники.Организации.СоздатьЭлемент(); КонецЕсли; 
        ОрганизацияРеквизиты = "ОГРН " + Организация.ОГРН + ", ИНН/КПП " + Организация.ИНН;
        ДанныеОбъекта.Вставить("ОрганизацияРеквизиты", ОрганизацияРеквизиты);
 
  Рекламное место пустует
   Stepa86
 
1 - 17.05.17 - 12:02
Подсказка синтаксис помощнику, чтоб он начал показывать что там у организации после точки
   _Batoo
 
2 - 17.05.17 - 12:03
(1)

Гениально)
   Shur1cIT
 
3 - 17.05.17 - 12:03
(1) Хм первый раз с таком столкнулся) хорошая идея
   1Снеговик
 
4 - 17.05.17 - 12:03
Оригинально)
Надо запомнить)
   lodger
 
5 - 17.05.17 - 12:06
+1. забавно. я обычно подсказываю СП так
перем = справочник.номенклатура.пустаяссылка();
и потом огребаю проблем когда забываю снести эту строчку...
   Волшебник
 
Модератор
6 - 17.05.17 - 12:07
(1) дебилизм какой-то
   Fragster
 
7 - 17.05.17 - 12:10
(6) норм.есть еще вариант
#Если Сервер и не Сервер
  А тут все определения
#КонецЕсли
   Ёпрст
 
8 - 17.05.17 - 12:10
(6) ?
норм идея,  же.

зато в пофигураторе, после точки доступны все методы объекта
   Stepa86
 
9 - 17.05.17 - 12:12
(7) А ты тоже удивлен, что все эти люди с длинными полосочками про этот финт не очень в курсе?
   Волшебник
 
Модератор
10 - 17.05.17 - 12:14
(7) Месье знает толк в извращениях...
 
  Рекламное место пустует
   Ёпрст
 
11 - 17.05.17 - 12:15
(9) це же [:]|||||||||[:]
   Вафель
 
12 - 17.05.17 - 12:15
(7) нужно раскладку переключать - неудобно
   Волшебник
 
Модератор
13 - 17.05.17 - 12:16
(9) у нас в Java строгая типизация, типы всех переменных известны, поэтому такие финты не нужны
   Ёпрст
 
14 - 17.05.17 - 12:16
(12) если есть снегопат, то ничего не надо
ну или шаблоны настроить
   Fragster
 
15 - 17.05.17 - 12:18
(12) не нужно. я пользуюсь раскладкой Чистова - там есть нужные символы. ну и шаблон можно свой сделать (но я не делаю, так как в падлу и есть раскладка Чистова)
случай с областью позволяет писать подобные подсказки для "возможно присутствующих" общих модулей, и синтакс контроль не ругается. спасибо TormozIT за идею
   Fragster
 
16 - 17.05.17 - 12:18
Чистова = @Groovy
   Fragster
 
17 - 17.05.17 - 12:19
   Ёпрст
 
18 - 17.05.17 - 12:20
#Если Сервер и не Сервер , надо запомнить
)
   mehfk
 
19 - 17.05.17 - 12:21
Еще короче
#Если _ Тогда
   Вафель
 
20 - 17.05.17 - 12:24
(16) Не всегда можно свою раскладку поставить
   Sиlьver
 
21 - 17.05.17 - 12:30
Встречался с таким вариантом использования конструкции:
Заменяемый типовой код не удаляется, а помещается в условие Когда Ложь Тогда, а свой код в блок Иначе.
В результате удобно сравнивать при обновлении и всегда видно как было раньше.
   Fragster
 
22 - 17.05.17 - 12:31
(20) это да... но я уже подсел... без нее не могу :)
   Вафель
 
23 - 17.05.17 - 12:32
(21) Так обычно при доработках и не удаляют. а комментируют
   Dotoshin
 
24 - 17.05.17 - 12:34
(13) >>у нас в Java строгая типизация...
Как? И Вы тоже соскочили с 1с?
   Sиlьver
 
25 - 17.05.17 - 12:35
(23) если ты закомментил кусок кода, то он уже не будет соответствовать тому же куску кода из обновления при сравнении. Удобство пострадает.
   Сильф
 
26 - 17.05.17 - 12:36
(5) такая ж фигня )

(1) (21) надо запомнить, век живи - век учись ))
   drcrasher
 
27 - 17.05.17 - 12:39
(19) уже не работает
   Stepa86
 
28 - 17.05.17 - 12:53
(13) У всех языков есть плюсы и минусы и есть финты и костыли для обхода этих минусов. В EDT динамическая типизация, когда СП подтягивает информацию о типе из дерева вызовов.
   Я не курил
 
29 - 17.05.17 - 13:05
   lubitelxml
 
30 - 17.05.17 - 13:06
#Если Сервер и не Сервер - вот это не видел, а сабж в (0) древний баян
   mehfk
 
31 - 17.05.17 - 13:07
(27) Наглая ложь
   Фокусник
 
32 - 17.05.17 - 13:10
(14) >"Организация = Выборка.Организация;"

Снегопат и из результата запроса вытянет информацию? А если запрос с динамическим текстом?
   Волшебник
 
Модератор
33 - 17.05.17 - 13:13
(24) Вы не поверите. По трудовой книжке, я никогда не был программистом 1с
 
  Рекламное место пустует
   Ёпрст
 
34 - 17.05.17 - 13:15
(32) ответ был про переключение расскладки клавиатуры.
   ildary
 
35 - 17.05.17 - 13:31
(21) интересная конструкция, надо попробовать.
   Dotoshin
 
36 - 17.05.17 - 13:42
(33) Так по трудовой наверно никто не был. У меня тоже просто программист записано...
   Волшебник
 
Модератор
37 - 17.05.17 - 13:44
(36) Вот-вот. У меня даже "программист" не было
   Fish
 
38 - 17.05.17 - 13:45
(36) У меня было написано программист 1С :)
   1Снеговик
 
39 - 17.05.17 - 13:49
(38) ты крут, а мы все инженеры да инженеры
   Dotoshin
 
40 - 17.05.17 - 13:52
(38) Это самоуправство и произвол вашего ОК :)
Такой профессии, согласно классификатору нет, есть только:
25857  3 Программист
22824  3 Инженер-программист 
27099  9 Техник-программист
42843  8 Инженер-системный программист
   Asmody
 
41 - 17.05.17 - 13:53
(13) Если бы java перевели на русский, это была бы песня:

Самовар мойСамовар = новый Самовар();
   Fragster
 
42 - 17.05.17 - 13:54
(36) по трудовой я был сначала веб программистом, потом специалист по разработке информационных систем, а потом уже ххх 1с в разных ипостасях. правда сейчас маятник в обратную сторону пошел (но должность та же).
   Волшебник
 
Модератор
43 - 17.05.17 - 13:57
(41) LOL!
   Dotoshin
 
44 - 17.05.17 - 13:58
(42) >> ххх 1с в разных ипостасях.
Жесткий Секас с 1С? :)))
   Fragster
 
45 - 17.05.17 - 14:00
(44) типа того
   kyvv
 
46 - 17.05.17 - 14:02
(24)Надо смотреть вперед. На смену SAP R3 пришла SAP HANA, а там java and js, eclipse.
   kyvv
 
47 - 17.05.17 - 14:16
А там, глядишь, пофигуратор от JetBrains появится.
   Вафель
 
48 - 17.05.17 - 14:23
(21) Прям очень похоже на 1С



Список тем форума
Рекламное место пустует  
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует