Вход | Регистрация

1С:Предприятие ::

Метки:

Как можно открыть форму активных пользователей, если нет кнопки "Все функции"

Я
   SeiOkami
 
21.04.17 - 15:16
Может ли пользователь, у которого нельзя использовать "Все функции" открыть сервисную обработку "Активные пользователи" ?
 
  Рекламное место пустует
   ildary
 
1 - 21.04.17 - 15:17
(0) где-то пробегал список ссылок на служебные окна для УФ. На неназываемом сайте вроде бы его публиковала ekaruk.
   ildary
 
2 - 21.04.17 - 15:18
   SeiOkami
 
3 - 21.04.17 - 15:19
да, но это ссылки для сохранения
а мне бы открыть
как навигационные ссылки они не воспринимаются
   ildary
 
4 - 21.04.17 - 15:23
(3) в (2) упоминается такой способ:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ИмяОбработки = ПодключитьВнешнююОбработкуНаСервере(); 
    Если ИмяОбработки = "StandardFindByRef" Тогда
      ОткрытьФорму("ВнешняяОбработка.StandardFindByRef.Форма");
    Иначе
      Предупреждение("Не удалось подключить внешнюю обработку!");
    КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ПодключитьВнешнююОбработкуНаСервере()
    ИмяОбработки = ВнешниеОбработки.Подключить("v8res://mngbase/StandardFindByRef.epf", "StandardFindByRef", Ложь);
Возврат ИмяОбработки;
КонецФункции
   ildary
 
5 - 21.04.17 - 15:23
Я сам не пробовал, если что...
   drcrasher
 
6 - 21.04.17 - 15:24
(0) если администрирование доступно, то из соответствующего раздела
   SeiOkami
 
7 - 21.04.17 - 15:26
нет, мне не кодом нужно
просто в режиме предприятия пользователь должен как-то открыть "Активные пользователи", если у него нет кнопки "Все действия"
может есть горячая клавиша какая-нить или навигационная ссылка или что-то ещё
   ildary
 
8 - 21.04.17 - 15:32
(7) У Вас странное понимание 1С. Да и вообще компьютерных программ в целом. Зачем 1С делать горячую клавишу для окна, запрещенного пользователю? И в чем грех написать обработку с кнопкой, которая откроет это окно? Можно не отвечать, я так, вслух удивляюсь.
   Митяйский
 
9 - 21.04.17 - 15:35
Ссылку видел только в "администрировании-подержке и обслуживании" и в других обработках типа "удаления помеченнных". Так что если по каким-то соображениям нельзя пользователю дать право на кнопку "все функции", то внешняя обработка с нужной самодельной кнопкой будет наименьшим из зол
   SeiOkami
 
10 - 21.04.17 - 15:43
(8), окей, если я проставлю роли совершенно все права, кроме доступа к "Все функции", то как мне открыть сервисную обработку Активные пользователи? Есть ли чисто платформенный способ или для этого нужно писать свой код?
 
 
   Вафель
 
11 - 21.04.17 - 15:43
(10) сохрани как внешнюю и открывай
   SeiOkami
 
12 - 21.04.17 - 15:44
есть ли платформенный способ?
   Dmitrii
 
13 - 21.04.17 - 15:44
(10) Конфигурацию озвучь.
Во всех типовых на основе БСП уже есть эта обработка. Так и называется - АктивныеПользователи.
   SeiOkami
 
14 - 21.04.17 - 15:46
(13), платформенный
это значит, что независимо от конфигурации
просто пустышка
   Вафель
 
15 - 21.04.17 - 16:03
но мне кажется чтоб получить список активных нужно иметь право администрирования
   SeiOkami
 
16 - 21.04.17 - 16:15
(15), у пользователя есть ВСЕ ПРАВА, кроме "Режим Все функции"
   Вафель
 
17 - 21.04.17 - 16:35
(16) а зачем так?
   Вафель
 
18 - 21.04.17 - 16:35
Если у него есть все права, то он может себе добавить и права на все функции
   SeiOkami
 
19 - 21.04.17 - 16:37
(18), только если изменит роль в конфигураторе и обновит ИБ
   МимохожийОднако
 
20 - 21.04.17 - 17:25
(19) В пользовательском режиме тоже можно добавлять права.


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует