Вход | Регистрация

1С:Предприятие ::

Метки:

Как запретить очистку реквизита формы?

Я
   Вовчик
08.08.04 - 14:44
Процедура ПриНачалеВыбораЗначения(Идент,Фл)
    Если Идент="Фирма" Тогда
        ФирмаДоРедакт=Фирма;
        Сообщить(ФирмаДоРедакт);
    КонецЕсли;
КонецПроцедуры

При фактическом выборе значения реквизита "Фирма" сообщает его без проблем, а вот при очистке по SHIFT+F4 не сообщает ничего. Судя по всему при очистке данная процедура не запускается. Зачем надо? Нужен запрет на очистку значения данного реквизита, чтобы при попытке очистить в поле оставалось старое значение реквизита (до процедуры ИзмФирма).
 
  Рекламное место пустует
   SnarkHunter
 
1 - 08.08.04 - 14:53
Форма.Фирма.Доступность(0)
   NS
 
2 - 08.08.04 - 14:54
В формулу - Реквизита процедуру запихни....
перем послФирма;
Процедура ПриИзмФирмы()
  Если Фирма.Выбран()=1 тогда
     послФирма=Фирма;
  Иначе
     Фирма=послФирма;
  КонецЕсли;
КонецПроцедуры;
   Вовчик
3 - 08.08.04 - 15:08
(3) Не работает. При очистке Фирма.Выбран() становится равным 0. Поэтому срабатывает Фирма=послФирма, а т. к. послФирма также не имеет значения, то поле Фирма очищается.
   Вовчик
4 - 08.08.04 - 15:08
(3) к (2)
   NS
 
5 - 08.08.04 - 15:09
И куда делось значение в послфирма?
Какой строкой оно очистилось?
   ( . ) ( . )
6 - 08.08.04 - 15:18
(5) Чтоб куда-то деться, нужно сначала откуда-то взяться. Вводим новый документ, переменная-то сама инициализируется в начале модуля, но конкретное значение ей не передается.
   NS
 
7 - 08.08.04 - 15:20
(6) Ты это мне рассказываешь?
   ( . ) ( . )
8 - 08.08.04 - 15:22
7. Вам.
   SnarkHunter
 
9 - 08.08.04 - 15:23
Про документ упоминания не было... Равно как и про то, что запрет очистки должен позволять изменять реквизит...
 
А понять, что переменную послФирма нужно объявить соотвествующим образом и инициализировать - на это воображения не хватает...
   NS
 
10 - 08.08.04 - 15:24
(8) Спасибо, буду знать! ;-)
 
 


Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует