Вход | Регистрация

1С:Предприятие ::

Метки:

Не могу выташить Адрес Сотрудника из справочникаСотрудники в свой отчет!!

Я
   Оля
06.08.04 - 16:04
Конфиг ЗиК. Документ ПриказПриемНаРаботу формирует мой дополнит отчет, нужно чтоб в этот отчет попадал Адрес сотрудника, а он есть только в справочнике Сотрудники и то как Представление, которое я не знаю как выдернуть.
Всяк элементы справочника по сотруднику я вытащила, а представления (Адрес -> глПредставлениеАдреса(АдресПрописка) и Паспорт ->ПредставлениеДокумента(ДокументУдЛичность)) не могу!
Нужно чтоб по сотруднику искал и присваивал.
Может кто знает??? Помогите!!!
Может можно это представление присвоить еще одному ревизиту справочника?
Тоже не получаеться, наверно не то делаю???
 
  Рекламное место пустует
   insert
 
1 - 06.08.04 - 16:41
Ни хрена не понятно. АдресПрописка - обычная строка, даже не периодическая. Чего там твой отчет не "ищет" и не "присваивает"?
   Оля
2 - 06.08.04 - 16:46
ИНН = СоздатьОбъект("Справочник.Сотрудники");  
ИНН.НайтиПоКоду(ТабельныйНомер);
Сотр = ИНН.ТекущийЭлемент();
Если Сотрудник = Сотр Тогда
ИНН2 = ИНН.ИНН;
ССПФ = ИНН.СтраховойНомерПФР;
Паспорт = ??????; Здесь нет конкретного реквизита!!!!
   shura
 
3 - 06.08.04 - 16:46
глПредставлениеАдреса(Сотрудник.АдресПрописка)?
   shura
 
4 - 06.08.04 - 16:47
ДокументУдЛичность
   shura
 
5 - 06.08.04 - 16:48
(2) А зачем такие сложности?
   shura
 
6 - 06.08.04 - 16:50
ИНН2 = Сотрудник.ИНН; 
ССПФ = Сотрудник.СтраховойНомерПФР; 
Паспорт = ПредставлениеДокумента(Сотрудник.ДокументУдЛичность);
Адрес = глПредставлениеАдреса(Сотрудник.АдресПрописка);
   shura
 
7 - 06.08.04 - 16:51
Функция ПредставлениеДокумента(Документ)
    Представление = "";
    СЗ = глРазложитьДокУдостоверяющийЛичность(Документ);
    Для Номер = 1 по СЗ.РазмерСписка() Цикл
        Если ПустоеЗначение(СЗ.ПолучитьЗначение(Номер))=0 Тогда
            Представление = Представление+?(ПустоеЗначение(Представление)=1,"",", ")
                            +?(Номер=2,"Серия: ",
                             ?(Номер=3,"",
                             ?(Номер=4,"Выдан: ","")))
                            +СокрЛП(СЗ.ПолучитьЗначение(Номер))
        КонецЕсли;
    КонецЦикла;
    Возврат ?(ПустоеЗначение(Представление)=1,"<<Нет данных>>",Представление)
КонецФункции   // ПредставлениеДокумента
   shura
 
8 - 06.08.04 - 16:51
+(7) тоже должно быть в модуле формы документа о приеме (если ее там нету)
   shura
 
9 - 06.08.04 - 16:52
Блин, приятно поговорить с умным человеком ...
А потом и говорят: флуд...
   Michael99
 
10 - 06.08.04 - 16:55
Адрес и паспорт хранятся в справочнике сотрудники в структурированных строках
Процедуры ПредставлениеАдреса и ПредставлениеДокумента нужны для визуализации и к значениям реквизитов справочника отношения не имеют.
PS . Рекомендация : Уменьшить количество ИНН-ов в коде , а то легко запутатся .
:-)
 
 
   Оля
11 - 06.08.04 - 16:56
Спасибо shura !!! Заработало!!!
Это отделу кадров нужно, чтоб договора сразу подкреплялись!!
А еще случайно не знаешь?? как в отчете который можно редактировать
если текст не влезает то добовлялись строки. Что то типа если нажать enter то добовлялась новая строка(как в стондартном worde).
   shura
 
12 - 06.08.04 - 17:04
А как в стандартном excel-e не пойдет? Я word не очень хорошо знаю ;)


Список тем форума
  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует