Вход | Регистрация


1С:Предприятие ::

Метки:отчеты

2 прихода 2 расхода

Я
   povar
 
06.08.04 - 14:13
формирую товарный отчет (товар-приход-расход-прибыль), проблема в том, что по некоторым позициям существуют 2 прихода и 2 расхода, когда формируется отчет, в него попадает либо 1 приход - 2 расход либо 2 приход - 1 расход (в зависимости от порядка выборки документов). Необходимо, чтобы 1 приходу соответствовал 1 расход,а 2 - 2 расход.
 
  Рекламное место пустует
   Старина Z
 
1 - 06.08.04 - 14:15
Поподробнее пожалуйста, откуда берешь информацию о приходах и расходах и как группируешь?
   povar
 
2 - 06.08.04 - 14:20
Вот кусок кода
.
ПрихДок=СоздатьОбъект("Документ.ПриходнаяАвто");
РасхДок=СоздатьОбъект("Документ.РасходнаяАвто");
Карт=СоздатьОбъект("Документ.Карточка");
РасхДок.ВыбратьДокументы(ДатаНач,ДатаКон);
Пока РасхДок.ПолучитьДокумент()=1 Цикл
    Если РасхДок.Фирма=ВыбФирма ТОгда
        РасхДок.ВыбратьСтроки();
        Пока РасхДок.ПолучитьСтроку()=1 Цикл
            Авто=РасхДок.Автомобиль;
            ПрихДок.ОбратныйПорядок(Обратно());
            ПрихДок.ВыбратьДокументы(ДатаНач,ДатаКон);
            Пока ПрихДок.ПолучитьДокумент()=1 Цикл
                ПрихДок.ВыбратьСтроки();
                Пока ПрихДок.ПолучитьСтроку()=1 Цикл
                    Если Найти(Строка(ПрихДок.VIN),СокрЛП(Авто))>0 Тогда
                        ВИН=СокрЛП(ПрихДок.VIN);
                        ТЗ.НоваяСтрока();
                        ТЗ.Модель=ПрихДок.Модель;
                        ТЗ.ВИН=ВИН;
                        ТЗ.ЦенаПрих=ПрихДок.Цена;
                        ТЗ.ЦенаРАсх=РасхДок.Цена;
                        ТЗ.Покупатель=РасхДок.Контрагент;
                        ТЗ.Поставщик=ПрихДок.Контрагент;
                   //Иначе

                   //    Продолжить;

                    КонецЕсли;
                КонецЦикла;
            КонецЦикла
        КонецЦикла;
   //Иначе

   //    Продолжить;

    КонецЕсли;
КонецЦикла; 

То есть открываю расходную накладную, выбираю товар, потом ищу его в приходе.
Можно конечно все запросом сделать, но тогда я совсем не вижу как поставить соответсвие 2 приходам и 2 расходам
   SnarkHunter
 
3 - 06.08.04 - 14:23
Надо что-то в консерватории менять..
   Valery
 
4 - 06.08.04 - 14:26
Да ты так ничего не получишь. Регистры необходимо использовать. Там есть вся информация и партионный учет тоже. Так-что перепиши все через регистры.
   povar
 
5 - 06.08.04 - 14:27
Snark-ты конечно умный малый, но лучше помоги конструктивно, чем остроумно
   Valery
 
6 - 06.08.04 - 14:28
Смотрика VIN у тебя уже появился?
   SnarkHunter
 
7 - 06.08.04 - 14:28
Мне лень... Я сейчас закончил искать ошибку в запросе на четыре сотни строк... Мой пыл иссяк...
   Michael99
 
8 - 06.08.04 - 14:30
Вообщето подобные вещи реализуются через партионный учет.
В таком виде ситуация слишком похожа на надуманную.
Что например будет если по двум приходам 1 расход ,
или чередующиеся приходв расходы на разное количество.
Количество совсем не последняя вещь в этом вопросе.
И кстати посему выборка документов прихода и расхода за одинаковый период?
   Старина Z
 
9 - 06.08.04 - 14:31
(0,2) А если у тебя количество прихода, например, 5 и 10, а расхода - 7 и 8. Какой и когда будешь брать?
Тебе нужно организовать учет партий. Для этого удобнее всего использовать регистр остатков с измерением "Партия".
При приходе пишешь в него текущий документ, а при расходе - списываешь в зависимости от того, какую методику вы используете: FIFO (т.е. первыми списываются партии, которые пришли раньше), LIFO (первыми списываются пришедшие позже) или другую
   Valery
 
10 - 06.08.04 - 14:31
У тебя вообще учет партий существует. Если нет, то делай все по средней цене.
 
  Рекламное место пустует
   povar
 
11 - 06.08.04 - 14:35
(8) Ситуация такая:
!
1)К нам пирходит автомобиль по цене (например)- 100 000 (1 приход)
2) Мы его продаем дилеру по цене 100 100 (1 расход)
3) Он продает ее нам обратно 100 200 (2 приход)
4) Мы его продаем окончательно :) 200 000 (2 расход)
   povar
 
12 - 06.08.04 - 14:39
(8) Такой ситуации не может быть (всегда 2 прих-2 расх)
   Michael99
 
13 - 06.08.04 - 14:46
Наперсточники какие-то , туда сюда обратно :-)

Если уникальность определяется по VIN.
то можно сделать двумя способами.
1 Бух.
Забалансовый счет с субконто Модель, VIN
Приход проводки в кредит счета по субконто
Расход проводки в дебет соотв счета
Забалансовй счет Наличие с соотв субконто
Приход Кредит 1
Расход дебет 1
Твой доход это грамотная выборка по этим двум счетам.

На компоненте опер учет примерно тоже самое только на регистрах.
   povar
 
14 - 06.08.04 - 14:51
(13) Что то не совсем понял если можешь, распиши чуть подробнее и с участием регистров. Существует регистр ОстаткиАвтомобилей(измерения:Фирма,Склад,ВИН;ресурсы:Остаток,себестоимость)
   SnarkHunter
 
15 - 06.08.04 - 14:54
(14)Интересно, ты там кем подвизаешься?
   povar
 
16 - 06.08.04 - 14:56
(15)Лень отвечать..
   Kopyl
 
17 - 06.08.04 - 14:58
(14)Ого, хпопец, тебе надо с самого начала всё изучать.
Бери книжку или ищи примерыв инете "применения регистров для учета остатков", "партионный учет", если тута подробно рассказывать то ветка будет самая запостованная..
   povar
 
18 - 06.08.04 - 15:04
(17) так я с начала и изучаю
   Michael99
 
19 - 06.08.04 - 15:05
В этом или аналогичном регистре заведи еще реквизиты
Количество покупок и количество продаж и сумма
движения по регистру надеюсь понятны
Промежуточный доход это остаток по ресурсу Сумма при количестве покупок = количеству продаж и равной 1
Окончательный доход это остаток по ресурсу Сумма при количестве покупок = количеству продаж и равной 2
   SnarkHunter
 
20 - 06.08.04 - 15:05
Сочувствую твоим подопытным кроликам в лице работодателей...
   vS
21 - 06.08.04 - 20:38
Snark'y запрос то забодал? Надо будет на тяпницу след. прийти... приходи, есть версия что у меня будет повод проставляться :-)
   427
 
22 - 06.08.04 - 21:14
(21) так так так .... с этого места подробнее...
   spock
 
23 - 07.08.04 - 11:48
2(21)Я поддерживаю (22) оратора, просим-просим.



Список тем форума
 
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует