Вход | Регистрация

1С:Предприятие ::

Метки:

Выбор значения из справочника. Просто любопытно.

Я
   maloy
 
06.08.04 - 11:18
Посмотрел как в типовой торговле 9.2 из справочника цен выбирают единицу и появились сомнения: может я чего не замечаю.
Процедура такая:
Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр)
    Перем Параметр;    
    Если ИдентЭлемДиалога = "Единица" Тогда
        ФлагСтандОбр = 0;
        Параметр = Владелец.ТекущийЭлемент();
        ОткрытьФорму("Справочник.Единицы", Параметр);    
        Если Форма.МодальныйРежим() = 1 Тогда
            Единица = Параметр;
            ПриИзмененииЕдиницы();
        КонецЕсли;
    КонецЕсли;                             
КонецПроцедуры // ПриНачалеВыбораЗначения()
Вопрос: справочник единиц понимает что его открыли для выбора значения?
Почему? Это что документированное поведение платформы?
Форма списка справочника цен открывается немодально.
 
  Рекламное место пустует
   Crew
 
1 - 06.08.04 - 11:22
Берется форма для выбора, как она установлена в свойствах справочника
   maloy
 
2 - 06.08.04 - 11:29
Да? И где об этом написано?
Открывают же не подбор, а просто форму.
Почему есть разница? Потому что, вызывается в теле процедуры
ПриНачалеВыбораЗначения() ?
   lexa
 
3 - 06.08.04 - 11:48
Единица тмеет тип Справочник.Единицы, поэтому при выборе открывается форма списка для выбора (см Справочник.Единицы), поскольку Справочник.Единицы подчиненный справочник то в приведенной тобой процедуре указывают владельца элементов этого справочника
   maloy
 
4 - 08.08.04 - 06:59
(3) неубедительно.
Если заметил, то ФлагСтандартнойОбработки устанавливается в 0.
Т.е. стандартный выбор значения не происходит, и форма для выбора не открывается. Её открывают. При этом открывают не для подбора значения, а просто открывают....
То что передают владельца в качестве параметра - это понятно.
Почему же она работает именно как форма для выбора значения??????
Если можно, то страничку из ЖКК.
   SnarkHunter
 
5 - 08.08.04 - 08:23
ПриНачалеВыбораЗначения
Предопределенная процедура при начале выбора значения.
...
...
Замечание. В теле этой процедуры методы ОткрытьФорму и ОткрытьПодбор работают ДЛЯ ВЫБОРА.
   SnarkHunter
 
6 - 08.08.04 - 08:25
(+5)ЖКК: ОВЯ, ч.2, гл. 30, стр.708
   maloy
 
7 - 08.08.04 - 09:43
О, точно!!! Большой рахмад!!!
У меня, правда, почему то стр. 707 :))
   SnarkHunter
 
8 - 08.08.04 - 13:39
Замечание, поясняющее "непонятное поведение", именно на 708...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует