Вход | Регистрация

1С:Предприятие ::

Метки:коллекции значений

Помогите начинающему: ТЗ

Я
   AlexNV
 
05.08.04 - 13:38
у меня есть таблица значений со следующими полями: поставщик, группатмц, номенклатура. Как мне пройтись по данной ТЗ, как при прохождении запроса (т.е. сначала надо вывести поставщика, затем группы, затем тмц)
 
 
   AlexNV
 
1 - 05.08.04 - 13:46
Эффект примерно следующий должен получиться
 Поставщик=ТЗ.Поставщик;
 пока запрос.групировка(2) цикл
 Группа = ТЗ.Группа ;
  пока запрос.групировка(3) цикл
   ТМЦ = ТЗ.ТМЦ;
  конеццикла;
 конеццикла;
конеццикла;
   Guk
 
2 - 05.08.04 - 13:52
(0) Предвижу, что если в эту ветку придут NS, Iam, Рупор абсурда и иже с ними, то назовут меня тупым бараном, ничего не понимающим в алгоритмах, но все же осмелюсь предложить наиболее простой в понимании начинающего, способ.
Сделать  3 ТЗ и тройной цикл по подчиненым ТЗ. Получится как в запросе...
   Юрий
3 - 05.08.04 - 13:56
Мне очень нравится метод  <Свернуть>.
Я использую его всегда при создании отчётов вместо запросов, т.к. запросы часто виснут. Обычно приходится делать комбинацию из двух-трёх таблиц: самая свёрнутая даёт данные для заголовков или шапок, а остальные дают разбивку по группам и строкам.
В Вашем случае я бы начал так:
ТЗ.Свернуть("поставщик,группатмц,номенклатура","Кол-во,Сумма, ... и т.п. ");
Часто бывает надо до или после свёртки делать сортировку.
   Эмблема форума
 
4 - 05.08.04 - 13:57
В любом случае придётся программировать ...
   Guk
 
5 - 05.08.04 - 14:03
(3) Начал хорошо. Не разменивайся на детали (с)...
   lexa
 
6 - 05.08.04 - 14:07
отсортируй по эти трем колонкам, введи переменные ТвойПоставщик, Твоя группа
ТвойПоставщик = "";
ТвояГруппа = "";
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку = 1 Цикл
   Если ТЗ.Поставщик <> ТвойПоставщик Тогда
       ТвойПоставщик = ТЗ.Поставщик;
      //Начало 1 группировки

       ТвояГруппа = ТЗ.Группа;
      //Начало 2 группировки

   КонецЕсли;
   Если ТЗ.Группа <> ТвояГруппа Тогда
       ТвойПоставщик = ТЗ.Поставщик;
        //Начало 2 группировки

   КонецЕсли;
КонецЦикла;
   Кофеин
7 - 21.12.04 - 13:23
А не проще ТЗ.Сортировать("Поставщик, ГруппаТМЦ, Номенклатура"); ?


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует