Вход | Регистрация

1С:Предприятие ::

Метки:

Подскажите с закладками, а то я запарился

Я
   Kopyl
 
04.08.04 - 14:39
Вот что есть
Процедура  ПриОткрытии()    
    Форма.ИспользоватьЗакладки(1);   
    Форма.Закладки.ДобавитьЗначение("Основной","Основной");
    Форма.Закладки.ДобавитьЗначение("СписокДок","Документы"); 
    Форма.ИспользоватьСлой("Основной");
КонецПроцедуры                         
//*************************************

Процедура ПриВыбореЗакладки(Номер,Значение)
    Форма.ИспользоватьСлой("Общий,"+Значение,2);
КонецПроцедуры
//*************************************
Тут все работает без приколов, но вот тута- Обраборка, когда просто нажата кнопка "Просмотреть"
//*************************************

Процедура  Просмотреть()
    Форма.ИспользоватьСлой("СписокДок");
КонецПроцедуры  
----------
Слой переключает а закладка остается активная первая,
как мне ативизировать вторую казладку "Документы", при нажатии на кнопку?
 
 
   SnarkHunter
 
1 - 04.08.04 - 14:45
Форма.Закладки.ТекущаяСтрока(2)
   Kopyl
 
2 - 04.08.04 - 15:20
Спасибо...


Список тем форума
Рекламное место пустует  
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует