Вход | Регистрация

1С:Предприятие ::

Метки:

Позицирование в списке справочника

Я
   David
 
04.08.04 - 10:27
Как установить указатель на нужную строку в списке (форме списка) справочника. В табл.части документа это АктивизироватьСтроку().
 
 
   ABZ
1 - 04.08.04 - 10:35
Активизировать()
   Press
 
2 - 04.08.04 - 10:56
АктивизироватьОбъект(<Объект>)
   David
 
3 - 04.08.04 - 11:11
Если использовать Активизировать() или АктивизироватьОбъект(<Объект>) выдается сообщение "В данной формуле не может быть вызвана эта процедура(функция)"
вот мой код, может что не так, используется в форме списка справочника (открытого)
Процедура ОбрИскатьПо()
    Если ПустоеЗначение(ИскатьПО) = 0 Тогда
        Спр = СоздатьОбъект("Справочник.Оборудование");
        Спр.ВыбратьЭлементы();
        Пока ((Спр.ПолучитьЭлемент() > 0)И
НайтиСокрЛП(Спр.Обозначение),СокрЛП(ИскатьПО)) = 0)) Цикл
        КонецЦикла;
        Сообщить(Спр.Обозначение," ");
        Спр = Спр.ТекущийЭлемент();
        АктивизироватьОбъект(Спр);//или Активизировать()

    КонецЕсли;
КонецПроцедуры
   skunk
 
4 - 04.08.04 - 11:16
АктивизироватьОбъект(Спр.ТекущийЭлемент());
   Press
 
5 - 04.08.04 - 11:34
   David
 
6 - 04.08.04 - 11:51
Попробовал, вот результат

АктивизироватьОбъект(Спр.ТекущийЭлемент());
{Справочник.Оборудование.ФормаСписка.ФормаСписка.Модуль(46)}: В данной формуле не может быть вызвана эта процедура(функция)
   dnp
7 - 04.08.04 - 11:57
а из откуда вызывается Процедура ОбрИскатьПо()?
проблема в этом..
   GrayT
 
8 - 04.08.04 - 12:00
(6) а по ссылке в (5)ходил?
   David
 
9 - 04.08.04 - 12:12
Сходил по ссылке, проблему понял, буду пробовать.
Спасибо за помощь.


Список тем форума
Рекламное место пустует  
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует