Вход | Регистрация

  1  2   
1С:Предприятие ::

Метки:документы

Как получить цену номенклатуры из последнего документа

Я
   Umka-Kate
 
03.08.04 - 16:01
мне нужно изменить цены в справочнике, документом.
при некоторых условиях мне нужно по определенной позиции номенклатуры получить ее цену из последнего документа "реализация"
как это сделать?
 
 
   Crew
 
1 - 03.08.04 - 16:04
Сделай выборку документов и ОбратныйПорядок(<Режим>)
   Валентин
 
2 - 03.08.04 - 16:05
или по регистру - находишь последний документ двигающий товар
   Валентин
 
3 - 03.08.04 - 16:05
или по регистру - находишь последний документ двигающий товар
   Umka-Kate
 
4 - 03.08.04 - 16:06
(1) а как проверить есть ли в данном документе данная номенклатура?
проверять по очереди?только так?
   Umka-Kate
 
5 - 03.08.04 - 16:07
(2) я - чайник...
можно поподробнее?..
   Filippych
 
6 - 03.08.04 - 16:08
док = СоздатьОбъект("Документ.Реализация");
Док.ОбратныйПорядок(1);
Док.ВыбратьДокументы();
Док.ПолучитьДокумент();

так ты спозиционирован(а) на последний док реализация. Успехов. дальше Сам(а)
   SiMazx
 
7 - 03.08.04 - 16:12
(6) ПоследнийДокРеализации<>ПоследнийДокРеализацииСНужнойНоменклатурой
   SnarkHunter
 
8 - 03.08.04 - 16:12
Документов в базе года за три... Ох и скорость будет...
   SiMazx
 
9 - 03.08.04 - 16:13
ПоследнийДокРеализацииСНужнойНоменклатурой<>ПоследнийПроведенныйДокРеализацииСделавшийДвижениеПоЭтойНоменклатуре
   Umka-Kate
 
10 - 03.08.04 - 16:15
(6) спасибо на это как раз мозгов хватило...)
просто если проверять все документы в обр порядке на наличие опред номенклатуры очень долго(4247 позиций номенклатуры)
 
  Рекламное место пустует
   Filippych
 
11 - 03.08.04 - 16:16
Ном = Создатьобъект("Справочник.номенклатура");
...
Док.выбратьСтроки();
Пока Док.ПолучитьСтроку() = 1 Цикл
  Если Док.Номенклатура = <то что нужно> Тогда
    Ном.Установить(Док.ДатаДок, Док.Цена);
  КонецЕсли;
КонецЦикла;
   Filippych
 
12 - 03.08.04 - 16:17
(7) ошибся я. тогда переберай все доки, в обратном порядке.
   Asmodeus
 
13 - 03.08.04 - 16:24
А если через запрос?
Условие - нужный товар. Перечень  возможных документов. Группировка День, упорядочить в обратном порядке (правда, не знаю - можно ли упорядочивание в обратном порядке делать?)
   SiMazx
 
14 - 03.08.04 - 16:28
(13)А зачем группировка День?
   SnarkHunter
 
15 - 03.08.04 - 16:29
Обход группировки можно в обратном порядке делать...
   Art-soft
16 - 03.08.04 - 16:30
Помоему через регистр гораздо проще
   Asmodeus
 
17 - 03.08.04 - 16:31
(14) Ну, чтобы, типа самый последний документ быстрее выловить... Я ее не использовал ни разу, но узнал о ней с удовольствием, т.к. хотел какую-то инфу представлять на временной оси... :-)
   Asmodeus
 
18 - 03.08.04 - 16:32
Клево, блин! Мало того, что у меня этот топик неправильно отражается (не влезает в экран), так еще и ответ мой сожрал!
   Asmodeus
 
19 - 03.08.04 - 16:33
О! Появился! Обновить нажимал - поэтому ногами не пинайте... А за пределы экрана все равно вылазит...
   Umka-Kate
 
20 - 03.08.04 - 16:34
(16)мне тоже так кажется
только подскажите как это сделать...
а то даже запросом очень долго будет
   SnarkHunter
 
21 - 03.08.04 - 16:38
Чем решать задачу переборами и запросами, не проще ли хранить "цену из последнего документа реализация" в том же справочнике Номенклатура?
   Art-soft
22 - 03.08.04 - 16:42
Регистр.УстановитьФильтр(номенклатура);
Регистр.ВыбратьДвижения();
Далее ищеш (как удобно) последнее движение в полученной выборке и
Док=Регистр.ТекущийДокумент();(Получаеш документ, выполневший движение)
а дальше все просто...
   Art-soft
23 - 03.08.04 - 16:46
(+22)Так точнее
Регистр.УстановитьФильтр(номенклатура); 
Регистр.ОбратныйПорядок(1);
Регистр.ВыбратьДвижения(); 
Регист.ПолучитьДвижение();
Док=Регистр.ТекущийДокумент();(Получаеш документ, выполневший движение)
а дальше все просто...
   Umka-Kate
 
24 - 03.08.04 - 16:48
(21) задача поставлена
я ее не могу менять... придется тогда  все документы проводить..

(22) спасибо сейчас попробую
   Asmodeus
 
25 - 03.08.04 - 16:53
А страница этого топика не у всех шире экрана? Это только мне так "повезло"?
   Umka-Kate
 
26 - 03.08.04 - 16:53
(25) у меня тоже глюк
   SiMazx
 
27 - 03.08.04 - 16:57
(25,26) Это я виноват... Смотрите (9)
   Umka-Kate
 
28 - 04.08.04 - 11:32
продолжаю разговор...(
сделано вот так:
    Рег = СоздатьОбъект("Регистр.ОстаткиТМЦ"); 
                                                
                        Рег.УстановитьФильтр(,Номенклатура,,);
                        Рег.ОбратныйПорядок(1);
                        Рег.ВыбратьДвижения();
                                Пока Рег.ПолучитьДвижение()<>0 Цикл 
                                                        Док = Рег.ТекущийДокумент(); 
                            Рег.ТекущийДокумент().ВыбратьСтроки(); 
                            Пока Рег.ТекущийДокумент().ПолучитьСтроку()=1 Цикл
                                Если Рег.ТекущийДокумент().Номенклатура=Номенклатура Тогда   
                                    ЦенаН=Рег.ТекущийДокумент().Цена;
                                КонецЕсли;
                            КонецЦикла; 
                                                                            КонецЦикла;  

в отладчике выбратьдвижения()=1
а получитьдвижение()=0

где может быть ошибка?
   Asmodeus
 
29 - 04.08.04 - 11:34
(28) В номенклатуре, видимо... Как позиционируешь?
   Umka-Kate
 
30 - 04.08.04 - 11:35
еще позиционируется только на одном документе(непонятно как его находит)
   Asmodeus
 
31 - 04.08.04 - 11:36
+(28)
Спр=СоздатьОбъект("Справочник.Номенклатура");
Спр.НайтиПоКоду(Номенклатура.Код);//например


   Рег.УстановитьФильтр(,Номенклатура,,);

заменить на

   Рег.УстановитьФильтр(,Спр.ТекущийЭлемент(),,);
   Umka-Kate
 
32 - 04.08.04 - 11:36
(29) номенклатура правильно выбирается...
   Umka-Kate
 
33 - 04.08.04 - 11:38
ето в функции, туда номенклатура правильно передается
 
  Рекламное место пустует
   Asmodeus
 
34 - 04.08.04 - 11:39
А ты попробуй... :-)
   Stan from Piter
 
35 - 04.08.04 - 11:51
(28)
1. А зачем переменная Док?
2. "Рег.ПолучитьДвижение()<>0" проверка на больше-меньше работает дольше, чем сравнение с 1 Рег.ПолучитьДвижение()=1
3. Если Рег.ТекущийДокумент().Номенклатура=Номенклатура Тогда  
                                  ЦенаН=Рег.ТекущийДокумент().Цена;
                              КонецЕсли.
А если в документе 1000 позиций, ты их так и будешь проверять все? Поставь "Прервать".
   Umka-Kate
 
36 - 04.08.04 - 11:56
(35) спасибо
1.Док.ВыбратьСтроки(); раньше так было - но в Док ничего не передавал..
2.ок
3.прервать у меня уже было
тут можно вообще без цикла мне только один документ нужен...
это уже остатки испробованных маразмов...(
   Stan from Piter
 
37 - 04.08.04 - 11:59
(36) "Остатки испробованных маразмов" - минус 1,5-2 секунды на исполнении...
Эх, молодежь, не работали вы на медленных машинах... Код оптимизировать не хотите. Разбаловали вас мощные машины..
   Umka-Kate
 
38 - 04.08.04 - 12:03
Рег = СоздатьОбъект("Регистр.ОстаткиТМЦ"); 
                        Спр=СоздатьОбъект("Справочник.Номенклатура"); 
                        Спр.НайтиПоКоду(Номенклатура.Код); 
                        
                        
                        
                        Рег.УстановитьФильтр(,Спр.ТекущийЭлемент(),,);
                        Рег.ОбратныйПорядок(1);
                        Рег.ВыбратьДвижения();
                        
                        Пока Рег.ПолучитьДвижение()=1 Цикл 
                            Док = Рег.ТекущийДокумент(); 
                            Рег.ТекущийДокумент().ВыбратьСтроки(); 
                            Пока Рег.ТекущийДокумент().ПолучитьСтроку()=1 Цикл
                                Если Рег.ТекущийДокумент().Номенклатура=Номенклатура Тогда   
                                    ЦенаН=Рег.ТекущийДокумент().Цена;
                                КонецЕсли;
                            КонецЦикла; 
                            Прервать;
                           //КонецЕсли;

                        КонецЦикла;  


вота...
и получитьдвижение()=0  ....((
   Stan from Piter
 
39 - 04.08.04 - 12:04
Рег = СоздатьОбъект("Регистр.ОстаткиТМЦ");
Рег.УстановитьФильтр(,Номенклатура,,); 
Рег.ОбратныйПорядок(1); 
Рег.ВыбратьДвижения(); 
Пока Рег.ПолучитьДвижение()=1 Цикл 
   Рег.ТекущийДокумент().ВыбратьСтроки(); 
   Пока Рег.ТекущийДокумент().ПолучитьСтроку()=1 Цикл 
        Если Рег.ТекущийДокумент().Номенклатура=Номенклатура Тогда   
            ЦенаН=Рег.ТекущийДокумент().Цена; 
            Прервать; 
        КонецЕсли;
   КонецЦикла; 
   Прервать;
КонецЦикла;
   Umka-Kate
 
40 - 04.08.04 - 12:07
(37) Вы , дядя:0), не понимаете, чтобы что-то оптимизировать, надо чтобы это что-то работало, а я тут по кол-ву задаваемых маразматичных вопросов первое место займу...

но огромное спасибо я запомню.. и подсказывайте мне в дальнейшем, пожалуйста..
   Umka-Kate
 
41 - 04.08.04 - 12:10
(39) суть в том, что он мне в отладчике все время
получитьдвижение()=0 выдает...
   Stan from Piter
 
42 - 04.08.04 - 12:13
Так! Конфигурация - торговля?
   Stan from Piter
 
43 - 04.08.04 - 12:16
Тогда проверь, а есть ли вообще движения по данному товару? Может его вообще не быть...
А коды у тебя уникальные?
   Umka-Kate
 
44 - 04.08.04 - 12:18
(42)нее у меня комплексная
   Stan from Piter
 
45 - 04.08.04 - 12:19
(44) См.(43)
   Umka-Kate
 
46 - 04.08.04 - 12:20
(43)есть специально в тестовой сделано... и движения есть и номенклатура

наверное фильтр неправильно что-то делает...
вообще я уже это запросом переделываю...
   GrayT
 
47 - 04.08.04 - 12:25
Не уверен, что ВыбратьДвижения без начальной даты хорошая идея.
   DRB
 
48 - 04.08.04 - 12:29
А нет ли записи периодической приходной цены в момент проведения - можешь проверить?
Это самый легкий путь кстати...
Если чайник - посмотри есть ли в движениях приходных накладных движения реквизитов справочников
   Umka-Kate
 
49 - 04.08.04 - 12:46
(47)опа!
с начальной датой идет...
 
  Рекламное место пустует
   Umka-Kate
 
50 - 04.08.04 - 12:48
теперь Рег.ТекущийДокумент().Номенклатура не определяется...
   GrayT
 
51 - 04.08.04 - 12:51
Выбери строки у текущего документа
   Umka-Kate
 
52 - 04.08.04 - 13:01
(51)дык
Рег.ТекущийДокумент().ВыбратьСтроки();
Пока Рег.ТекущийДокумент().ПолучитьСтроку()=1 Цикл
                                Если Рег.ТекущийДокумент().Номенклатура=Спр.ТекущийЭлемент() Тогда   
                                    ЦенаН=Рег.ТекущийДокумент().Цена;
                                КонецЕсли;
                            КонецЦикла;
   DRB
 
53 - 04.08.04 - 13:04
(52)А откуда взял что не определяется Номенклатура?
Может так:
СпрН.ЦенаН=Рег.ТекущийДокумент().Цена
СпрН.Записать();
должно быть?
   Umka-Kate
 
54 - 04.08.04 - 14:00
(53)
в отладчике не показывает
мне не в справочник ее надо записать, а в документ вывести
не проверяет Если Рег.ТекущийДокумент().Номенклатура=Спр.ТекущийЭлемент() Тогда
   Den
 
55 - 04.08.04 - 14:58
А ежели через НайтиСсылки? Если обработка идет документом, то в принципе, можно накидать всю номенклатуру, получить ссылки а потом анализировать.
   DRB
 
56 - 04.08.04 - 15:00
Давай весь код в студию
   Den
 
57 - 04.08.04 - 15:04
(56) Это ты кому?
   DRB
 
58 - 04.08.04 - 15:09
(57) это для (0)
а то так долго гадать будем
   Umka-Kate
 
59 - 04.08.04 - 15:13
Сделано!
надо документ спозицинировать!(ну или как это называется)
    Дк = СоздатьОбъект("Документ");
Дк.НайтиДокумент(Рег.ТекущийДокумент());
    Дк.ВыбратьСтроки();
                            Пока Дк.ПолучитьСтроку()=1 Цикл
                                Если Дк.Номенклатура=Спр.ТекущийЭлемент() Тогда
                                    ЦенаН=Дк.Цена;
                                КонецЕсли;
                            КонецЦикла;

просто по Рег.ТекущийДокумент() - ни фига строки не получает...

ишшо вопрос можно ли найти строку документа по какой было движение, а то циклом долго документы большие?..
   SnarkHunter
 
60 - 04.08.04 - 15:14
Интересно, до 100 постов дойдет?..
   Umka-Kate
 
61 - 04.08.04 - 15:20
(60) жалко?
   DRB
 
62 - 04.08.04 - 15:27
Самый простой вариант (делать АККУРАТНО!)
Работает моментально и без перебора.
1. Выгоняем всех из базы и лочим ее (каталог переименовываем - зачем - узнаешь дальше)
2. Снимаем у приходной накладной галочку Автогматическое удаление движений
3. Создаем периодический реквизит ЦЕНАПрихода у справочника ТМЦ
4. Дописываем в модуль проведения приходников строчки типа того:

Процедура ОбработкаПроведения()
   ПроставитьЦены();
   Возврат;
  ... то что у тебя дальше не важно
КонецПроцедуры;
5. Процедура ПроставитьЦены() такая будет:
Процедура ПроставитьЦены()
  Спр=СоздатьОбъект("Справочник.ТМЦ");
  ВыбратьСтроки();
  Пока ПолучитЬСтроку()=1 Цикл
    Спр.НайтиЭлемент(Номенклатура);
    УстановитьРеквизитСправочника(Спр.ТекущийЭлемент(),"ЦенаПрихода",Цена,ДатаДок);
  КонецЦикла;
КонецПроцедуры
6. Создаем обработку:
Док=СоздатьОбъект("Документ.ПриходнаяНакладная");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
Док.Провести();
КонецЦикла;

7. Запускаем эту обработку только 1раз!!!!
8. Заходим в конфигуратор - ставим галочку Автоматическое удаление движений;
9. Удаляем одну строчку с приходной накладной - Возврат; (чтобы проведение шло и дальше)
10. Пускаем пользователей в базу.

11. Все.. Дальше просто
======================
По Поводу (59) а посмотри в модуле приходной - есть ли ПривязыватьСтроку()
======================
Плюс ко всему - а регистр оборотный или остатков?
если остатков - посмотри есть ли движения по оборотным регистрам - делается намного быстрее если не подойдет описанный мною вариант
   Stan from Piter
 
63 - 04.08.04 - 15:31
1. Долго, но надежно:
Таб=СоздатьОбъект("ТаблицаЗначений");
Док.ВыгрузитьТабличнуюЧасть(Таб);
НайдСтрока=0;
Таб.НайтиЗначение(Номенклатура,НайдСтрока,"Товар");
ЦенаН=Таб.Цена;

2. Быстро, но ненадежно (при проведении ОБЯЗАТЕЛЬНО должна быть привязка к номеру строки!!!)                
Документ=Рег.ТекущийДокумент(); 
Документ.ПолучитьСтрокуПоНомеру(Рег.НомерСтроки());
Ну и т.д.
   SnarkHunter
 
64 - 04.08.04 - 15:34
(61)Нет-нет... Продолжайте...
   Umka-Kate
 
65 - 04.08.04 - 15:34
(62)шайтан...
   Umka-Kate
 
66 - 04.08.04 - 15:37
(64) гран мерси
   Stan from Piter
 
67 - 04.08.04 - 15:37
Вот кажись наиболее быстрый вариант...
Док=СоздатьОбъект("Документ");
Рег = СоздатьОбъект("Регистр.ОстаткиТМЦ"); 
Рег.УстановитьФильтр(,Номенклатура,,); 
Рег.ОбратныйПорядок(1); 
Рег.ВыбратьДвижения(НачГода(ТекущаяДата),ТекущаяДата()); 
Пока Рег.ПолучитьДвижение()=1 Цикл 
  Док=Рег.ТекущийДокумент();
  Док.ПолучитьСтрокуПоНомеру(Рег.НомерСтроки());
  ЦенаН=Рег.ТекущийДокумент().Цена; 
  Прервать; 
КонецЦикла;
   DRB
 
68 - 04.08.04 - 15:38
(65) Зачем так сложно и что получишь в итоге?
1. Не меняются ни проводки ни движения, добавляются только движения для справочников.
2. В новых приходах тоже это будет уже проводится
3. У любого ТМЦ на любую дату получишь цену прихода
4. и если надо получишь и документ который эту цену установил
хотя цель по моему как раз приходнуй цену получить последнюю
   DRB
 
69 - 04.08.04 - 15:39
(67) только это вариант если в модуле стоит ПривязыватьСтроку() при движениях
плюс быстрее все таки делать не по регистру остатков а по регистру оборотов..
   DRB
 
70 - 04.08.04 - 15:40
(60),(61),(64),(66)
:-)))
   Den
 
70 - 04.08.04 - 15:40
(62) Глянь повнимательнее в (0). Там есть слово "реализация". При чем здесь приход?
   DRB
 
72 - 04.08.04 - 15:43
Ну ладно - тогда это же в реализацию засунуть - невнимательно прочитал - смысл тот же..
   Umka-Kate
 
73 - 04.08.04 - 15:44
(67)ШАЙТАН!!..
   Stan from Piter
 
74 - 04.08.04 - 15:44
(65)
Ага был у меня такой клиент ....
Зазодил он значится в товар, что-то там менял, говорил "Изменить все пердические элементы", а потом думал, откуда у него 1 марта появилась цена, когда он ничего не покупал...
   DRB
 
75 - 04.08.04 - 15:46
(74) ИзменяетсяТолько документами галочка есть для этого воощето
   Stan from Piter
 
76 - 04.08.04 - 15:47
Я так понимаю у человека такая проблема:
Народ хочет продать товар по последней закупке ...
   DRB
 
77 - 04.08.04 - 15:48
И еще - движения по регистру делаются не только расходными накладными - не забывай проверять - реализация ли это...
и некоторые конфы возврат расходной накладной делают...
так что не забудь и эти проверки кинуть..
еще бывают перемещения внутренние....
   Den
 
78 - 04.08.04 - 15:49
(76) Или купить по последней продаже... :-))) (70)
   Den
 
79 - 04.08.04 - 15:49
(73) За что ты его так???
   DRB
 
80 - 04.08.04 - 15:50
(76) Нет, скорее чтобы в расходник попадали цены последней продажи автоматом
а для этого мой вариант таки самый простой иначе задолбутся ждать если такой товар продавался год назад... а если база обрезана?
   Stan from Piter
 
81 - 04.08.04 - 15:50
(75) Есть, есть, такая галочка ....
А отпускные цены ты тоже будешь через документ менять?
(73) см. (37) в плане оптимизации
   Stan from Piter
 
82 - 04.08.04 - 15:53
(80) Давай не будем гадать, а спросим Umka-Kate... зачем ей это, а уж из
   Den
 
83 - 04.08.04 - 15:54
(81) Зачем через документ? Меняй через обработку. Да еще отслеживай изменения, чтобы потом клиента носом ткнуть в ту самую лужу, в которую он тебя пытается посадить
   SnarkHunter
 
84 - 04.08.04 - 15:54
Вторая здравая мысль в этой ветке...
   SnarkHunter
 
85 - 04.08.04 - 15:54
(+84)Это по поводу (82)
   Stan from Piter
 
86 - 04.08.04 - 15:54
(80) Давай не будем гадать, а спросим Umka-Kate... зачем ей это, а уж из поставленной задачи будем решать, что лучше ...
Сорри, за повтор - на ноуте слишком близко расположены клавиши :-))
   Stan from Piter
 
87 - 04.08.04 - 15:58
НАРОД!!!!
А ВЫ ВСЕ ВНИМАТЕЛЬНО ЧИТАЛИ КОД?????
А КТО БУДЕТ ПРОВЕРЯТЬ ЭТО ТОЧНО БЫЛ ПРИХОД ТОВАРА? А МОЖЕТ ЭТО РАСХОД??? ВО ПРИКОЛ ПОЛУЧИЛСЯ!!!
   DRB
 
88 - 04.08.04 - 15:59
(87) а я о чем тебе твердю в (77)
:-))
   DRB
 
89 - 04.08.04 - 16:00
(0) Расскажи зачем тебе это надо??
Если одноразово - один вариант если постоянно то делай другой вариант
   Stan from Piter
 
90 - 04.08.04 - 16:02
(88)
Потерял нить разговора...
Посыпал голову пеплом...
   Stan from Piter
 
91 - 04.08.04 - 16:03
А куда зачинщик разговора пропал?
   DRB
 
92 - 04.08.04 - 16:04
я уже тоже начал запутыватся...
:-)
Умка-кейт объясни зачем тебе это?
   Umka-Kate
 
93 - 04.08.04 - 16:05
(82)(83)(86)отвечаю, у меня куча заявок на изменение базы
нынче делаю эту:
Алгоритм исправления московских цен:
1. Отбираем закупочные и Московские продажные цены, равные 0, 1, 0,95
2. Если есть продажная цена Вологда, не равная 0, 1, 0,95, 1,05 - берем ее и ставим, как Московскую продажную.
3. Если продажная цена Вологда равна 0, 1, 0,95, 1,05 - берем цену из последнего документа Реализация ( по любому из складов, но в первую очередь Вологодского)

4. Если нет Реализации по данным позициям - выводим отдельный список с наименованием, остатком и складом
5. Закупочная цена берется из последнего документа Поступление ТМЦ по любому из складов, но в первую очередь по Московскому

6. Позиции, на которые не найдены закупочные цены, выводятся отдельным списком с наименованием, остатком и складом.

это алгоритм
я по нему пишу документ!(это тоже в заявке)
а зачем и почему меня особо не волнует...
   DRB
 
94 - 04.08.04 - 16:07
Как часто это будет делаться?
   Stan from Piter
 
95 - 04.08.04 - 16:10
(93)
Это какой-то бред..
Ты уж тогда опиши весь бизнес-процесс, а так ни ... не понятно.
   DRB
 
96 - 04.08.04 - 16:10
Хи... так тебе отбор по последнему документу по складу и по товару нужен...
мой вариант отпал сразу - по складу привязать надо больше манипуляций сделать :-))
а вообще чето мне не понятно зачем это....  
Типа распродажа остатков?
   Umka-Kate
 
97 - 04.08.04 - 16:15
(95)ща.. и сразу работу подыскивать))
вся заявка перед вами

по алгоритму и делаю...вопросы задаю только технические..
так и работаю...
   SnarkHunter
 
98 - 04.08.04 - 16:18
Канатчикова дача... Я так и знал...
   Stan from Piter
 
99 - 04.08.04 - 16:20
(97)
Это не заявка, а ...
1. Отбираем закупочные и Московские продажные ...
 (Как отбираем закупочные, по приходныем накладным, по справочнику, от скольких поставщиков, и т.д.)
 (Московские продажные цены отбираем за какой период, за последний год, месяц ... по каким контрагентам)
Ну и т.д.
И это только вопросы к первому пункту...
   Umka-Kate
 
100 - 04.08.04 - 16:29
(99)блин
это уже сделано
я задаю вопросы по тому что я не могу сделать...
по конкретной проблеме
у меня было сделано все до выбора последней реализации.. вот и вопрос

не надо всю заявку за меня делать...и менять ее мне нельзя..

мне все равно чем мои "Рога и копыта" занимаются..

  1  2   

Список тем форума
 
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует