Вход | Регистрация


1С:Предприятие ::

Метки:

ole

Я
   kaena
02.08.04 - 23:32
пытаюсь разобраться с OLE. для меня это пока совсем темный лес.  может, что посоветуете, хотя вопрос думаю очень банальный.
 
  Рекламное место пустует
   Guk
 
1 - 02.08.04 - 23:35
(0) По поводу чего вопрос то? По поводу леса, так я не грибник. А про ОЛЕ спрашивай...
   NS
 
2 - 02.08.04 - 23:36
Последние страницы второго тома ЖКК
   Guk
 
3 - 02.08.04 - 23:38
(2) Если по ним ОЛЕ учиться, то проще повеситься...
   NS
 
4 - 02.08.04 - 23:39
(3) Там же всё написано!!!
   IAm
 
5 - 02.08.04 - 23:39
3 Смотря на чем.
   kaena
6 - 02.08.04 - 23:41
(1) пытаюсь разобраться, хочу воспользоваться им для переноса данных. то есть пока получилось только подключить базу, а дальше?
   kaena
7 - 02.08.04 - 23:42
(4) у меня его нет... где взять, что ли?
   Матрейя
8 - 02.08.04 - 23:47
7. Тебе подключение возвратило Базу. Затем все объекты OLE базы создаешь и юзаешь так же, как и обычной , только не Спр=СоздатьОбъект("Справочник.Такой"), а База.CreateObject("Справочник.Такой"). База.Метаданные.... База.Перечисление , База.CreateObject("ТаблицаЗначений") и т.д.
   Guk
 
9 - 02.08.04 - 23:47
(4) Вот здесь всё написсано. Да и то не всё.
http://www.sinor.ru/~my1c/knowhow/v7&OLE.html
   kaena
10 - 02.08.04 - 23:56
(8) то есть база у меня есть.  запускала... через обработку.  тут же в модуле создаешь все обьекты, которые нужны //(CreateObject) в курсе. и не только справочники, как я поняла.
p.s: спасибо...
 
  Рекламное место пустует
   Матрейя
11 - 03.08.04 - 00:01
10. Так а что непонятного тогда?
Д=СоздатьОбъект("ПризоднаяНакладная");//документ текущей базы

Д1=База.CreateObject("ПриходнаяНакладная");//документ OLE базы

Д.ВыбратьДокументы();
Пока Д.ПолучитьДокумент()=1 Цикл
Д1.Новый();
Д1.ДатаДок=Д.датаДок;
Д1.НомерДок=Д.НомерДок;
.............
Д1.Записать();
КонецЦикла;
   kaena
12 - 03.08.04 - 00:03
все бы это в голове уложить, да побыстрей...
  создав нужные мне объекты в этой базе, откуда берутся данные для например справочников?   как их туда из уже имеющихся забить?
   kaena
13 - 03.08.04 - 00:09
(11) пока возилась, ответ пришел... то есь это и есть перенос данных, как я и поняла
  и еще - вернули мне базу.. пытаясь сделать это еще раз ничего не выходит. так должно быть?  
  как еще далеко мне до всего этого...
   Матрейя
14 - 03.08.04 - 00:11
12. Копировать справочники - что-то вроде этого (написал, но не проверял)
Процедура глКопированиеСправочников(База="",КопСпр,РодительСпр="",Род="")
    Перем Спр;
    Если База<>"" Тогда
    Спр=база.CreateObject("Справочник."+КопСпр.Вид()); 
    Иначе
    Спр=СоздатьОбъект("Справочник."+КопСпр.Вид());
    КонецЕсли;    
    Если РодительСпр<>"" Тогда
        Спр.ИспользоватьРодителя(РодительСпр);
    КонецЕсли;
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент(0)=1 Цикл
        Если Спр.ЭтоГруппа()=1 Тогда
        КопСпр.НоваяГруппа();
        Иначе
        КопСпр.Новый();
        КонецЕсли;
          // если есть код - запишем!

           Если Метаданные.Справочник(КопСпр.Вид()).ДлинаКода>0 Тогда
              КопСпр.Код=Спр.Код;                                       
           КонецЕсли;                 
          // если есть наименование - запишем!

           Если Метаданные.Справочник(КопСпр.Вид()).ДлинаНаименования>0 Тогда
              КопСпр.Наименование=Спр.Наименование;                             
           КонецЕсли;
          // теперь переберем все реквизиты

            Для П=1 По Метаданные.Справочник(КопСпр.Вид()).Реквизит() Цикл
                 Попытка
              Если Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Тип="Перечисление" тогда
                     Врем=Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Тип+"."+Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Вид().ЗначениеПоИдентификатору(Спр.ПолучитьАтрибут(Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Идентификатор));
                 ИначеЕсли Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Тип="Справочник" тогда    
                     Врем=СоздатьОбъект(Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Тип+"."+Метаданные.Справочник(КопСпр.Вид()));
                     Врем.НайтиПоКоду(Спр.ПолучитьАтрибут(Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Идентификатор).Код);
              Иначе
                   Врем=Спр.ПолучитьАтрибут(Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Идентификатор);
              КонецЕсли;  
              КопСпр.УстановитьАтрибут(Метаданные.Справочник(КопСпр.Вид()).Реквизит(П).Идентификатор,Врем);
              Исключение
              
              КонецПопытки;    
            КонецЦикла;
        Если ПустоеЗначение(Род)=0 Тогда
        КопСпр.Родитель=Род;            
        КонецЕсли;
        КопСпр.Записать();
        Если Спр.ЭтоГруппа()=1 Тогда
            ТекРодитель=КопСпр.ТекущийЭлемент();
            глКопированиеСправочников(База,КопСпр,Спр.ТекущийЭлемент(),ТекРодитель);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
   Guk
 
15 - 03.08.04 - 00:11
(13) Истина где-то рядом...
   Матрейя
16 - 03.08.04 - 00:15
kaena - жаль что ты не в Ростове. Я бы тебя на работу взял...
   kaena
17 - 03.08.04 - 00:19
хотя на самом деле вполне хватит в этой ситуации и переноса остатков.  
  может, повеселю кого,но с xml тоже надо разбираться к примеру, и с правилами к сему.. и надеюсь в ступор не попасть.  
  всем спасибо за внимание к моим наивным вопросам.
пока не заканчиваю, учусь пока...
   Guk
 
18 - 03.08.04 - 00:20
(16) Матрейя - это свет...
   kaena
19 - 03.08.04 - 00:21
(16) и чем заслужила?  рада была бы поучиться кстати.  и не лень с такой непонятливой и наивной возиться?
   Матрейя
20 - 03.08.04 - 00:27
18. Да.
19. Тебе не нужно было бы программировать, только по собственному желанию. Достаточно просто делать мне кофе и мыть вовремя мою кружку (секретарша не очень способная попалась). Кроме приятных высокооплачиваемых обязанностей ты еще могла бы общаться иногда с Совершенством.
   kaena
21 - 03.08.04 - 00:30
(20) а я хочу научиться сией непростой вещи как программирование и т.д. в 1с.
   для раздумий - кофе люблю, в  коллекцию совершенств могу отправить свою фотку, если есть желание взглянуть... (мыло)
           пардон что не по теме...
   Матрейя
22 - 03.08.04 - 00:34
21. Фотка - это классно! matreya@mail.ru
   kaena
23 - 03.08.04 - 00:50
(22)отсылаю, ладно уж.. пока я тут.
   Матрейя
24 - 03.08.04 - 01:00
kaena, да ты просто красавица! + превосходный ум программиста + очень приятное кокетство - твой избранник будет счастливейшим человеком.
   kaena
25 - 03.08.04 - 01:07
(24) фотка дошла?
   очень мило... ишо недолго тут сижу, завтра те проблемы, которые пытаюсь решить. очень грустно, что наверное решить их не смогу.  в крайнем случае придется сливать на флэшку конфы втихаря и ковыряться дома. но главное - чтобы получилось...
   Матрейя
26 - 03.08.04 - 01:15
25. Я ведь тебе говорил - будут проблемы - пиши мне среди рабочего дня на аську. Возможно смогу помочь. Правда быстрый ответ не гарантирую.
   kaena
27 - 03.08.04 - 01:19
(26) акей. я закругляюсь, всем тут удачи.
   21
28 - 03.08.04 - 01:30
"Достаточно просто делать мне кофе и мыть вовремя мою кружку (секретарша не оень способная попалась)."
Вот. А клеветники что-то там еще об сексуальной озабоченности франей талдычут. Нету, озабоченности той.
   Матрейя
29 - 03.08.04 - 02:05
28. Я не франч, я простой консультант Б.Нуралиева.



Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует