Вход | Регистрация

1С:Предприятие ::

Метки:

ТЗ

Я
   ZZ
02.08.04 - 15:48
Можно ли вручную вносить данные в таблицу значений расположенную в форме
 
  Рекламное место пустует
   Волшебник
 
1 - 02.08.04 - 15:50
Нет. Нужно программировать операции Добавить, Скопировать, Изменить, Удалить.
   ZZ
2 - 02.08.04 - 15:54
Ну Добавить,Удалить и Скопировать это понятно.
Но допустим в процедуре Изменить, как сделать чтобы ячейка ТЗ "открывалась" для редактирования
   ZZ
3 - 02.08.04 - 15:55
... или это невозможно в принципе
   shura
 
4 - 02.08.04 - 15:56
ВвестиЧисло()
ВвестиСтроку()
   Рупор абсурда
5 - 02.08.04 - 15:57
(4)+ ВвестиДату()
   Рупор абсурда
6 - 02.08.04 - 15:57
(5)+ ВвестиПеречисление()
   Рупор абсурда
7 - 02.08.04 - 15:58
(6)+ ВвестиЗначение()
   Волшебник
 
8 - 02.08.04 - 15:59
(2) Повесь на таблицу значения формулу. В процедуре анализируй текущую строку и колонку.
   shura
 
9 - 02.08.04 - 15:59
ВвестиЗначение() лучше всего ;)
   Рупор абсурда
10 - 02.08.04 - 15:59
(7)+ Да мало ли чего можно ещё всякого разного ввести? ...
 
  Рекламное место пустует
   Guk
 
10 - 02.08.04 - 15:59
+(7) ВвестиВидСубконто()...
 
  Рекламное место пустует
   Рупор абсурда
12 - 02.08.04 - 15:59
(7)+ Да мало ли чего можно ещё всякого разного ввести? ...
   Stan from Piter
 
13 - 02.08.04 - 17:17
(0)Ну, например, вот так:
Процедура Выбор()
    Перем ПозицияY, ПозицияX; 
    ПозицияY  = ТЗ.ТекущаяСтрока();
    ТЗ.ТекущаяКолонка(,ПозицияX);
    Если (ПозицияX > 0) И
         (ПозицияY > 0) Тогда 
             Если ПозицияX=1 Тогда
                 ОткрытьФорму(ТЗ.Счет);
             ИначеЕсли ПозицияX=2 Тогда
                 Если ТЗ.ПолучитьЗначение(ПозицияY,ПозицияX)="V" Тогда
                     ТЗ.УстановитьЗначение(ПозицияY,ПозицияX,"");
                 Иначе
                     ТЗ.УстановитьЗначение(ПозицияY,ПозицияX,"V");
                 КонецЕсли;
                Форма.Обновить();
            ИначеЕсли ПозицияX=3 Тогда
                XYZ=0;
                ВвестиЧисло(XYZ,"Введи XYZ",15,3);
                 Счет.УстановитьЗначение(ПозицияY,ПозицияX,XYZ);
                Форма.Обновить();
             КонецЕсли;
    КонецЕсли;
КонецПроцедуры
   IAm
 
14 - 02.08.04 - 17:28
ВнестиВклад()
   IAm
 
15 - 02.08.04 - 17:28
Сегодня видел надпись на маршрутке "Лечу бесплодие методом тыка"
   IAm
 
16 - 02.08.04 - 17:28
Тупо, зато есть о чем вспомнить.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует