Вход | Регистрация

1С:Предприятие ::

Метки:

Ошибка "Не выбран документ!" по непонятной причине

Я
   keyt
 
02.08.04 - 13:11
Подскажите пожалуйста, может кто-нибудь сталкивался с такой проблемой. Не пойму - то ли я туплю, то ли это как-то просто должно разрешаться.
Имеется код (ДокРезерв - документ) :

ДокРезерв = НайтиДок(РезервПоПроекту);
ДокРезерв.НоваяСтрока();

текст функции НайтиДок:

Функция НайтиДок(строкадок)  
    Перем Номер, Имя, ДатаДокум;
    пдок=СоздатьОбъект("Документ.СкладРасход");  
    гл_ВозвратитьНомерИмяДатуДокумента(строкадок, Номер, Имя, ДатаДокум);
    пдок.НайтиПоНомеру(Номер,ДатаДокум,Имя);
    Если пдок.Выбран()=1 тогда
        возврат пдок.ТекущийДокумент();
    Иначе
        Сообщить("Документ не найден: "+строкадок);
        возврат ПолучитьПустоеЗначение("Документ.СкладРасход");
    КонецЕсли;
КонецФункции


На второй строке кода упорно вылетает ошибка " Не выбран документ!". При проходе отладчиком тоже всё выглядит нормально. Отчего такое может быть?
 
  Рекламное место пустует
   NS
 
1 - 02.08.04 - 13:16
К объекту текущийДокумент() - неприменим метод новаяСтрока()..
   NS
 
2 - 02.08.04 - 13:17
к объекту ПолучитьПустоеЗначение("Документ.СкладРасход"); -
то же самое...
   NS
 
3 - 02.08.04 - 13:24
Док=создатьобъект("Документ.СкладРасход");
ДокРезерв = НайтиДок(РезервПоПроекту);
Если пустоеЗначение(докрезерв)=1 тогда
  док.новый();
Иначе
 док.найтидокумент(докрезерв); 
КонецЕсли;
Док.НоваяСтрока(); 
.....
Док.Записать();
   keyt
 
4 - 02.08.04 - 13:24
Блин, вот же ж грабли какие :(
Большое спасибо за подсказку


Список тем форума
Рекламное место пустует  
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует