Вход | Регистрация

1С:Предприятие ::

Метки:

Таблица значений формы

Я
   Questor
02.08.04 - 09:57
Кинул на форму ТЗ, добавил колонок.
Как теперь войти в режим редактирования ячейки (после ТЗ.НоваяСтрока();)?
 
  Рекламное место пустует
   Michael99
 
1 - 02.08.04 - 09:59
Версия 1С ?
   Questor
2 - 02.08.04 - 10:01
7.7
   Michael99
 
3 - 02.08.04 - 10:04
Никак , нет у ТЗ режима редактирования ячейки.
Доступ через функцию в Формуле.
например :
Процедура КликНаТабл()
    Перем ВЗ;
    Если ТЗЦена.ТекущаяКолонка()="Стоимость" Тогда
        ВЗ=ТЗЦена.Стоимость;
        Если ВвестиЧисло(ВЗ,"Введите стоимость услуги",15,2)>0 Тогда
            ТЗЦена.Стоимость=ВЗ;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры//КликНаТабл
   Guk
 
4 - 02.08.04 - 10:05
(0) Для ввода значений, надо свою процедуру писать...
   Valery
 
5 - 02.08.04 - 10:06
ТЗ интерактивно не редактируется. Добавь кнопки типа "Добавить", "Изменить"
   Questor
6 - 02.08.04 - 10:10
ясно, пасиб)


Список тем форума
Рекламное место пустует  
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует