Вход | Регистрация


1С:Предприятие ::

Метки:

Автоподстановка ГТД (релиз 460)

Я
   AA
31.07.04 - 22:26
НЕ работает, может галку где надо поставить?
 
 
   BorisG
 
1 - 01.08.04 - 11:23
(0) А разве должно?
   AA
2 - 01.08.04 - 12:58
Не похоже, на всякий случай спрашиваю, а то бывает напишешь решение, а оказывается оно уже есть :)
Вот и спрашиваю у всех, кстати точно пока никто не ответил, может просто не знает никто?
   BorisG
 
3 - 01.08.04 - 13:02
Да... Коронная фраза... "может просто не знает никто?"
Ну ну... с таким "подходом" вероятность получения ответа нулевая.
   427
 
4 - 01.08.04 - 13:43
Рексона - никогда не подведет...

Ок, Об....
   AA
5 - 01.08.04 - 14:31
(3)Особенно если его не знаешь :)
(4)Не смотри телевизор, плохо кончишь.
   BorisG
 
6 - 01.08.04 - 14:43
(5) Ну ну... продолжай...
Запомни одну простую истину, если хочешь получить ответ "Никто никому ничем не обязан..."
Почитай для начала правила форума... и...
Как правильно задавать вопросы (Эрик Раймонд)
Как правильно задавать вопросы (Эрик Раймонд)

Считай, что предупредил.
   Рупор абсурда
7 - 01.08.04 - 14:45
(5) 427 - грамотный специалист и уважаемый персонаж на форуме ...
То же касается и BorisG ..., кроме всего он ещё и модератор тут ...
Вам следует, снисходительно относиться к их хамству ...

ЗЫ: Разве этого не написано в правилах форума? ...
   AA
8 - 01.08.04 - 14:57
(7)А что есть здесь есть правило, что модер должен отвечать на вопрос, даже если он не знает ответ?
А 427 просто прикалывается, это как раз понятно и не вызывает никакого негатива.

(6)Очень длинно, нет столько времени, проще самому на свой вопрос ответить,
делов-то открыть пару модулей, просто время с экономить хотел :)
   Gavrila
 
9 - 01.08.04 - 15:04
(8) А ты вопрос задавай, а потом время экономь(самостоятельно)... можь че и получится :)
   AA
10 - 01.08.04 - 15:11
(8)Ок.
Бух(460)
Пришел Товар с гтд , потом его продают, и на основании отгрузки товара, выписывают сч фактуру, в которой это самое гтд не подставляется автоматически.
Вопрос соответственно,почему не подставляется?
 
 
   Rogervik
 
11 - 01.08.04 - 15:22
(6)Твои оригинальные ответы все уже наизусть запомнили;) и перестань учить людей как задавать вопросы, это в купе с постоянным обзыванием новых посетителей неудачниками характеризует большую часть, так называемых, активных экспертмодов как глубоко закомплексованных снобов.
   SnarkHunter
 
12 - 01.08.04 - 15:36
(10)Вопрос "почему не подставляется" этА ГТД (ибо декларация) было правильнее адресовать разработчикам типовой... Один из вариантов - забыли...

(11)Диагнозы - вещь неблагодарная... Можно и по твоему посту диагноз поставить... Только будет ли он верным?..
   AA
13 - 01.08.04 - 15:41
Спасибо тебе человек  человек со звездой, буду решать.
Если сделаю выложу.
   SnarkHunter
 
14 - 01.08.04 - 15:46
Да там делать-то, собственно, нечего... В процедуру ВводНаОсновании одну строчку добавить...
   Rogervik
 
15 - 01.08.04 - 15:59
(14)А ты молодцом, за себя и других отдуваешься и народу не забываешь помогать, по ряду косвенных признаков полагаю, тебя скоро ждет повышение;)
   Guk
 
16 - 01.08.04 - 16:01
(15) Не хочу показаться снобом, но Вы по-моему не очень умный человек...
   Gavrila
 
17 - 01.08.04 - 16:05
(16) Все в мире нашем относительно :)
зы: особенно в инете :)
   BorisG
 
18 - 01.08.04 - 16:17
(12) Не забыли. Нет и скорее не будет. Это идеология. Ибо в бухии нет партионного учета.
   SnarkHunter
 
19 - 01.08.04 - 16:24
(18)Это понятно...
Только тут вопрос-то не так глобально ставится... А именно - почему при вводе СФ на основании РН (в которой номера ГТД проставлены) эти номера не подтягиваются в СФ... ИМХО такой "бантик" ничему не противоречит...
   Хряк
 
20 - 01.08.04 - 16:26
(19) Да нету в РН ГТД :(
   BorisG
 
21 - 01.08.04 - 16:29
(19) Ну ка где это в РН ГТД ;-))) Не смеши.
ГТД только во входной СФ.
   AA
22 - 01.08.04 - 16:29
Поэтому одной строчкой наверно не получится, придется наверно запрос клеить...
   SnarkHunter
 
23 - 01.08.04 - 16:36
:-))
Есть ГТД в РН, есть...
При возврате поставщику...
:-)
   SnarkHunter
 
24 - 01.08.04 - 16:38
В отгрузке нету... Тут я со своей бухией спутал... Сорри...
   spock
 
25 - 01.08.04 - 17:14
2(18)Если нет партионного учета для учета ТМЦ, то кто запретит использовать FIFO/LIFO для учета номеров ГТД???
Все решается просто, хоть и в разрез с общей идеологией.
   BorisG
 
26 - 01.08.04 - 17:27
(25) Ну это ты разработчикам напиши ;-))
   spock
 
27 - 01.08.04 - 17:30
2(26)Типовые решения я использую только для расчета з/п :-)
Все остальное мне интересно только в качестве вдохновения.
   AA
28 - 01.08.04 - 21:17
//Форма-Документ.СчетФактура          

Аванс = 0;        //Текст  оригинального модуля

СчГТД = СчетПоКоду("ГТД");                                  //АА

СпрГтд=СоздатьОбъект("Справочник.ГТД");                     //АА

СпТов=СоздатьОбъект("СписокЗначений");                      //АА

ДатаЗапроса=ДокОсн.ДатаДок;                                 //АА

ДокОсн.ВыгрузитьТабличнуюЧасть(СпТов,"Товар");              //АА

Би=СоздатьОбъект("БухгалтерскиеИтоги");                     //АА

Би.ИспользоватьСубконто(ВидыСубконто.Номенклатура,СпТов,2,);//АА

Би.ИспользоватьСубконто(ВидыСубконто.ГТД,,1,);               //АА

Би.ВыполнитьЗапрос(,ДатаЗапроса,СчГТД,,,,4);                //АА

ДокОсн.ВыбратьСтроки();                      //Текст  оригинального модуля

Пока ДокОсн.ПолучитьСтроку()=1 Цикл      //Текст  оригинального модуля

НоваяСтрока();               //Текст  оригинального модуля

НазначитьТип("Товар", "Справочник.Номенклатура");  //Текст  ориг модуля

Если ( ДокОсн.Вид()="ОказаниеУслуг" ) Тогда     //Текст  оригинального модуля

Товар=ДокОсн.Услуга;                         //Текст  оригинального модуля

ИначеЕсли ( ДокОсн.Вид()="ВыполнениеЭтапаРабот" ) Тогда  //Текст ориг модуля

Товар=ДокОсн.Работа;                        //Текст  оригинального модуля

Иначе                                  //Текст  оригинального модуля

Товар=ДокОсн.Товар;        //Текст  оригинального модуля

КонецЕсли;               //Текст  оригинального модуля

ГтдДляПодстановки = "";                                                  //АА

Если Би.ПолучитьСубконто(ВидыСубконто.Номенклатура,,ДокОсн.Товар)=1 Тогда //АА

Би.ВыбратьСубконто(2,,,,,,);                                              //АА

Пока Би.ПолучитьСубконто(ВидыСубконто.Гтд)=1 Цикл                         //АА

Если ПустоеЗначение(Би.ПредставлениеСубконто(2,))=1 Тогда                  //АА

Прервать;                                                              //АА

Иначе                                                                   //АА

ГтдДляПодстановки = Би.ПредставлениеСубконто(2,);                   //АА

Если СпрГтд.НайтиПоНаименованию(ГтдДляПодстановки,0,1) = 1 Тогда                 //АА

ГТД = СпрГтд.ТекущийЭлемент();                                   //АА

КонецЕсли;      //АА

Прервать;               //АА

КонецЕсли;     //АА

КонецЦикла;                   //АА

КонецЕсли;                     //АА
   427
 
29 - 01.08.04 - 23:16
на самом деле в бухии (да и в ТиС) можно лихо прикрутить псевдоучет ГТД...
Один реквизит, три-четыре строки в Приход, пара в Расход ..... и все довольны....

И никаких регистров.... и счетов ГТД...
   NS
 
30 - 01.08.04 - 23:40
(29) Из Номенклатуры Брать?
   spock
 
31 - 03.08.04 - 21:29
2(29)Вопрос правильный...:)
А вот я на самом деле под словом "псевдоучет" подрузомевал учет на счетах или регистрах... как клава даецца плохо под выпитием.



Список тем форума
Рекламное место пустует   Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует