Вход | Регистрация

  1  2
1С:Предприятие ::

Метки:Встроенный язык

Как найти третий символ в строке ...

Я
   Рупор абсурда
30.07.04 - 12:14
... штатными средствами 1С77 ..., не используя методов Лев(), Прав(), Сред(), Формат() и Шаблон() ...

SnarkHunter, чур, не отвечать ...
 
 
   Рупор абсурда
101 - 30.07.04 - 18:37
(97) Какая рекурсия? Отпуск начался ...
   cup of tea
101 - 30.07.04 - 18:38
+97 если задаться целью не именно 3-й, а универсально N-й
   cup of tea
103 - 30.07.04 - 18:41
(101) до отпуска осталось 23 минуты...по серверным часам. Только они врут на 4 минуты - так что 19... )))
   cup of tea
104 - 30.07.04 - 18:42
время у нас такое - местное )))
   Z1
 
105 - 30.07.04 - 18:45
(101) Да отпуск это хорошо.
Да и я давно уж об этой рекурсии намекаю элитным товарищам.
Да и ссылке по 98 вроде нет рекурс решений
   Матрейя
106 - 30.07.04 - 19:14
105. Та рекурсия не будет элитной из-за скорости.
   Z1
 
107 - 30.07.04 - 19:16
(106) Так там не скорость а алгоритм - красота понимаешь ...
   Матрейя
108 - 30.07.04 - 19:17
107. Да какая там красота. Красиво это так Сред(Стр,3,1)
   Z1
 
109 - 30.07.04 - 19:22
(108) Ну это каждый тупой одинэсник может,
а через ВК еще быстрее чем 108 будет
   Рупор абсурда
110 - 30.07.04 - 19:25
(109) Готов поспорить на пару сотен, что быстрее не будет ...
 
 
   Z1
 
111 - 30.07.04 - 19:30
(110) Спорить не буду.
Но если делать скурпулезный пооператорный анализ то будет
потому что на Си быстрее но все время съестся на создание
OLE Variant String поэтому различие величина очень малого порядка.
   Рупор абсурда
112 - 30.07.04 - 19:33
(111) Жаль ... :((
Мне счас как раз срочно бабки нужны ... :((
   Z1
 
113 - 30.07.04 - 19:38
(112) И еще преимущество ВК ( а еще лучше свой внут ole server )короче путь до испольняемого кода.
Вспомни ускоритель Orefkov - т.е. как он до точки входа в модуль доползает
сколько на это усилий уходит в 1с.exe - кто его знает.
   Z1
 
114 - 30.07.04 - 19:41
(112) Мне тоже нужны до зарплаты еще неделя-полторы
   Матрейя
115 - 30.07.04 - 19:53
Вам занять?
   Тиркатор
116 - 02.08.04 - 14:31
А так потянет?

Функция Рекурсия(ИсходнаяСтрока,Символ,номер)
    ТотСамый="Охренел что-ли меньшепервый символ искать !!!";
    
    Для Шаг=1 по 255 Цикл
        Если Найти(ИсходнаяСтрока, Символ+Симв(Шаг))=1 тогда
            Символ=Символ+Симв(Шаг);
            номер=номер-1;
            Если номер=0 тогда 
                возврат(Симв(Шаг));
            КонецЕсли;
            ТотСамый=Рекурсия(ИсходнаяСтрока,Символ,номер);
        КонецЕсли;               
    КонецЦикла;
    
    Если номер<1 тогда 
        возврат(ТотСамый); 
    КонецЕсли;
    
КонецФункции


Процедура Сформировать() 
    ТотСимвол=Рекурсия(ИсходнаяСтрока,"",3);   
    Сообщить(ТотСимвол);

КонецПроцедуры
   Рупор абсурда
117 - 02.08.04 - 14:41
(116) Вполне потянула бы ..., когда бы работала ...
   тиркатор
118 - 03.08.04 - 11:06
Пардоньте :)

Функция Рекурсия(ИсходнаяСтрока,Символ,номер) 
   ТотСамый="Охренел что-ли меньшепервый символ искать !!!"; 
    
   Для Шаг=1 по 255 Цикл 
       Если Найти(ИсходнаяСтрока, Символ+Симв(Шаг))=1 тогда 
           Символ=Символ+Симв(Шаг); 
           номер=номер-1; 
           Если номер=0 тогда 
               возврат(Симв(Шаг)); 
           КонецЕсли; 
           ТотСамый=Рекурсия(ИсходнаяСтрока,Символ,номер); 
       КонецЕсли;               
       
   Если номер<1 тогда 
       возврат(ТотСамый); 
   КонецЕсли; 
   
   КонецЦикла; 
   
КонецФункции 


Процедура Сформировать() 
   ТотСимвол=Рекурсия(ИсходнаяСтрока,"",3);   
   Сообщить(ТотСимвол);
КонецПроцедуры;
   Рупор абсурда
119 - 03.08.04 - 11:35
(118) Ну вот ..., теперь совсем другое дело ... :))

  1  2

Список тем форума
Рекламное место пустует   Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует