Вход | Регистрация

1С:Предприятие ::

Метки:

не получется создать новый элемент справочника...

Я
   Aiuan
 
29.07.04 - 20:45
в=Создатьобъект("XBase");
в.ОткрытьФайл("1.dbf");   
в.Первая();
ы=в.КоличествоЗаписей();
СчетчикЦикла = 0;
Для СчетчикЦикла = 0 По (ы-1) Цикл
    Сообщить("Номер записи " + в.НомерЗаписи());
    в.Перейти(в.НомерЗаписи() + 1);
    имя = СокрЛП(в.NAME);
    спр = создатьобъект("Справочник.Номенклатура");
    Если спр.НайтипоНаименованию(имя,0) = 1 тогда
         спр.СрокРеализации = в.SROK_REAL;
         спр.ПроцентВозврата = в.VOZVR_PR;
         Сообщить("Издание " + имя + "имеется в классификаторе...");
         спр.Записать();
    ИначеЕсли
             
         спр.Новый();
         спр.ПолнНаименование = имя;
             
             
         Если в.NDS="10" Тогда
             спр.СтавкаНДС = Перечисление.СтавкиНДС.НДС10;
         ИначеЕсли в.NDS="18" Тогда
             спр.СтавкаНДС = Перечисление.СтавкиНДС.НДС18;
         ИначеЕсли в.NDS="0" Тогда                           спр.СтавкаНДС = Перечисление.СтавкиНДС.БезНДС;
        КонецЕсли;
             
        спр.СрокРеализации = в.SROK_REAL;
        спр.ПроцентВозврата = в.VOZVR_PR;
        спр.Записать();
        Сообщить("Издание " + имя + "добавлено...");
        
        КонецЕсли;    
    КонецЦикла;
 
  Рекламное место пустует
   Crew
 
1 - 29.07.04 - 20:49
ошибку выдает?
   Aiuan
 
2 - 29.07.04 - 20:51
спр.Новый()<<?>>;
{Обработка.ДополнениеСправочник.Форма.Модуль(21)}: Выражение должно иметь логический тип
   Орк
 
3 - 29.07.04 - 20:59
После ИначеЕсли чего-нибудь пририсуй.
   Aiuan
 
4 - 29.07.04 - 20:59
блин.... снова протупил....  извиняйте, что отвлек...
   Crew
 
5 - 29.07.04 - 21:03
дык вроде в коде все правильно. Переменную спр должно быть видно. :(
Посмотри в отладчике по строкам, наиная с
 спр = создатьобъект("Справочник.Номенклатура");
   Crew
 
6 - 29.07.04 - 21:03
(3)
Оп. пора домой :(
   Aiuan
 
7 - 29.07.04 - 21:08
(6):)


Список тем форума
  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует