Вход | Регистрация

1С:Предприятие ::

Метки:

Как победить данное издевательство?

Ø [Волшебник, 29.07.04 - 18:24]
Я
   trdm
29.07.04 - 18:23
Процедура ГруппировкиСчелчек()
  ПромГруппировки = СоздатьОбъект("СписокЗначений");
  Группировки.Выгрузить(ПромГруппировки);
  Если ПромГруппировки.ТекущаяСтрока()<>0 Тогда
   ТекСтрока = ПромГруппировки.ТекущаяСтрока();
    ТекПредставлениеСЗ = "";
    ТекЗначение = ПромГруппировки.ПолучитьЗначение(ТекСтрока, ТекПредставлениеСЗ);
    Позиция1 = 0;
    Позиция2 = 0; 
    Позиция1 = Найти(ТекПредставлениеСЗ,СтрокаСГ);
    Позиция2 = Найти(ТекПредставлениеСЗ,СтрокаБГ); 
    Если Позиция1<>0 Тогда
               // Позиция1 = 7 А, вот в эту ветку в упор не хочет заходить :( Как это ПОБЕДИТЬ?

     СтрЗаменить(ТекПредставлениеСЗ,СтрокаСГ,СтрокаБГ);
    ИначеЕсли Позиция2<>0 Тогда
     СтрЗаменить(ТекПредставлениеСЗ,СтрокаБГ,СтрокаСГ);
    КонецЕсли;
    Сообщить(ТекПредставлениеСЗ);
    ПромГруппировки.УстановитьЗначение(ТекСтрока,ТекЗначение, ТекПредставлениеСЗ);
  КонецЕсли;
  ПромГруппировки.Выгрузить(Группировки);
КонецПроцедуры// ГруппировкиСчелчек()
 
  Рекламное место пустует
   Волшебник
 
1 - 29.07.04 - 18:24
Тема должна отражать суть сообщения.


Список тем форума
Рекламное место пустует  
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует