Вход | Регистрация

1С:Предприятие ::

Метки:Бухгалтерия 7.7

Работа с подчиненным справочником договора

Я
   Hardy
 
29.07.04 - 11:58
Уважаемые коллеги помогите начинающему, есть обработка (Бухия 460) для простановки всем контрагентам договора, что нужно дописать в обработке чтоб сообщалось если договор с таким наменованием уже существует? И как если он существует перезаписать его?

Процедура СоздатьПодчиненныйДоговор()
Спр=СоздатьОбъект("Справочник.Контрагенты");
Попытка
дог=СоздатьОбъект("Справочник.Договоры");
исключение
Предупреждение("В конфигурации нет справочника ДОГОВОРЫ");
возврат;
конецПопытки;
Спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент()=1 Цикл
Если спр.ЭтоГруппа()=1 Тогда
продолжить;
КонецЕсли;
дог.ИспользоватьВладельца(спр.ТекущийЭлемент());
дог.Новый();
дог.наименование="СпецДоговор";
дог.ВидДоговора=глЗначениеПоУмолчанию("ОсновнойВидДоговоров");
дог.ОплатаДоговора=1;
Сообщить("Договор создаётся для контрагента: "+Спр+"");
дог.записать();
конецЦикла;
конецПроцедуры
 
  Рекламное место пустует
   Guk
 
1 - 29.07.04 - 12:10
(0) Убери вот это
Попытка
дог=СоздатьОбъект("Справочник.Договоры");
исключение 
Предупреждение("В конфигурации нет справочника ДОГОВОРЫ"); 
возврат; 
конецПопытки; 

Тогда скажу...
   lexa
 
2 - 29.07.04 - 12:13
Процедура СоздатьПодчиненныйДоговор() 
Спр=СоздатьОбъект("Справочник.Контрагенты"); 
Попытка 
дог=СоздатьОбъект("Справочник.Договоры"); 
исключение 
Предупреждение("В конфигурации нет справочника ДОГОВОРЫ"); 
возврат; 
конецПопытки; 
Спр.ВыбратьЭлементы(); 
Пока спр.ПолучитьЭлемент()=1 Цикл 
Если спр.ЭтоГруппа()=1 Тогда 
продолжить; 
КонецЕсли; 
дог.ИспользоватьВладельца(спр.ТекущийЭлемент()); 
Если дог.НайтиПоНаименованию("СпецДоговор") = 1 тогда
  Сообщить(то что хочешь сообщить);
Иначе 
   дог.Новый(); 
КонецЕсли;
дог.наименование="СпецДоговор"; 
дог.ВидДоговора=глЗначениеПоУмолчанию("ОсновнойВидДоговоров"); 
дог.ОплатаДоговора=1; 
Сообщить("Договор создаётся для контрагента: "+Спр+""); 
дог.записать(); 
конецЦикла; 
конецПроцедуры
   Hardy
 
3 - 29.07.04 - 12:15
(1) Хорошо убрал, скажи пожайлуста как... Очень нужно!
Процедура СоздатьПодчиненныйДоговор() 
Спр=СоздатьОбъект("Справочник.Контрагенты"); 
Спр.ВыбратьЭлементы(); 
Пока спр.ПолучитьЭлемент()=1 Цикл 
Если спр.ЭтоГруппа()=1 Тогда 
продолжить; 
КонецЕсли; 
дог.ИспользоватьВладельца(спр.ТекущийЭлемент()); 
дог.Новый(); 
дог.наименование="СпецДоговор"; 
дог.ВидДоговора=глЗначениеПоУмолчанию("ОсновнойВидДоговоров"); 
дог.ОплатаДоговора=1; 
Сообщить("Договор создаётся для контрагента: "+Спр+""); 
дог.записать(); 
конецЦикла; 
конецПроцедуры
   Hardy
 
4 - 29.07.04 - 12:17
(2) Спасибо!
   Guk
 
5 - 29.07.04 - 12:19
Спр=СоздатьОбъект("Справочник.Контрагенты"); 
Спр.ВыбратьЭлементы(0); 
Пока спр.ПолучитьЭлемент()=1 Цикл 
Если спр.ЭтоГруппа()=1 Тогда 
продолжить; 
КонецЕсли; 
дог.ИспользоватьВладельца(спр.ТекущийЭлемент()); 
Если дог.НайтиПоНаименованию("СпецДоговор",1,1) = 1 тогда 
 Сообщить(то что хочешь сообщить);
Иначе 
  дог.Новый(); 
КонецЕсли; 
дог.наименование="СпецДоговор"; 
дог.ВидДоговора=глЗначениеПоУмолчанию("ОсновнойВидДоговоров"); 
дог.ОплатаДоговора=1; 
Сообщить("Договор создаётся для контрагента: "+Спр+""); 
дог.записать(); 
конецЦикла; 
конецПроцедуры
   Hardy
 
6 - 29.07.04 - 12:27
(5) Спасибо!!! извини что ступил ;)


Список тем форума
 
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует