Вход | Регистрация


1С:Предприятие ::

Метки:документы

заполнение документа

Я
   Tabo
 
28.07.04 - 13:03
Дорогие друзья,
Пишу конфигурацию. Есть справочник Номенклатура, а там уровни.
Проблема:
При заполнении накладной товаром хотелось бы увидеть полностью все конкретные значения уровней, которые я выбрал. Например:

Бумага.Формат-А4.Грам-250ю.Белый

Может кто нибудь поможете.
Спасибо
 
  Рекламное место пустует
   Crew
 
1 - 28.07.04 - 13:07
ПолноеНаименование()
   Gary
 
2 - 28.07.04 - 13:07
Новая колонка в ТЧ документа типа "текст", с вызовом самодельной функции "ВернутьПолноеОписаниеТовара" и обработкой "ПриНачалеВыбораЗначения"
   Vovchik
 
3 - 28.07.04 - 13:11
Пиши функцию:
Функция ПолныйПуть(Товар)
 Перем Имя;
 Имя=Товар.Наименование
 Для Ном=1 По Товар.Уровень() Цикл
  Товар=Товар.Родитель;
  Имя=Товар.Наименование;
 КонецЦикла;
КонецФункции
//писал не отлаживая но можно попробовать
   SnarkHunter
 
4 - 28.07.04 - 13:12
Бред...
   Vovchik
 
5 - 28.07.04 - 13:12
Извиняюсь в коде ошибка
Имя=Имя+"." + Товар.Наименование;
   Vovchik
 
6 - 28.07.04 - 13:13
и
Возврат Имя;
   Vovchik
 
7 - 28.07.04 - 13:13
SnarkHunter
в чем?
   Vovchik
 
8 - 28.07.04 - 13:21
Вот готовое
Функция Имя(Товар)
    Перем Имя; 
    Имя=Товар.Наименование ;
    Для Ном=1 По Товар.Уровень() Цикл 
        Товар=Товар.Родитель; 
         Имя=Товар.Наименование+ "." + Имя; 
    КонецЦикла;
     Возврат Имя;
КонецФункции
//Где Товар ссылка на Номенклатуру
   SnarkHunter
 
9 - 28.07.04 - 13:22
Кое-что исправил... Но не все...
   Crew
 
10 - 28.07.04 - 13:31
(0)
СтрЗаменить(<СтрИсточник>, <СтрПодстрока>, <СтрЗамены>)
Если слеши мешают и нужны точки.
 
  Рекламное место пустует
   Vovchik
 
11 - 28.07.04 - 13:35
Не поял что?
Есть глюк на то что если это верхний уровень все одно выводиться точка
но это исправимо
Функция Имя(Товар) 
   Перем Имя; 
   Имя=Товар.Наименование ; 
   Если Товар.Уровень()=1 Тогда
       Возврат Имя;
   КонецЕСли;
   Для Ном=1 По Товар.Уровень() Цикл 
       Товар=Товар.Родитель; 
       Имя=Товар.Наименование+ "." + Имя; 
   КонецЦикла; 
   Возврат Имя; 
КонецФункции 

вариантов исправления впринципе много
   Vovchik
 
12 - 28.07.04 - 13:38
Да про ПолноеНаименование упустил из виду
как-то не приходилось использовать
:))
   Tabo
 
13 - 28.07.04 - 14:15
Vovchik,

Твой алгоритм не сработал а причину я не нахожу.
   Crew
 
14 - 28.07.04 - 14:28
(13)
Мдя...
СтрПН=Товар.ПолноеНаименование();
СтрПН=СтрЗаменить(Стр,"/",".");
   Vovchik
 
15 - 28.07.04 - 14:46
Tabo, не знаю последнее что выкинул сам просмотрел, работает
   Vovchik
 
16 - 28.07.04 - 14:47
Crew, я понял - из простого сделал сложное
:))
   Crew
 
17 - 28.07.04 - 14:52
(16)
"Все дороги ведут в Рим". Одни дольше другие быстрее ;)
   Vovchik
 
18 - 28.07.04 - 14:55
:))
То же верно
   Tabo
 
20 - 29.07.04 - 12:41
Дорогой Crew
Должен ли я прописать эти строчки в модуле списка справочника а справочник просто подключить к документу?

СтрПН=Товар.ПолноеНаименование(); 
СтрПН=СтрЗаменить(Стр,"/",".");

Спасибо за внимание
   SnarkHunter
 
21 - 29.07.04 - 12:43
»
   Crew
 
22 - 29.07.04 - 12:53
(20)
Если это относится к вопросу (0), то сделай два реквизита в табличной части (1-текстовый, 2-Спр.Номенклатура). 1-й реквизит - можно сделать нередактируемым и вставить в колонку функцию:
СтрЗаменить(Товар.ПолноеНаименование(),"/",".");

P.S. Не называй меня дорогим ;)

(21) Хватит прикалываться, тебя бы так назвали
   SnarkHunter
 
23 - 29.07.04 - 12:57
»
   Crew
 
24 - 29.07.04 - 12:58
»
   Tabo
 
25 - 29.07.04 - 15:33
Если заметили я ко всем обратился как Дорогие Друзья.
А за советы спасибо большое.



Список тем форума
Рекламное место пустует  
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует