Вход | Регистрация

1С:Предприятие ::

Метки:документы

Как в табличной части документа вернуть значение строки?

Я
   Начинающий
26.07.04 - 18:36
Конфигурация ТиС.
Документ "Реализация товара". В табличной части вставил реквизит "Скидка", который,надеюсь, будет высчитывать размер скидки и влиять на цену. Вычисление табличных реквизитов происходит в глобальнике, типа:
  В табличном реквизите стоит формула в свойстве поля ввода (количество):
глПересчетТаблЧасти(Контекст,Форма.ТекущаяКолонка())
 
 
   Матрейя
 
1 - 26.07.04 - 18:50
Формула глПересчетСтроки(Контекст) 

Процедура глПересчетСтроки(Конт) Экспорт
Конт.Цена=Конт.Цена*Конт.Скидка)
КонецПроцедуры
   Матрейя ©
 
2 - 26.07.04 - 18:51
Гы.
   Матрейя
 
3 - 26.07.04 - 18:54
Какая то левая регистрация.
   Матрейя
 
4 - 26.07.04 - 18:55
Все, срочно меняю ник.
   427
 
5 - 26.07.04 - 22:08
Ник Света Семененко давно уже ждет тебя...

Пароль - "qwert"
   Света Семененко
6 - 26.07.04 - 22:37
test
   Матрейя
7 - 27.07.04 - 00:32
5. Ты уже наносился? Нам подержанное не нужно. Так что продолжай пользоваться сам.
   Начинающий
8 - 27.07.04 - 10:30
Вот что нужно было написать вначале:


Конфигурация ТиС.
Документ "Реализация товара". В табличной части вставил
реквизит "Скидка", который,надеюсь, будет высчитывать размер скидки и
влиять на цену. Вычисление табличных реквизитов происходит в глобальнике,
типа:
  В табличном реквизите стоит формула в свойстве поля ввода
(количество):
глПересчетТаблЧасти(Контекст,Форма.ТекущаяКолонка())

Далее в глобальнике есть процедура: Процедура глПересчетТаблЧасти
(Конт,ИмяРеквизита, ПараметрыРозничнойЦены = 0) Экспорт

чуть дальше в этой процедуре:
ИначеЕсли ИмяРеквизита = "Количество" Тогда
      
      Конт.Сумма = Конт.Цена*Конт.Количество-
ПроцентСкидки/100*Конт.Цена*Конт.Количество;
      Если ЕстьНП = 1 Тогда
         глРасчетНалога(Конт,"НП");
      КонецЕсли;
      Если ЕстьНДС = 1 Тогда
         глРасчетНалога(Конт,"НДС");
      КонецЕсли;
     
  ИначеЕсли ИмяРеквизита = "Единица" Тогда  ......И т.д. .

Вставляю в этой процедуре следующие строки:
   ИначеЕсли (ИмяРеквизита = "ВеличинаСкидки") Тогда 
      Конт.Цена=Конт.Цена-Конт.Цена*Конт.ВеличинаСкидки/100;
       Конт.Сумма = Конт.Цена*Конт.Количество;    
   Если ЕстьНП = 1 Тогда
         глРасчетНалога(Конт,"НП");
      КонецЕсли;
      Если ЕстьНДС = 1 Тогда
         глРасчетНалога(Конт,"НДС");
      КонецЕсли;
//***************************************************

Такое вот получается плохое: когда меняю в 1с-складе в документе в
табличной части величину скидки, то в первый раз нормально - цена
изменяется, дальше меняю скидку ещё раз - цена изменяется уже не от
первоначальной, а от той, кторая получилась после изменения.

  Будьте любезны, подскажите, что да как, а?:-)
   Vantala
9 - 27.07.04 - 14:52
Чтобы такого не случалось, храни где-нибудь первоначальное значение цены.
   Композитор
 
10 - 27.07.04 - 14:58
Пример того, как можно работать со скидкой, есть в типовой комплексной. Документы "Завка покупателя", "Реализация" и другие.
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует