Вход | Регистрация

1С:Предприятие ::

Метки:запросы, Запросы и построители

Период в запросе

Я
   sergefox
 
26.07.04 - 12:31
1С 7.7 (dbf)
Есть вот такой запрос:
    ЗапросРасход = СоздатьОбъект("Запрос");
    ТекстЗапросаРасход = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |ТекущийДокумент = Операция.ТекущийДокумент;    
    |ОперДата = Операция.ДатаОперации;
    |Счет = Операция.Кредит.Счет;
    |ТМЦ = Операция.Кредит.ТМЦ;
    |МестаХранения = Операция.Кредит.МестаХранения;    
    |Количество = Операция.Количество;
    |Сумма = Операция.Сумма;
    |Функция СумКво = Сумма(Количество);
    |Группировка ТМЦ без групп;
    |Группировка ТекущийДокумент упорядочить по ТекущийДокумент.ДатаДок без групп;
    |Без итогов;
    |Условие((ТекущийДокумент.Вид()<>""СписаниеТМЦ"") И (ТекущийДокумент.Вид()<>""СписаниеМБП""));";
    Если ПустоеЗначение(Товар) = 0 Тогда
        ТекстЗапросаРасход=ТекстЗапросаРасход+"
        |Условие(ТМЦ=Товар);";
    КонецЕсли;
    Если ПустоеЗначение(Склад) = 0 Тогда
        ТекстЗапросаРасход=ТекстЗапросаРасход+"
        |Условие(МестаХранения=Склад);";
    КонецЕсли;                      
   // Если ошибка в запросе, то выход из процедуры

    Если ЗапросРасход.Выполнить(ТекстЗапросаРасход) = 0 Тогда
        Возврат;
    КонецЕсли;
   ЗапросРасход.Выгрузить(ТЗР,3);
Когда его запускаю на выполнение, в зависимости от значения ВыбНачПериода, отбираются значения за некий произвольный период,
допустим с 30/09/02 по 26/07/04, выбираются значения только по 31/10/02.
В чем прикол?
Как заставить выбирать за весь заданный период?
 
  Рекламное место пустует
   Ninon
 
1 - 26.07.04 - 13:16
Ну, ты уже, наверное, догадался отладчиком пройтись...


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует