Вход | Регистрация


1С:Предприятие ::

Метки:бухгалтерский учет

Выбор плана счетов. v7.7

Я
   Василий
2 - 26.07.04 - 14:09
Запускаем базу в режиме 1с:Предприятие.
Открываем планы счетов: Операции - План счетов.
Вижу перед собой открытый "Основной план" и закладку "Бюджетный план".
Имена планам счетов присвоил сам ("Основной план" и "Бюджетный план").
Как отлавить момент выбора закладки плана счетов ?
Пробовал процедурой ПриВыбореЗакладки(), но результат ноль.

з.ы. Прошу прощения за сумбур в первом вопросе.
   Волшебник
 
5 - 26.07.04 - 18:57
Наверное, никак. В форме списка планов счетов закладки генерируются системой автоматически. Достучаться до них программно не получилось.
При вызове метода Форма.ИспользоватьЗакладки(1) пишет "Закладки уже задействованы".
Метод Форма.ИспользоватьЗакладки(0) игнорируется.

p.s. Переходи на 8.0.
   Press
 
9 - 27.07.04 - 09:42
Попробовал на 21 релизе вроде работает.
Перем ПрошлПлан;
//_____________________________________________________________________________

Функция Тест()  

    ПланСчетов = ТекущийСчет().ПланСчетов().ПорядковыйНомер();  
    
    Если ПланСчетов=0 Тогда
           Возврат \"\";    
    КонецЕсли;
    
    Если ПланСчетов<>ПрошлПлан Тогда
        Сообщить(ПланыСчетов.ЗначениеПоНомеру(ПланСчетов));// Вот здесь то       

                                                        //событие и поймали...

    КонецЕсли;                         
    ПрошлПлан = ПланСчетов;   

       Возврат \"\";    
КонецФункции//Тест

..............................................
ПрошлПлан=1;

На форме, естественно, текст с формулой тест().
   dkuznecov
14 - 27.07.04 - 16:02
Помещаем на форму функцию (текст с формулой Управление())
В модуле пишем:
Функция Управление()
Если ИспользоватьПланСчетов()="Основной" Тогда
Форма.БлаБлаБла.Видимость(0);
КонецЕсли;
Возврат 0;
КонецФункции
   cup of tea
15 - 27.07.04 - 16:03
Может я чего-то не понимаю, но по-моему задача совершенно тривиальная.
Планы Счетов - Формы списка - редактировать ->> в основной форме плана счетов на форму списка нужно разместить текстовую метку с формулой. ИспользоватьПланСчетов() в формуле возвратит значение интерактивно выбранного плана счетов, и в зависимости от выбранного плана можно сделать видимыми те или иные колонки.
   cup of tea
17 - 27.07.04 - 16:07
(14) только не ИспользоватьПланСчетов()="Основной" , а ИспользоватьПланСчетов()=ПланыСчетов.Основной однако... :-)



Список тем форума
  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует