Вход | Регистрация


1С:Предприятие ::

Метки:справочники

не проставляется контрагент в создаваемый программно документ....

Я
   Aiuan
 
25.07.04 - 15:35
сначала пытался найти его по коду, наименованию, реквизитам
КонтрПох = Пост.НайтиПоКоду(5, 0);    
Если Пост.Выбран()>0 Тогда
 ДокНах.Контрагент = КонтрПох;    
КонецЕсли;
Потом добавил на форму выбор контрагента.... выбираю его там... и снова не проставляется в документ
ДокНах.Контрагент    = ВыбКонтрагенты;
где ВыбКонтрагенты выбранное в справочнике значение...
 
  Рекламное место пустует
   Глазья
 
1 - 25.07.04 - 15:37
Добавь Реквизит Дока - "Контрагент", а потом засунь его на форму Дока.
   Aiuan
 
2 - 25.07.04 - 15:40
(1) на доке все есть...
   Глазья
 
2 - 25.07.04 - 15:40
А впервом случае
 
Если Пост.НайтиПоКоду(5, 0)=1      Тогда
   ДокНах.Контрагент = Пост.ТекущийЭлемент();     
КонецЕсли;
   Warlock
 
4 - 25.07.04 - 15:40
(0)Не забыл сделать ДокНах.Записать()?
   427
 
5 - 25.07.04 - 15:44
Похоже на типовые грабли в ТиС...
   Aiuan
 
6 - 25.07.04 - 15:45
(4) после проставления реквизитов и заполнения табличной части
   Aiuan
 
7 - 25.07.04 - 16:09
он не находит элемент в справочнике.... похоже на то.... попробовал Пост.ВыборГруппы(0); фиг...
элемент находится в группе... в таком же случае, но когда справочник без групп элемент находится...
подскажите, что я не правильно сделал....
   Warlock
 
8 - 25.07.04 - 16:14
(7)Пост.НайтиПоКоду(5, 0);
Сообщить(Пост.ТекущийЭлемент());

или посмотри в отладчике - находит или нет.
   NS
 
9 - 25.07.04 - 16:17
Пост.НайтиПоКоду("5");
   Aiuan
 
10 - 25.07.04 - 16:26
Заработало.... спасибо!
Пост.ВыборГруппы(0);
Если  Пост.НайтиПоКоду("00000005", 0)=1 Тогда
  ДокНах.Контрагент    = Пост.ТекущийЭлемент();
 
  Рекламное место пустует
   Warlock
 
11 - 25.07.04 - 16:28
(10)Ну так не "не проставляется контрагент в создаваемый программно документ....", а "не находится контрагент по коду"!
   Глазья
 
12 - 25.07.04 - 16:29
(10) КонецЕсли не забудь поставить... на всякий случай...
   SAS_Chelny
 
13 - 25.07.04 - 16:38
по ходу дело было в нулях кода ?
   NS
 
14 - 25.07.04 - 16:40
(13) По ходу - дело в том, что код всегда текстовый!!!!
То, что в конфигураторе называется числовой - просто запрещает вводить начальные нули и нецифры, но код всё-равно остается текстовым...
   Глазья
 
15 - 25.07.04 - 16:44
(14)NS, ты не прав.
Если код - числовой, прекрасно ишшет по Пост.НайтиПоКоду(5, 0)
Насчет, если код числовой - Пост.НайтиПоКоду("5", 0) - не знаю,не проверял
   NS
 
16 - 25.07.04 - 16:46
(15) Глянь в ДБФ, Сделай запрос и выгрузи в ТЗ...
Код всегда текстовый, просто 5 - будет приведено к "5"....
   Глазья
 
17 - 25.07.04 - 16:50
(16)Щас, гляну...
   SAS_Chelny
 
18 - 25.07.04 - 16:51
По-любому код в кавычках надо писать хоть числовой хоть текстовый
   Warlock
 
19 - 25.07.04 - 16:52
Числовой код работает без кавычек - проверил!
   NS
 
20 - 25.07.04 - 16:54
(19) Работать-то работает - но хранится он в строковом виде...
И ошибки из-за этого постоянно возникают...
   SAS_Chelny
 
21 - 25.07.04 - 16:55
Короче в конфе смотришь тип кода и не паришься
   Глазья
 
22 - 25.07.04 - 16:56
(NS)
Справочник.Разряд - код числовой.
////**********************

// Прекрасно ищет и так

Процедура Сформировать() 
    Спр=СоздатьОбъект("Справочник.Разряд");
    Если Спр.НайтиПоКоду(1,0)=1 Тогда
        стоп=1;
    КонецЕсли;    
КонецПроцедуры
//// и так 

Процедура Сформировать() 
    Спр=СоздатьОбъект("Справочник.Разряд");
    Если Спр.НайтиПоКоду("1",0)=1 Тогда
        стоп=1;
    КонецЕсли;    
КонецПроцедуры
   NS
 
23 - 25.07.04 - 16:58
Еще раз - не надо в конфе смотрать тип кода - проще всегда использовать строку!
(22) Глянь файл 1cv7.dd
Я не говорил, что не найдет, если искать по числу - я сказал, что он текстовый - тип значения в таблице - строка!
   Warlock
 
24 - 25.07.04 - 17:00
Ищет по-любому:
 Спр.НайтиПоКоду("1",0);
 Спр.НайтиПоКоду(" 1",0);
Спр.НайтиПоКоду("  1",0);
Может 1С где-то все-таки приводит к числу, а потом к строке, как в ДБФ?
   SAS_Chelny
 
25 - 25.07.04 - 17:02
А я что в (18) написал не так что ли ?
   Глазья
 
26 - 25.07.04 - 17:05
(23)Лады...:)) Согласен.
   Warlock
 
27 - 25.07.04 - 17:07
(25)Насчет (18) - можно и без кавычек! Насчет (24) наличие пробелов не влияет на результат!
   NS
 
28 - 25.07.04 - 21:12
срочно все провяряем типзначениястр(спр.код);



Список тем форума
Рекламное место пустует   Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует