Вход | Регистрация

1С:Предприятие ::

Метки:Обмен данными и УРБД

Работа с индексами.

Я
   usr088
 
23.07.04 - 18:00
Суть проблемы: из одной ДБФ берутся данные. Из другой таблицы необходимо по этим данным извлечь другие: принцип связи ДБФ-ов один-ко-многим.
Связь надо осуществить с помощью индексов.
У меня получается найти только одну запись (метод НайтиПоКлючу(0)).
Не могу получить остальные.Прилагаю текст проги:

Процедура ПриОткрытии()
    ДБФ1.Перейти(Форма.Параметр);
    Пок=ДБФ1.ПолучитьЗначениеПоля(2);
    Кошель=ДБФ1.ПолучитьЗначениеПоля(6);
    Вал=ДБФ1.ПолучитьЗначениеПоля(4);
    ДБФ2.ТекущийИндекс("IDXBuyCur");
    ДБФ2.Ключ.Buyer=ДБФ1.ПолучитьЗначениеПоля(2);
    ДБФ2.Ключ.Currence=ДБФ1.ПолучитьЗначениеПоля(4);
    Если ДБФ2.НайтиПоКлючу(0)=1 Тогда 
        Пока (ДБФ2.ПолучитьЗначениеПоля(2)=Пок) и (ДБФ2.ПолучитьЗначениеПоля(4)=Вал) Цикл
            ТЗПоиск.НоваяСтрока();
            ТЗПоиск.Дата=ДБФ2.ПолучитьЗначениеПоля(7);
            ТЗПоиск.Номер=ДБФ2.ПолучитьЗначениеПоля(1);
            ТЗПоиск.Контракт=ДБФ2.ПолучитьЗначениеПоля(3);
            Остаток=ДБФ2.ПолучитьЗначениеПоля(6)-ДБФ2.ПолучитьЗначениеПоля(5);
            ТЗПоиск.Осталось=Остаток; 
            ТЗПоиск.Вносим=ДБФ2.ПолучитьЗначениеПоля();
            ДБФ2.Следующая();
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры
 
  Рекламное место пустует
   Valery
 
1 - 23.07.04 - 19:09
Сделай так
Пока (ДБФ2.Поле2=Пок) и (ДБФ2.Поле4=Вал) Цикл


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует