Вход | Регистрация

1С:Предприятие ::

Метки:бухгалтерский учет

Проблема при создании операций обработкой

Я
   Filippych
 
20.07.04 - 15:23
//*******************************************

Ïðîöåäóðà Ñôîðìèðîâàòü()

    Âûãð = ÑîçäàòüÎáúåêò("Òåêñò");

    Âûãð.Îòêðûòü(Ôàéëî);

    Îï = Ñîçäàòüîáúåêò("Îïåðàöèÿ");

    Ôèðìà = ÑîêðËÏ(Âûãð.Ïîëó÷èòüÑòðîêó(1));

    Ôèðìû = ÑîçäàòüÎáúåêò("Ñïðàâî÷íèê.Ôèðìû");

    Åñëè Ôèðìû.ÍàéòèÏîÍàèìåíîâàíèþ(Ôèðìà,0,0) = 0 Òîãäà

        Ôèðìû.Íîâûé();

        Ôèðìû.Íàèìåíîâàíèå = Ôèðìà;

        Ôèðìû.Çàïèñàòü();

    ÊîíåöÅñëè;

    Îï.Íîâàÿ()//

    Îï.ÍîâàÿÏðîâîäêà();

    
    Äëÿ ¸ = 2 ïî Âûãð.Êîëè÷åñòâîÑòðîê() Öèêë

        ñòð = Âûãð.Ïîëó÷èòüÑòðîêó(¸);

        èää = Ëåâ(Ñòð,4);

        äàííûå = Ïðàâ(Ñòð, ÑòðÄëèíà(Ñòð)-4);

        Åñëè (èää = "Îïåð") òîãäà

            Îï.Ôèðìà = Ôèðìû.ÒåêóùèéÝëåìåíò();

            Îï.Çàïèñàòü();

            &#197;&#241;&#235;&#232; &#184; < &#194;&#251;&#227;&#240;.&#202;&#238;&#235;&#232;&#247;&#229;&#241;&#242;&#226;&#238;&#209;&#242;&#240;&#238;&#234;() &#210;&#238;&#227;&#228;&#224;

                &#206;&#239;.&#205;&#238;&#226;&#224;&#255;();

            &#202;&#238;&#237;&#229;&#246;&#197;&#241;&#235;&#232;;

        &#202;&#238;&#237;&#229;&#246;&#197;&#241;&#235;&#232;;

        
        &#197;&#241;&#235;&#232; &#232;&#228;&#228; = "&#196;&#224;&#242;&#224;" &#242;&#238;&#227;&#228;&#224;

            &#206;&#239;.&#196;&#224;&#242;&#224;&#206;&#239;&#229;&#240;&#224;&#246;&#232;&#232; = &#196;&#224;&#242;&#224;(&#196;&#224;&#237;&#237;&#251;&#229;);

        &#202;&#238;&#237;&#229;&#246;&#197;&#241;&#235;&#232;;    

        
        &#197;&#241;&#235;&#232; &#232;&#228;&#228; = "&#207;&#240;&#238;&#226;" &#210;&#238;&#227;&#228;&#224;

            &#206;&#239;.&#205;&#238;&#226;&#224;&#255;&#207;&#240;&#238;&#226;&#238;&#228;&#234;&#224;();

        &#202;&#238;&#237;&#229;&#246;&#197;&#241;&#235;&#232;;

            
        &#197;&#241;&#235;&#232; &#232;&#228;&#228; = "&#209;&#247;_&#196;" &#210;&#238;&#227;&#228;&#224;

            &#206;&#239;.&#196;&#229;&#225;&#229;&#242;.&#209;&#247;&#229;&#242; = &#209;&#247;&#229;&#242;&#207;&#238;&#202;&#238;&#228;&#243;(&#196;&#224;&#237;&#237;&#251;&#229;);

        &#202;&#238;&#237;&#229;&#246;&#197;&#241;&#235;&#232;;
 
 
   Filippych
 
1 - 20.07.04 - 15:24
ни фига себе глюк?
   Filippych
 
2 - 20.07.04 - 15:26
//*******************************************

Процедура Сформировать()
    Выгр = СоздатьОбъект("Текст");
    Выгр.Открыть(Файло);
    Оп = Создатьобъект("Операция");
    Фирма = СокрЛП(Выгр.ПолучитьСтроку(1));
    Фирмы = СоздатьОбъект("Справочник.Фирмы");
    Если Фирмы.НайтиПоНаименованию(Фирма,0,0) = 0 Тогда
        Фирмы.Новый();
        Фирмы.Наименование = Фирма;
        Фирмы.Записать();
    КонецЕсли;
    Оп.Новая()//

    Оп.НоваяПроводка();
    
    Для ё = 2 по Выгр.КоличествоСтрок() Цикл
        стр = Выгр.ПолучитьСтроку(ё);
        идд = Лев(Стр,4);
        данные = Прав(Стр, СтрДлина(Стр)-4);
        Если (идд = "Опер") тогда
            Оп.Фирма = Фирмы.ТекущийЭлемент();
            Оп.Записать();
            Если ё < Выгр.КоличествоСтрок() Тогда
                Оп.Новая();
            КонецЕсли;
        КонецЕсли;
        
        Если идд = "Дата" тогда
            Оп.ДатаОперации = Дата(Данные);
        КонецЕсли;    
        
        Если идд = "Пров" Тогда
            Оп.НоваяПроводка();
        КонецЕсли;
            
        Если идд = "Сч_Д" Тогда
            Оп.Дебет.Счет = СчетПоКоду(Данные);
        КонецЕсли;
        Если идд = "Сч_К" Тогда
            Оп.Кредит.Счет = СчетПоКоду(Данные);
        КонецЕсли;
        Если идд = "Сумм" Тогда
            Оп.Сумма = 100//Число(Данные);

        КонецЕсли;
        
    КонецЦикла;
КонецПроцедуры
   Filippych
 
3 - 20.07.04 - 15:28
Когда происходит запись операции, то выскакивает ошибка:
Оп.Записать();
{C:\WORK\_______\EXTFORMS\ЗАГРУЗКАПРОВОДОК.ERT(23)}: Не указаны счета проводки!(проводка 1)
   It is me
 
4 - 20.07.04 - 15:36
(3) Если я спрошу, что показывает тебе отладчик при вводе первой проводки, это не будет слишком дерзко?
   GrayT
 
5 - 20.07.04 - 15:37
И что тебя удевляет идд равен или "Сч_Д" или "Сч_К", так что один из счетов явно не определен. Для проводок для балансовых счетов - недопустимо
   Filippych
 
6 - 20.07.04 - 15:38
2(3) Показывает, что Счета дебета и кредита, а так же сумма, дата заполненны верно.
   Filippych
 
7 - 20.07.04 - 15:39
(6) к (4), да и к (5) то же
   GrayT
 
8 - 20.07.04 - 15:54
Да, сразу не врубился в построковую загрузку.
Сколько проводок грузишь?
   Filippych
 
9 - 20.07.04 - 16:06
Мо-о-о-о-го, такое впечатление, что проводки в операции теряются когда  делаю Оп.новаяПроводка()
   GrayT
 
10 - 20.07.04 - 16:15
А ты одну загрузи и протрассируй
 
 
   Evgeni01
11 - 20.07.04 - 16:21
Я в нете лазил и вот [url=http://www.hot.ee/besik]сайтик[/url] нашёл, там вроде доступно напсано
   Filippych
 
12 - 20.07.04 - 16:39
Добавил волшебный оператор сообщить:
Если идд = "Сумм" Тогда
  Оп.Сумма = Число(Данные);
  Сообщить(" ");
  Сообщить ("Д"+Оп.Дебет.Счет.Код+" К"+Оп.Кредит.Счет.Код+" "+ Строка(Оп.Сумма));            
КонецЕсли;
Легче не стало:

Д60.2 К51 110

Д60.2 К51 109.78

Д60.2 К51 241.08

Д60.2 К51 361.6

Д60.1 К51 3841

Д60.2 К51 5530.8

Д60.2 К51 5600

Д60.1 К51 5600

Д60.2 К51 11000

Д60.2 К51 11400

Д60.2 К51 30517.16

Д60.1 К51 33958.31

Д60.2 К51 44523.96

Д76.1.1 К51 169619.16

Д60.7 К51 84107.47

Д60.7 К51 287293.71

Д60.1 К51 552960

Д58.3 К51 2000000

Д60.7 К51 253486.88
Оп.Записать();
{C:\WORK\_______\EXTFORMS\ЗАГРУЗКАПРОВОДОК.ERT(24)}: Не указаны счета проводки!(проводка 1)
   Filippych
 
13 - 20.07.04 - 16:56
Если убрать "фирмы" то всё работает, как быть с разделителем учёта?
   Filippych
 
14 - 20.07.04 - 17:02
Всё, разобрался, одна Оп.НоваяПроводка() - лишняя.
   Medved
 
15 - 20.07.04 - 17:03
Эх-хех-хех...
Ну нет у документа "операции" реквизита "Фирма"


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует