Вход | Регистрация


1С:Предприятие ::

Метки:внешние обработки

Как получить имена столбцов реквизитов ?

Я
   Матрейя
18.07.04 - 21:59
Соответствие имен реквизитов в метаданных и идентификаторов столбцов в таблицах. Для получения соответствия имен таблиц давно использовал такой вариант (для реквизитов тогда так ничего и не придумал):
ТС=СоздатьОбъект("Текст");
ТЗОбъектов=СоздатьОбъект("ТаблицаЗначений");
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗОбъектов.НоваяКолонка("Объект");
ТЗОбъектов.НоваяКолонка("ИД");
Попытка
ТС.Открыть(КаталогИБ()+"\1cv7.dd");
Исключение
ТС.Открыть(КаталогИБ()+"\1cv7.dds");    
КонецПопытки;    
Для П1=1 По ТС.КоличествоСтрок() Цикл
ТЗОбъектов.НоваяСтрока();
ТЗОбъектов.Объект=ТС.ПолучитьСтроку(П1);
КонецЦикла;    
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.Загрузить(ТЗОбъектов);
ТЗОбъектов.УдалитьСтроки();
П1=0;
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
П1=П1+1;
Стр=ТЗ.Объект;
Если Лев(Стр,1)="T" Тогда
ТЗОбъектов.НоваяСтрока();    
Стр1=Лев(Стр,10);
ТЗОбъектов.ИД=СокрЛП(Прав(Стр1,СтрДлина(Стр1)-2));
Стр=ТС.ПолучитьСтроку(П1-2);
Стр1=Сред(Стр,21);
ТЗОбъектов.Объект=СокрЛП(Стр1);
КонецЕсли;
КонецЦикла;
ТЗ.Очистить();
Таб.ВывестиСекцию("ЗаголовокТаблицБД");
ТЗОбъектов.ВыбратьСтроки();
Пока ТЗОбъектов.ПолучитьСтроку()=1 Цикл
Таб.ВывестиСекцию("СтрокаТаблицБД");
КонецЦикла;
ТЗОбъектов.Очистить();
КонецЕсли;
 
  Рекламное место пустует
   Матрейя
1 - 18.07.04 - 22:01
Эта тема актуальна для ADO запросов. Пока же приходится устанавливать идентификаторы стобцов визуально.
   Asmody
 
2 - 18.07.04 - 22:02
1C++, радуга...
   Матрейя
3 - 18.07.04 - 22:04
2. Все это понятно, но часто в использовании ВК нет необходимости. Достаточно набора операционной системы.
   Asmody
 
4 - 18.07.04 - 22:08
(3) чего достаточно?
   skunk
 
5 - 18.07.04 - 22:09
я тоже децел не понял
   Матрейя
6 - 18.07.04 - 22:12
4. Для запросов достаточно ADO, для отправки почты cdo и т.д. Та же 1с++ имеет несколько глючных моментов, поэтому ее применение должно быть обосновано реальными потребностями. Если таких серьезных обоснований нет - не вижу смысла использовать столь мощный инструмент вместо надежного как чугун ADO.:)
   Матрейя
7 - 18.07.04 - 22:13
+3.Достаточно набора библиотек операционной системы.
   skunk
 
8 - 18.07.04 - 22:19
стесняюсь спросить, а CDO - это что
   Матрейя
9 - 18.07.04 - 22:23
Поясняю вопрос, если непонятен: Допустим мне нужно сделать выборку из справоника номенклатура-> с помощью алгоритма (0) я получаю физическое имя таблицы, code, descr, id - то же понятно. А вот реквизиты выглядят как Sp133 и т.д. Как получить по имени реквизита в метаданных имя идентификатора столбца таблицы? (типа полнНаименование=sp21)
   Матрейя
10 - 18.07.04 - 22:25
8. Microsoft Collaboration Data Objects. Для создания, отсылки и примема e-mail.
 
  Рекламное место пустует
   Asmody
 
11 - 18.07.04 - 22:34
(10) мхм... а чего не MAPI сразу? >;))
   Asmody
 
12 - 18.07.04 - 22:36
(9) ну тогда тебе нужно писать полноценный DD-парсер. в радуге (и в 1С++) оно уже есть...
   Матрейя
13 - 18.07.04 - 22:41
11. Это для программистов. А менеджеры, как я, используют высокоуровневые интерфейсы.
   Матрейя
14 - 18.07.04 - 22:44
12. Парсить - не проблема. Но я подумал, что может это уже кто-то делал :)
   skunk
 
15 - 18.07.04 - 22:45
ихмо есть более простое решение
Выгрузка таблицы с индентификатором ROW_ID...
   Матрейя
16 - 18.07.04 - 22:52
15. Надо попробывать. Спасибо.
   skunk
 
17 - 18.07.04 - 22:55
(16) наше вам с булочкой
   Матрейя
18 - 18.07.04 - 23:02
После пятничных яиц рыб и этилового спирта ничего есть пока не могу:)
   skunk
 
19 - 18.07.04 - 23:06
везет ;) а я вот тут усилено борюсь с зеленым змием...
   Asmody
 
20 - 18.07.04 - 23:31
(19) и кто побеждает? >;))
   skunk
 
21 - 18.07.04 - 23:33
фих его знает... борьба идет с переменым успехом ;))
   skunk
 
22 - 18.07.04 - 23:36
+21 уже неделю как алкоголь не брал в рот вообще... да и по сравнению с тем что было... когда путылку на грудь, это так в качестве разминки
   Матрейя
23 - 18.07.04 - 23:39
22. Для меня бутылка за короткий период - это верная смерть:)
   skunk
 
24 - 18.07.04 - 23:53
кто на что учился... хотя...
   427
 
25 - 19.07.04 - 06:52
Нда... 1с-программистка в (0) - это морская свинка ...



Список тем форума
Рекламное место пустует  
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует