Вход | Регистрация

1С:Предприятие ::

Метки:Обмен данными и УРБД

Туплю с загрузкой

Я
   MaxMaster
 
18.07.04 - 13:43
Гружу накладную из ДБФ. Смысл такой, что если номенклатуру не находит, то создает, есть в файле какое поле как код группы которой принадлежит номенклатура. Видимо где-то переклинило ни как не могу сообразить как заисать именно в эту группу. Подскажите, пожалуйста.
 
 
   dkuznecov
1 - 18.07.04 - 13:48
Спр.Родитель = НужнаяГруппа;
   dkuznecov
2 - 18.07.04 - 13:48
Спр.Родитель = НужнаяГруппа;
   NS
 
3 - 18.07.04 - 13:49
КодГруппы=Дбф.Rod;
КодЭлемента=Дбф.Kod;
Этогруппа=ДБФ.isGrup;
Если спр.НайтиПоКоду(КодЭлемента)=0 Тогда
 Если спр.найтипокоду(КодГруппы)=0 Тогда
    род="";
 Иначе
    род=спр.текущийЭлемент();
КонецЕсли;
если Этогруппа=1 тогда
   спр.новаягруппа();
иначе
   спр.новый();
КонецЕсли;
спр.Родитель=род;
спр.Записать();
   Матрейя
4 - 18.07.04 - 13:49
Спр.НайтиПоКоду(КодГруппы);
ТекРод=Спр.ТекущийЭлемент();
Спр.Новый();
Спр.Родитель=ТекРод;

Хотя у меня сомнения по поводу рациональности структуры dbf файла.
   NS
 
5 - 18.07.04 - 13:50
в конце еще КонецЕсли;
   MaxMaster
 
6 - 18.07.04 - 13:53
Я меня так и написано, выплевывет, говорит
{Обработка.ЗагрузкаДок.Форма.Модуль(117)}: Поле агрегатного объекта не обнаружено (Родитель)
   NS
 
7 - 18.07.04 - 13:55
Так, это как?
Код в студию...
   NS
 
8 - 18.07.04 - 13:55
Может справочник одноуровневый?
   MaxMaster
 
9 - 18.07.04 - 13:57
Арт=Дбф.ПолучитьЗначениеПоля("NOMENKL_ID"); 
                Номенкл=Дбф.ПолучитьЗначениеПоля("NOMENKL_N");
                ПапаНоменкл =   Дбф.ПолучитьЗначениеПоля("Flag2");
                Номенклатура=СоздатьОбъект("Справочник.Номенклатура"); 
                Если Номенклатура.НайтиПоРеквизиту("Артикул",""+СокрЛП(ДБФ.NOMENKL_ID),1)=0 тогда 
                    Номенклатура.НайтиПоКоду(СокрЛП(ПапаНоменкл)); 
                    ГруппаНайденная=Номенклатура.ТекущийЭлемент();
                    Номенклатура.Родитель=ГруппаНайденная;
                    Номенклатура.Новый();
                    Номенклатура.Артикул=Арт;     
                    Номенклатура.Наименование=Номенкл;     
                    Номенклатура.Записать();
                КонецЕсли;
   NS
 
10 - 18.07.04 - 14:01
ГруппаНайденная=Номенклатура.ТекущийЭлемент(); 
Номенклатура.Новай;//!!!!!!!!!

                   Номенклатура.Родитель=ГруппаНайденная; 
                  //Номенклатура.Новый(); 

// Кому интересно ты родителя решил присвоить???                   
Номенклатура.Артикул=Арт;
 
  Рекламное место пустует
   NS
 
11 - 18.07.04 - 14:02
ГруппаНайденная=Номенклатура.ТекущийЭлемент(); 
Номенклатура.Новый();//!!!!!!!!! 

Номенклатура.Родитель=ГруппаНайденная; 
//Номенклатура.Новый(); 

// Кому интересно ты родителя решил присвоить???                   
Номенклатура.Артикул=Арт; 
//Извиняюсь... рука бойца колоть устала ;-)
   MaxMaster
 
12 - 18.07.04 - 14:08
Она материться перестала, но рузит все равно в корень?

У меня код грппы в ДБФ без нулей в переди, а в базе с нулями может из-за этого
   NS
 
13 - 18.07.04 - 14:11
(12)
ГруппаНайденная=Номенклатура.ТекущийЭлемент(); 
сообщить(ГруппаНайденная);
Номенклатура.Новый();//!!!!!!!!! 

Номенклатура.Родитель=ГруппаНайденная;                  
Номенклатура.Артикул=Арт;
/////// 

Номенклатура.НайтиПоКоду(прав("000000000000"+СокрЛП(ПапаНоменкл),ДлинаКодаВБазеПриемнике));
   MaxMaster
 
14 - 18.07.04 - 14:13
точно из-за нулей!!!!

ВСЕМ ОГРОМНОЕ СПАСИБО!!! NS С МЕНЯ ПИВО!!!!!!!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует