Вход | Регистрация

1С:Предприятие ::

Метки:

Нельзя изменять поле, содержащее объект данных формы

Я
   Azgerd
 
05.04.13 - 13:50
При выполнении на сервере следующего кода появляется ошибка:
Нельзя изменять поле, содержащее объект данных формы
На строке - Объект = РезультатПоиска.ПолучитьОбъект();
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
              |    МойСправочник.Ссылка,
              |МойСправочник.Владелец,
          |МойСправочник.Код,
              |МойСправочник.НомерЛицензии,
              |МойСправочник.ДатаЛицензии,
              |Из
              |Справочник.МойСправочник КАК МойСправочник";
        РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
             КодЗп = Выборка.Код;
             НомЛиц =Выброка.НомерЛицензии;
             ДвтЛиц = Выборка.ДатаЛицензии;
             ВыборкаСпр = Справочники.МойСправочник.Выбрать();
             Пока ВыборкаСпр.Следующий() Цикл
                  Если ВыборкаСпр.НомерЛицензии = НомЛиц Тогда
                      РП=Справочники.МойСправочник.НайтиПоКоду(КодЗп);
                      Объект=РП.ПолучитьОбъект();
                      НовСтрока=Объект.Подсистемы.Добавить();
                      НовСтрока.Дата=ДатЛиц;
                  КонецЕсли;               
             КонецЦикла;
        КонецЦикла; 
Из-за чего возникает ошибка?
1
2
3
 
 
   rutony
 
1 - 05.04.13 - 13:52
(0) Делай проверку сначало
РП=Справочники.МойСправочник.НайтиПоКоду(КодЗп);
Если Не РП.Пустой() Тогда
    Объект=РП.ПолучитьОбъект();
КонецЕсли;
4
   rutony
 
2 - 05.04.13 - 13:53
(0) Если справочник не будет найден, там будет сидеть пустая ссылка
4
   sapphire
 
3 - 05.04.13 - 13:54
(0)
Объект=РП.ПолучитьОбъект();// вот здеся...
 
НовСтрока=Объект.Подсистемы.Добавить();
НовСтрока.Дата=ДатЛиц;
   sapphire
 
4 - 05.04.13 - 13:55
(1) (2) Не неси пургу, просто переменную надо обозвать иначе.
   Azgerd
 
5 - 05.04.13 - 13:57
На самом деле я делаю проверку "Если Не РП.Пустой() Тогда"  просто в тексте вопроса я её пропустил.
6
   Infsams654
 
6 - 05.04.13 - 14:28
(5) Форма обычная ? не может быть что управляемая...
   Azgerd
 
7 - 05.04.13 - 15:15
Форма управляемая.
   Azgerd
 
8 - 05.04.13 - 16:26
sapphire Спасибо! Хотя не сразу въехал какую переменную ты имел ввиду.
Вместо Объект=РП.ПолучитьОбъект()
сделал ППОбъект=РП.ПолучитьОбъект() и ошибка пропала!

 
Список тем форума

 
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.