Вход | Регистрация

1С:Предприятие ::

Метки:документы

ввод на основание (перенос из табличной части в обычную и наоборот)

Я
   Lem
 
16.07.04 - 15:52
Почему не заполняются поля но основании одного документа (табличной части) в другой (обычной)?
И как сделать так чтобы из одного документа (табличной части) брались часть данных первой строки и часть второй и переносились в табличноу часть первой строки другого документа?

PS Таблицы обоих документов заполняются с помощью массивов.
 
  Рекламное место пустует
   3V
 
1 - 16.07.04 - 15:56
распиши структуру табличных частей обоих доков
   laeg
 
2 - 16.07.04 - 16:06
Так ты покажи как ты заполняешь один Док на Основании другого и мы скажем в чом твоя проблема ...
А то иди не знаю куда и принеси мне то не знаю чего ...
   Salimbek
2 - 16.07.04 - 16:06
(0)А в чем проблема?
ДокОсн.ВыбратьСтроки();
Счетчик=1;
Пока ДокОсн.ПолучитьСтроку()=1 Цикл
  Если Счетчик=1 Тогда
    Счетчик=2;
    ВзятьПервуюЧастьСтроки();
  Иначе
    Счетчик=1;
    ВзятьВторуюЧастьСтроки();
    СоздатьИзЭтихДвухЧастейЧтоНужно();
    НоваяСтрока();
    ЗаписатьПолученныеЗначенияВНашДокумент();
КонецЦикла;
   Lem
 
4 - 16.07.04 - 16:21
Laeg в томто и дело что не знаю как это делать а так ка обычно

водитель=докосн.водитель;
прицеп=докосн.прицеп;
авто=докосн.авто;
пробовал так еще адреспогрузки[1]=докосн.адресразгруски[2];
заказчик[1]=докосн.заказчик;  
но так не получается



Salimbek спасибо попробую :)
Если есть идеи пишите :).
   laeg
 
5 - 16.07.04 - 16:31
водитель, прицеп, авто - Это у тебя реквизиты Шапки или Табличной части ?
   Lem
 
6 - 16.07.04 - 16:37
водитель, прицеп, авто  - шапка

заказчик в первом документе шапка во втором табличная
   Salimbek
7 - 16.07.04 - 16:42
В (2) перед КонецЦикла надо добавить КонецЕсли; а что у тебя в квадратных скобках в(4)? Номер строки?
   Lem
 
8 - 16.07.04 - 16:45
табличная часть заплняется с помощью массива
т.е. я пытаюсь например из 2 строки 1 столбца перегнать в другой документ в табличную часть в 1 строку 2 столбца
   laeg
 
9 - 16.07.04 - 16:50
С Шапкой все ясно, думаю ты разобрался ...
Для табличной части нудно немного похитрее тебе ...
тбл = СоздатьОбъект("Таблица.Значений");
ДокОсн.ВыгрузитьТабличнуюЧасть(тбл);

НоваяСтрока();
Заказчик = Тбл.ПолучитьЗначение(1,"Заказчик")
Подрядчик = Тбл.ПолучитьЗначение(2,"Подрядчик")

Типа того что я тебе написал, посмотри мануал по методам, ни чего сложного нету.
   Рупор абсурда
10 - 16.07.04 - 16:51
А что такое "обычная" часть документа?
 
 


Список тем форума
Рекламное место пустует   Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует