Вход | Регистрация

1С:Предприятие ::

Метки:документы

Возможно ли изменить панель инструментов для расходной накладной

Я
   Appon
 
14.07.04 - 13:49
Возможно ли изменить панель инструментов для расходной накладной.Конкретно интересует запрет копирования накладной. Ситуация такова. Написал я обработку автора накладной и соответственно запрет на открытие, тому кто не являеться автором.Но народ догадался что при копирование накладной ты становишься ее автором. Соответственно и просмотр возможен. Помогите кто может
 
  Рекламное место пустует
   Warlock_old
 
1 - 14.07.04 - 14:04
Беда не в панели инструментов (есть еще кнопка F9 для копирования).
Это тебе поможет:

Процедура ВводНового(ПризнКопирования)
   Если ПризнКопирования = 1 Тогда
      СтатусВозврата(0);
   КонецЕсли;
КонецПроцедуры
   At
 
4 - 14.07.04 - 14:24
Процедура ВводНового(<?>,)
КонецПроцедуры
Синтаксис:
ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
Назначение:
Предопределенная процедура при интерактивном вводе нового документа.
Параметры:
<ПризнКопирования> - признак того, что объект введен копированием. Число: 1 - объект введен копированием, 0 - просто новый объект. Данный признак может быть использован для анализа необходимости инициализации реквизитов нового объекта.
<ОбъектКопирования> - объект, который был скопирован.
Замечание:
Данная процедура может располагаться только в модуле формы документа.


Список тем форума
 
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует