Вход | Регистрация

1С:Предприятие ::

Метки:документы

Возможно ли изменить панель инструментов для расходной накладной

Я
   Appon
 
14.07.04 - 13:49
Возможно ли изменить панель инструментов для расходной накладной.Конкретно интересует запрет копирования накладной. Ситуация такова. Написал я обработку автора накладной и соответственно запрет на открытие, тому кто не являеться автором.Но народ догадался что при копирование накладной ты становишься ее автором. Соответственно и просмотр возможен. Помогите кто может
 
  Рекламное место пустует
   Warlock_old
 
1 - 14.07.04 - 14:04
Беда не в панели инструментов (есть еще кнопка F9 для копирования).
Это тебе поможет:

Процедура ВводНового(ПризнКопирования)
   Если ПризнКопирования = 1 Тогда
      СтатусВозврата(0);
   КонецЕсли;
КонецПроцедуры
   clg
2 - 14.07.04 - 14:05
Можно отслеживать копирование в процедуре ВводНового()
   Appon
 
3 - 14.07.04 - 14:07
А что значит признак копирования.Ну для общего развития
   At
 
4 - 14.07.04 - 14:24
Процедура ВводНового(<?>,)
КонецПроцедуры
Синтаксис:
ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
Назначение:
Предопределенная процедура при интерактивном вводе нового документа.
Параметры:
<ПризнКопирования> - признак того, что объект введен копированием. Число: 1 - объект введен копированием, 0 - просто новый объект. Данный признак может быть использован для анализа необходимости инициализации реквизитов нового объекта.
<ОбъектКопирования> - объект, который был скопирован.
Замечание:
Данная процедура может располагаться только в модуле формы документа.
   Warlock
 
5 - 14.07.04 - 14:26
(3)Смотри (4), а на будущее - синтаксис-помощник!
   Appon
 
6 - 14.07.04 - 14:33
Огромное всем спасибо.Не перестаю удивляться этому форуму. Каждый раз получаю действительно ответ на вопрос.А не нравоучения по поводу не далекости в 1с.
   Композитор
 
7 - 14.07.04 - 15:04
(6) Удачное время выбираете. Обеденное. Нравоучители кушают.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует