Вход | Регистрация

1С:Предприятие ::

Метки:бухгалтерский учет, Запросы и построители

БухИтоги и Запрос

Я
   Денис
08.07.04 - 10:37
Необходимо получить бух. результаты стандартным текстовым запросом.
Обычным
Есть небольшая проблема. Для понятности приведу текст модуля.

.........
|Период с Дата1 по Дата2;
|СчЗапр = Операция.Счет;
|Абонент = Операция.Субконто.Абонент; 
|Сумма = Операция.Сумма;
|Функция ОборотДО = ДО(Сумма);
|Группировка СчЗапр Все; 
|Группировка Абонент;
|";

.......

Пока ЗапросСКЛ.Группировка(1)=1 Цикл
     Состояние("Обрабатывается счет: "+СокрЛП(ЗапросСКЛ.СчЗапр));
              Если ЗапросСКЛ.СчЗапр=СчетПоКоду("60") Тогда
                   Пока ЗапросСКЛ.Группировка(2)=1 Цикл
///НЕ ЗАХОДИТ           Сообщить("Траливали");

                   КонецЦикла;
              ИначеЕсли ЗапросСКЛ.СчЗапр=СчетПоКоду("60.1") Тогда
                   Пока ЗапросСКЛ.Группировка(2)=1 Цикл
///ЗАХОДИТ              Сообщить("Траливали");

                   КонецЦикла;                   
              КонецЕсли;
КонецЦикла;
 
  Рекламное место пустует
   GrayT
 
1 - 08.07.04 - 10:51
Ни когда не работал не Бух запросом с Бух итогами, и слышал что криво это.
Ну если "Необходимо получить бух. результаты стандартным текстовым запросом.." попробуй выгрузить в ТЗ и посмотреть что там у тебя
   Crystalizer
 
2 - 08.07.04 - 10:52
дык... видимо выбираются не те счета что ты предпологаешь

в частности 60 не выбирается
60.1 выбирается
   Crystalizer
 
3 - 08.07.04 - 10:54
действительно
сделай

запрос.выгрузить(табл_знач);
табл_знач.выбратьстроку();
   GrayT
 
4 - 08.07.04 - 11:01
В счет группу он явно не зайдет, но вообще все криво - делается бух итогами в режиме запроса
   Денис
5 - 08.07.04 - 11:02
В ТЗ выгружает по 60 счет-группе только итоговые суммы по счету. А по субсчетам (60.1,60.2) - как полагается: суммы по субконто и итоговая сумма в конце группировки. Как построить запрос, чтобы в группировку по счетуг-руппе попадали субконто? Вот в чем вопрос :-)
   Денис
6 - 08.07.04 - 11:07
Я делаю так, потому что мне надо выполнить запрос только по списку субконто (СписокЗначений).
ИспользоватьСубконто(<ВидСубконто>,СписокЗначений) - отлично работает на DBF базе, а на SQL - в 20 дольше, а на некоторых базах - совсем зависает. А обычным запрос все работает очень быстро.....
   GrayT
 
7 - 08.07.04 - 11:20
Про SQL не знаю, не работал. Думаю обычным запросом через операцию значения субконто по счету группе ты не получишь (в операции этого просто нет) (имхо)
   427
 
8 - 08.07.04 - 20:16
Вполне исповедимы пути одноЭсовцев - все, что можно и нельзя, надо делать через жЁппу...


Список тем форума
  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует