Вход | Регистрация

1С:Предприятие ::

Метки:отчеты

Как добавить в отчет кн покупок/продаж какой выпиской закрылась запись?!

Я
   Андрей
07.07.04 - 11:38
Как добавить в отчет кн покупок/продаж какой выпиской закрылась запись книги?! У меня бухи наработали полгода , а всплыло только счас
, нужен номер и дата выписки напротив каждой записи книги.Помогите...
Пока незнаю как сделать... Буду очень благодарен !
 
  Рекламное место пустует
   Виктор
1 - 09.07.04 - 02:29
Какая конфигурация стоит? Я так понял типовая бухгалтерская!
Вообще такое сделать можно (если очень хочется то можно) в книге покупок, при условии если в документе выписки, в поле документ поставки он указан (если не указан, тогда никак). Тогда в самом отчете прописать при выборе документов записей в книгу покупок:

НужныйДокумент = ДокАвто.ДокументОснование;
ДокВыписка=СоздатьОбъект("Документ.Выписка");
ДокВыписка.ВыбратьДокументы(ДатаНачала,ДатаКонца);
Пока ДокВыписка.ПолучитьДокумент()=1 Цикл
    НомерИДатаВыписки="";
    ВыпискаНайдена=0;
    ТекВыписка=ДокВыписка.ТекущийДокумент();
    ТекВыписка.ВыбратьСтроки();
    Пока ТекВыписка.ПолучитьСтроку()=1 Цикл
        Если ТекВыписка.ДокументПоставки=НужныйДокумент Тогда
            НомерИДатаВыписки="Выписка № "+СокрЛП(ТекВыписка.НомерДок)+" от "+ТекВыписка.ДатаДок;
           //Соответственно <НомерИДатаВыписки> вписать в отчет

           ВыпискаНайдена=1;
           Прервать;
        КонецЕсли;
    КонецЦикла;
    Если ВыпискаНайдена=1 Тогда
        Прервать;
    КонецЕсли;
КонецЦикла;

Код не проверял, должно сработать...
На счет книги продаж по идее тоже самое только код надо немного поменять.
Если я правильно понял вопрос, то это должно помочь :)
А вообще продумывать нужно все заранее...
   Андрей
2 - 09.07.04 - 04:48
Спасибо большое за помощь, но бухи оказывается не заполняют поле документ поставки.........собаки серые...
Виктор, а как еще можно?....
   427
 
3 - 09.07.04 - 07:31
Достоверно сказать по имеющейся в типовой информации - НИКАК
   Виктор
4 - 09.07.04 - 10:15
Ну а больше по моему никак...
По идее связей между записями в кн.пок./кн.прод. и выписками НЕТ...
(последний вариант проставить эти документы поставки, но я так понял Вым нужно быстро тагда точно НИКАК...)
   Crew
 
5 - 09.07.04 - 10:41
(2)
Можно, но только частично. Если сумма поставки/покупки была оплачена/получена полностью, т.е. суммы должны совпадать (если оплата была частями, то все равно можно попробовать определить, если данная коммерческая операция закрылась полностью, т.е. сумма оплат = сумме накладной).
Но, в конце концов, я сделал расшифровки в печатной форме книги продаж/покупок, т.е. при двойном щелчке на строку таблицы открывается карточка счета с выбранным контрагентом.

В общем дальше думай сам (можно сделать, чтобы при дв.щелчке на строку таблицы формировалась ТЗ с выписками по данному контрагенту, затем бухгалтер чистит ее и передает данные о выписках обратно в печатную форму)

Все это гемор, но сделать можно ;) если очень нужно.

P.S. я в свое время сделал


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует